summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-10-17 18:37:56 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-10-17 18:37:56 +0000
commita4c0bdd796102212928ac3f2e239c8f0eca3dd6a (patch)
tree42f13e36b7925a8842f238666c479e1967cc464c /net-misc/gnomba
parentkeyword (diff)
downloadgentoo-2-a4c0bdd796102212928ac3f2e239c8f0eca3dd6a.tar.gz
gentoo-2-a4c0bdd796102212928ac3f2e239c8f0eca3dd6a.tar.bz2
gentoo-2-a4c0bdd796102212928ac3f2e239c8f0eca3dd6a.zip
ebuild overhaul from Sven Wegener <swegener@gentoo.org> (#38279)
Diffstat (limited to 'net-misc/gnomba')
-rw-r--r--net-misc/gnomba/ChangeLog8
-rw-r--r--net-misc/gnomba/Manifest4
-rw-r--r--net-misc/gnomba/files/digest-gnomba-0.6.2-r11
-rw-r--r--net-misc/gnomba/gnomba-0.6.2-r1.ebuild36
-rw-r--r--net-misc/gnomba/metadata.xml5
5 files changed, 52 insertions, 2 deletions
diff --git a/net-misc/gnomba/ChangeLog b/net-misc/gnomba/ChangeLog
index 2bf9f7bb7067..5745cda0f19f 100644
--- a/net-misc/gnomba/ChangeLog
+++ b/net-misc/gnomba/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/gnomba
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/gnomba/ChangeLog,v 1.10 2004/07/01 21:02:53 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gnomba/ChangeLog,v 1.11 2004/10/17 18:37:56 liquidx Exp $
+
+*gnomba-0.6.2-r1 (17 Oct 2004)
+
+ 17 Oct 2004; Alastair Tse <liquidx@gentoo.org> +metadata.xml,
+ +gnomba-0.6.2-r1.ebuild:
+ ebuild overhaul from Sven Wegener <swegener@gentoo.org> (#38279)
01 Jul 2004; Jon Hood <squinky86@gentoo.org> gnomba-0.6.2.ebuild:
change virtual/glibc to virtual/libc
diff --git a/net-misc/gnomba/Manifest b/net-misc/gnomba/Manifest
index 4fce3ba452f5..09e42e721fb9 100644
--- a/net-misc/gnomba/Manifest
+++ b/net-misc/gnomba/Manifest
@@ -1,3 +1,5 @@
-MD5 2172ae164f492fe0967e80b58927c768 gnomba-0.6.2.ebuild 897
MD5 06e630958efbcfda0e3d27f641bf8641 ChangeLog 1295
+MD5 c4d4fa173f07c56f372d8be9aff654ac gnomba-0.6.2-r1.ebuild 1074
+MD5 2172ae164f492fe0967e80b58927c768 gnomba-0.6.2.ebuild 897
MD5 900ccd7d2abcc3d34cc0858830561440 files/digest-gnomba-0.6.2 64
+MD5 900ccd7d2abcc3d34cc0858830561440 files/digest-gnomba-0.6.2-r1 64
diff --git a/net-misc/gnomba/files/digest-gnomba-0.6.2-r1 b/net-misc/gnomba/files/digest-gnomba-0.6.2-r1
new file mode 100644
index 000000000000..5b9e90cf5595
--- /dev/null
+++ b/net-misc/gnomba/files/digest-gnomba-0.6.2-r1
@@ -0,0 +1 @@
+MD5 698c40d2755c5b0d467e4de2f2119c0c gnomba-0.6.2.tar.gz 556655
diff --git a/net-misc/gnomba/gnomba-0.6.2-r1.ebuild b/net-misc/gnomba/gnomba-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..9f809cdce785
--- /dev/null
+++ b/net-misc/gnomba/gnomba-0.6.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gnomba/gnomba-0.6.2-r1.ebuild,v 1.1 2004/10/17 18:37:56 liquidx Exp $
+
+inherit eutils
+
+DESCRIPTION="Gnome Samba Browser"
+SRC_URI="http://gnomba.sourceforge.net/src/${P}.tar.gz"
+HOMEPAGE="http://gnomba.sourceforge.net/"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc"
+SLOT="0"
+
+IUSE="debug nls"
+DEPEND="gnome-base/gnome-libs"
+
+src_compile() {
+ econf `use_enable debug` || die "econf failed"
+ # We touch the Makefile here, because the configure script
+ # touches Makefile.in and we want to avoid the recreation
+ touch Makefile
+ emake \
+ CODEPAGEDIR=/var/lib/samba/codepages \
+ LMHOSTSFILE=/etc/samba/lmhosts \
+ SMB_PASSWD_FILE=/etc/samba/private/smbpasswd \
+ PASSWD_PROGRAM=/usr/bin/passwd \
+ DRIVERFILE=/etc/samba/printers.def \
+ || die "emake failed"
+}
+
+src_install() {
+ edos2unix gnomba.desktop
+
+ einstall || die "einstall failed"
+ dodoc AUTHORS BUGS COPYING ChangeLog HACKING INSTALL NEWS README TODO
+}
diff --git a/net-misc/gnomba/metadata.xml b/net-misc/gnomba/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/net-misc/gnomba/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>