summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-02-17 20:15:31 +0000
committerJeroen Roovers <jer@gentoo.org>2010-02-17 20:15:31 +0000
commit03a658ba185a54de3b2340a663b46b1ded258c03 (patch)
treef2afd3e1a661589685de70a01083554c74920f63 /net-misc/gsasl
parentfix #305527 (diff)
downloadgentoo-2-03a658ba185a54de3b2340a663b46b1ded258c03.tar.gz
gentoo-2-03a658ba185a54de3b2340a663b46b1ded258c03.tar.bz2
gentoo-2-03a658ba185a54de3b2340a663b46b1ded258c03.zip
Version bump
(bug #300551). Have SRC_URI use mirror://gnu. Do not hardcode package name in SRC_URI. (Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'net-misc/gsasl')
-rw-r--r--net-misc/gsasl/ChangeLog11
-rw-r--r--net-misc/gsasl/gsasl-1.1.ebuild4
-rw-r--r--net-misc/gsasl/gsasl-1.4.1.ebuild42
3 files changed, 54 insertions, 3 deletions
diff --git a/net-misc/gsasl/ChangeLog b/net-misc/gsasl/ChangeLog
index 88ce87337e00..8d8cba6c545e 100644
--- a/net-misc/gsasl/ChangeLog
+++ b/net-misc/gsasl/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-misc/gsasl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/gsasl/ChangeLog,v 1.32 2010/01/07 15:47:25 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gsasl/ChangeLog,v 1.33 2010/02/17 20:15:31 jer Exp $
+
+*gsasl-1.4.1 (17 Feb 2010)
+
+ 17 Feb 2010; Jeroen Roovers <jer@gentoo.org> gsasl-1.1.ebuild,
+ +gsasl-1.4.1.ebuild:
+ Version bump
+
+ (bug #300551). Have SRC_URI use mirror://gnu. Do not hardcode package name
+ in SRC_URI.
07 Jan 2010; Christian Faulhammer <fauli@gentoo.org> gsasl-1.1.ebuild:
Transfer Prefix keywords
diff --git a/net-misc/gsasl/gsasl-1.1.ebuild b/net-misc/gsasl/gsasl-1.1.ebuild
index d8f65d42db01..3210c0ed3d18 100644
--- a/net-misc/gsasl/gsasl-1.1.ebuild
+++ b/net-misc/gsasl/gsasl-1.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/gsasl/gsasl-1.1.ebuild,v 1.2 2010/01/07 15:47:25 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gsasl/gsasl-1.1.ebuild,v 1.3 2010/02/17 20:15:31 jer Exp $
DESCRIPTION="The GNU SASL client, server, and library"
HOMEPAGE="http://www.gnu.org/software/gsasl/"
-SRC_URI="ftp://ftp.gnu.org/pub/gnu/gsasl/${P}.tar.gz"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
# TODO: check http://www.gnu.org/software/gsasl/#dependencies for more
diff --git a/net-misc/gsasl/gsasl-1.4.1.ebuild b/net-misc/gsasl/gsasl-1.4.1.ebuild
new file mode 100644
index 000000000000..c539b02fe399
--- /dev/null
+++ b/net-misc/gsasl/gsasl-1.4.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gsasl/gsasl-1.4.1.ebuild,v 1.1 2010/02/17 20:15:31 jer Exp $
+
+DESCRIPTION="The GNU SASL client, server, and library"
+HOMEPAGE="http://www.gnu.org/software/gsasl/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+# TODO: check http://www.gnu.org/software/gsasl/#dependencies for more
+# optional external libraries.
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="kerberos nls static doc"
+PROVIDE="virtual/gsasl"
+DEPEND="nls? ( sys-devel/gettext )
+ kerberos? ( virtual/krb5 )"
+RDEPEND="${DEPEND}
+ !virtual/gsasl"
+
+src_compile() {
+ econf \
+ --enable-client \
+ --enable-server \
+ $(use_enable kerberos gssapi) \
+ $(use_enable nls) \
+ $(use_enable static) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "einstall failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+ doman doc/gsasl.1
+
+ if use doc; then
+ dodoc doc/*.{eps,ps,pdf}
+ dohtml doc/*.html
+ docinto examples
+ dodoc examples/*.c
+ fi
+}