summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-07-21 16:18:17 +0000
committerPacho Ramos <pacho@gentoo.org>2012-07-21 16:18:17 +0000
commit6577266c4e7e281347d72d18ccdef7d91baeb7f2 (patch)
treeccbbf52765b3e7e0838c08fc14faede983a7af52 /net-misc/gwget
parentUse proper jdk slots to build, bug #422603 by Ralph Sennhauser. (diff)
downloadgentoo-2-6577266c4e7e281347d72d18ccdef7d91baeb7f2.tar.gz
gentoo-2-6577266c4e7e281347d72d18ccdef7d91baeb7f2.tar.bz2
gentoo-2-6577266c4e7e281347d72d18ccdef7d91baeb7f2.zip
Let it compile against glib-2.32
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/gwget')
-rw-r--r--net-misc/gwget/ChangeLog7
-rw-r--r--net-misc/gwget/files/gwget-1.0.4-glib-single-include.patch13
-rw-r--r--net-misc/gwget/gwget-1.0.4.ebuild13
3 files changed, 24 insertions, 9 deletions
diff --git a/net-misc/gwget/ChangeLog b/net-misc/gwget/ChangeLog
index 60d5c01f0ae6..bd64fccb05ce 100644
--- a/net-misc/gwget/ChangeLog
+++ b/net-misc/gwget/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/gwget
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/gwget/ChangeLog,v 1.26 2012/05/05 03:20:43 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gwget/ChangeLog,v 1.27 2012/07/21 16:18:17 pacho Exp $
+
+ 21 Jul 2012; Pacho Ramos <pacho@gentoo.org>
+ +files/gwget-1.0.4-glib-single-include.patch, gwget-1.0.4.ebuild:
+ Let it compile against glib-2.32
05 May 2012; Jeff Horelick <jdhore@gentoo.org> gwget-1.0.4.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
@@ -160,4 +164,3 @@
13 Aug 2003; Mike Gardiner <obz@gentoo.org> gwget2-0.5.ebuild:
New package. Thanks to Jose Romildo Malaquias (romildo@iber.com.br). See bug
#18255
-
diff --git a/net-misc/gwget/files/gwget-1.0.4-glib-single-include.patch b/net-misc/gwget/files/gwget-1.0.4-glib-single-include.patch
new file mode 100644
index 000000000000..a5cf4ee995bc
--- /dev/null
+++ b/net-misc/gwget/files/gwget-1.0.4-glib-single-include.patch
@@ -0,0 +1,13 @@
+Index: gwget-1.0.4/src/gwget-application.h
+===================================================================
+--- gwget-1.0.4.orig/src/gwget-application.h
++++ gwget-1.0.4/src/gwget-application.h
+@@ -18,7 +18,7 @@
+ #ifndef GWGET_APPLICATION_H
+ #define GWGET_APPLICATION_H
+
+-#include <glib/gerror.h>
++#include <glib.h>
+ #include <glib-object.h>
+
+ G_BEGIN_DECLS
diff --git a/net-misc/gwget/gwget-1.0.4.ebuild b/net-misc/gwget/gwget-1.0.4.ebuild
index 38ed80ecf05d..de8532c5d7c6 100644
--- a/net-misc/gwget/gwget-1.0.4.ebuild
+++ b/net-misc/gwget/gwget-1.0.4.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/gwget/gwget-1.0.4.ebuild,v 1.7 2012/05/05 03:20:43 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gwget/gwget-1.0.4.ebuild,v 1.8 2012/07/21 16:18:17 pacho Exp $
-EAPI="2"
+EAPI="4"
GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+GNOME_TARBALL_SUFFIX="bz2"
inherit eutils gnome2
@@ -30,9 +32,8 @@ DEPEND="${RDEPEND}
>=dev-util/intltool-0.35.0
>=sys-devel/gettext-0.10.4"
-DOCS="AUTHORS ChangeLog NEWS README THANKS TODO"
-
pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README THANKS TODO"
G2CONF="${G2CONF}
$(use_enable epiphany epiphany-extension)
$(use_enable libnotify)
@@ -42,6 +43,7 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+ epatch "${FILESDIR}"/${P}-glib-single-include.patch
gnome2_src_prepare
}
@@ -50,7 +52,4 @@ src_install() {
# remove /var/lib, which is created without any reason
rm -rf "${D}"/var || die "rm failed"
-
- # remove useless la files
- find "${D}" -name '*.la' -delete
}