summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-08-19 14:18:33 +0000
committerMike Frysinger <vapier@gentoo.org>2006-08-19 14:18:33 +0000
commit65618be20e93380e0aaa30539090cea8af92a06f (patch)
tree8f7372d8276efed246cd8930844c023f24020ba3 /net-misc/howl
parentarm/sh love (diff)
downloadgentoo-2-65618be20e93380e0aaa30539090cea8af92a06f.tar.gz
gentoo-2-65618be20e93380e0aaa30539090cea8af92a06f.tar.bz2
gentoo-2-65618be20e93380e0aaa30539090cea8af92a06f.zip
arm/s390/sh stable
(Portage version: 2.1.1_pre4)
Diffstat (limited to 'net-misc/howl')
-rw-r--r--net-misc/howl/files/digest-howl-1.0.02
-rw-r--r--net-misc/howl/howl-1.0.0.ebuild20
2 files changed, 12 insertions, 10 deletions
diff --git a/net-misc/howl/files/digest-howl-1.0.0 b/net-misc/howl/files/digest-howl-1.0.0
index 031025e428ab..5397cf3a4e6e 100644
--- a/net-misc/howl/files/digest-howl-1.0.0
+++ b/net-misc/howl/files/digest-howl-1.0.0
@@ -1 +1,3 @@
MD5 c389d3ffba0e69a179de2ec650f1fdcc howl-1.0.0.tar.gz 542782
+RMD160 f8eb6633d9edbb62038795ea66dcbf9dca4cffc1 howl-1.0.0.tar.gz 542782
+SHA256 6f0145ab1802092308adeb8dfa285f58e104f0822fa266e5ec97e9d27f0e1923 howl-1.0.0.tar.gz 542782
diff --git a/net-misc/howl/howl-1.0.0.ebuild b/net-misc/howl/howl-1.0.0.ebuild
index 711ff8e6c80c..5e5d454bab39 100644
--- a/net-misc/howl/howl-1.0.0.ebuild
+++ b/net-misc/howl/howl-1.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/howl/howl-1.0.0.ebuild,v 1.10 2006/03/10 00:52:55 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/howl/howl-1.0.0.ebuild,v 1.11 2006/08/19 14:18:33 vapier Exp $
inherit eutils flag-o-matic
@@ -10,10 +10,10 @@ SRC_URI="http://www.porchdogsoft.com/download/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ia64 ~mips ~ppc ~ppc-macos ppc64 ~s390 ~sh sparc ~x86"
+KEYWORDS="~amd64 arm ~hppa ia64 ~mips ~ppc ~ppc-macos ppc64 s390 sh sparc ~x86"
IUSE=""
-DEPEND="virtual/libc"
+DEPEND=""
# sys-devel/automake - needed if we remove the html docs from /usr/share
# sw_log is unprovided (Bug #87436)
@@ -21,9 +21,9 @@ RESTRICT="test"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# patch fixes #84030 (missing linux/types.h include)
- epatch ${FILESDIR}/${PN}-0.9.8-types.patch
+ epatch "${FILESDIR}"/${PN}-0.9.8-types.patch
}
src_compile() {
@@ -39,19 +39,19 @@ src_compile() {
}
src_install() {
- emake DESTDIR=${D} install || die "emake install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS COPYING ChangeLog INSTALL README TODO
dohtml -r docs/
# Install conf files
insinto /etc/conf.d
- newins ${FILESDIR}/nifd.conf.d nifd
- newins ${FILESDIR}/mDNSResponder.conf.d mDNSResponder
+ newins "${FILESDIR}"/nifd.conf.d nifd
+ newins "${FILESDIR}"/mDNSResponder.conf.d mDNSResponder
# Install init scripts
insinto /etc/init.d
- newins ${FILESDIR}/nifd.init.d nifd
- newins ${FILESDIR}/mDNSResponder.init.d mDNSResponder
+ newins "${FILESDIR}"/nifd.init.d nifd
+ newins "${FILESDIR}"/mDNSResponder.init.d mDNSResponder
# Fix the perms on the init scripts
fperms a+x /etc/init.d/nifd /etc/init.d/mDNSResponder