summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2007-10-17 21:19:36 +0000
committerSteve Arnold <nerdboy@gentoo.org>2007-10-17 21:19:36 +0000
commitd516d8d4659301ccbf56c51c99567bc074d2d2f3 (patch)
tree7e2f0bbae037afb48e5f56323aef451bd88101d6 /net-misc/hylafax/hylafax-4.3.1.ebuild
parentMask ghostscript-gpl-8.60 for testing, first release with ghostscript-esp mer... (diff)
downloadgentoo-2-d516d8d4659301ccbf56c51c99567bc074d2d2f3.tar.gz
gentoo-2-d516d8d4659301ccbf56c51c99567bc074d2d2f3.tar.bz2
gentoo-2-d516d8d4659301ccbf56c51c99567bc074d2d2f3.zip
fix for bug 196147 in all versions
(Portage version: 2.1.3.12)
Diffstat (limited to 'net-misc/hylafax/hylafax-4.3.1.ebuild')
-rw-r--r--net-misc/hylafax/hylafax-4.3.1.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/net-misc/hylafax/hylafax-4.3.1.ebuild b/net-misc/hylafax/hylafax-4.3.1.ebuild
index fae965976964..d08a1bf1e0ad 100644
--- a/net-misc/hylafax/hylafax-4.3.1.ebuild
+++ b/net-misc/hylafax/hylafax-4.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/hylafax-4.3.1.ebuild,v 1.6 2007/08/24 03:42:26 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hylafax/hylafax-4.3.1.ebuild,v 1.7 2007/10/17 21:19:36 nerdboy Exp $
inherit eutils multilib pam flag-o-matic toolchain-funcs
@@ -51,7 +51,7 @@ src_compile() {
[ $(gcc-major-version) -eq 3 ] && [ $(gcc-minor-version) -ge 4 ] \
&& filter-flags -fstack-protector -fstack-protector-all
- epatch ${FILESDIR}/gentoo-gcc-version.patch || die "epatch failed"
+ epatch "${FILESDIR}/gentoo-gcc-version.patch" || die "epatch failed"
local my_conf="
--with-DIR_BIN=/usr/bin
@@ -63,7 +63,7 @@ src_compile() {
--with-DIR_MAN=/usr/share/man
--with-DIR_SPOOL=/var/spool/fax
--with-DIR_HTML=/usr/share/doc/${P}/html
- --with-DIR_CGI=${WORKDIR}
+ --with-DIR_CGI="${WORKDIR}"
--with-PATH_DPSRIP=/var/spool/fax/bin/ps2fax
--with-PATH_IMPRIP=\"\"
--with-SYSVINIT=no
@@ -80,6 +80,7 @@ src_compile() {
if use mgetty; then
my_conf="${my_conf} \
+ --with-PATH_GETTY=/sbin/mgetty \
--with-PATH_EGETTY=/sbin/mgetty \
--with-PATH_VGETTY=/usr/sbin/vgetty"
else
@@ -134,10 +135,10 @@ src_install() {
/var/spool/fax/bin/{faxrcvd,pollrcvd} || die "dosed failed"
einfo "Adding env.d entry for Hylafax"
- newenvd ${FILESDIR}/99hylafax-4.2 99hylafax
+ newenvd "${FILESDIR}/99hylafax-4.2" 99hylafax
einfo "Adding init.d entry for Hylafax"
- newinitd ${FILESDIR}/hylafax-4.2 hylafax
+ newinitd "${FILESDIR}/hylafax-4.2" hylafax
use pam && pamd_mimic_system hylafax auth account session