summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-08-31 06:11:46 +0000
committerPacho Ramos <pacho@gentoo.org>2013-08-31 06:11:46 +0000
commit885bce2a7ea3d11752564a95e6fb7ebc4a2978e7 (patch)
tree601ec2cb2d27f2da534e9f4e5ac385b1e682e26c /net-misc/icecast
parentversion bump (diff)
downloadgentoo-2-885bce2a7ea3d11752564a95e6fb7ebc4a2978e7.tar.gz
gentoo-2-885bce2a7ea3d11752564a95e6fb7ebc4a2978e7.tar.bz2
gentoo-2-885bce2a7ea3d11752564a95e6fb7ebc4a2978e7.zip
Add unit file (#480696 by Mehmet Giritli)
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-misc/icecast')
-rw-r--r--net-misc/icecast/ChangeLog8
-rw-r--r--net-misc/icecast/files/icecast.service9
-rw-r--r--net-misc/icecast/icecast-2.3.3-r2.ebuild83
3 files changed, 99 insertions, 1 deletions
diff --git a/net-misc/icecast/ChangeLog b/net-misc/icecast/ChangeLog
index 450fd5b9e343..3bfaa6e038c7 100644
--- a/net-misc/icecast/ChangeLog
+++ b/net-misc/icecast/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/icecast
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/ChangeLog,v 1.96 2013/03/03 23:00:41 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/ChangeLog,v 1.97 2013/08/31 06:11:46 pacho Exp $
+
+*icecast-2.3.3-r2 (31 Aug 2013)
+
+ 31 Aug 2013; Pacho Ramos <pacho@gentoo.org> +files/icecast.service,
+ +icecast-2.3.3-r2.ebuild:
+ Add unit file (#480696 by Mehmet Giritli)
03 Mar 2013; Markos Chandras <hwoarang@gentoo.org> -icecast-2.3.2.ebuild,
-icecast-2.3.3.ebuild, icecast-2.3.3-r1.ebuild:
diff --git a/net-misc/icecast/files/icecast.service b/net-misc/icecast/files/icecast.service
new file mode 100644
index 000000000000..badb65e5d93c
--- /dev/null
+++ b/net-misc/icecast/files/icecast.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=An opensource alternative to shoutcast
+After=network.target
+
+[Service]
+ExecStart=/usr/bin/icecast -c /etc/icecast2/icecast.xml
+
+[Install]
+WantedBy=multi-user.target
diff --git a/net-misc/icecast/icecast-2.3.3-r2.ebuild b/net-misc/icecast/icecast-2.3.3-r2.ebuild
new file mode 100644
index 000000000000..908e2ac118fa
--- /dev/null
+++ b/net-misc/icecast/icecast-2.3.3-r2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/icecast-2.3.3-r2.ebuild,v 1.1 2013/08/31 06:11:46 pacho Exp $
+
+EAPI=4
+inherit eutils autotools systemd user
+
+DESCRIPTION="An opensource alternative to shoutcast that supports mp3, ogg (vorbis/theora) and aac streaming"
+HOMEPAGE="http://www.icecast.org/"
+SRC_URI="http://downloads.xiph.org/releases/icecast/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="kate logrotate +speex +ssl +theora +yp"
+
+#Although there is a --with-ogg and --with-orbis configure option, they're
+#only useful for specifying paths, not for disabling.
+DEPEND="dev-libs/libxslt
+ dev-libs/libxml2
+ media-libs/libogg
+ media-libs/libvorbis
+ kate? ( media-libs/libkate )
+ logrotate? ( app-admin/logrotate )
+ speex? ( media-libs/speex )
+ theora? ( media-libs/libtheora )
+ yp? ( net-misc/curl )
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewuser icecast -1 -1 -1 nogroup
+}
+
+src_prepare() {
+ # bug #368539
+ epatch "${FILESDIR}"/${P}-libkate.patch
+ # bug #430434
+ epatch "${FILESDIR}"/${P}-fix-xiph_openssl.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --sysconfdir=/etc/icecast2 \
+ $(use_enable kate) \
+ $(use_with theora) \
+ $(use_with speex) \
+ $(use_with yp curl) \
+ $(use_with ssl openssl) \
+ $(use_enable yp)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS README TODO HACKING NEWS conf/icecast.xml.dist
+ dohtml -A chm,hhc,hhp doc/*
+ doman debian/icecast2.1
+
+ newinitd "${FILESDIR}"/init.d.icecast icecast
+ systemd_dounit "${FILESDIR}"/${PN}.service
+
+ insinto /etc/icecast2
+ doins "${FILESDIR}"/icecast.xml
+ fperms 600 /etc/icecast2/icecast.xml
+
+ if use logrotate; then
+ dodir /etc/logrotate.d
+ insopts -m0644
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotate ${PN}
+ fi
+ diropts -m0764 -o icecast -g nogroup
+ dodir /var/log/icecast
+ keepdir /var/log/icecast
+ rm -rf "${D}"/usr/share/doc/icecast
+}
+
+pkg_postinst() {
+ touch "${ROOT}"var/log/icecast/{access,error}.log
+ chown icecast:nogroup "${ROOT}"var/log/icecast/{access,error}.log
+}