summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2009-02-18 16:26:06 +0000
committerTony Vroon <chainsaw@gentoo.org>2009-02-18 16:26:06 +0000
commitb00cc9f066dece7a8738ad4a1efa7344dbff9590 (patch)
treeb71a732229937f8b07a694accf6d2846f263677c /net-misc/ipsc
parentSync from ../../arch/ia64 (diff)
downloadgentoo-2-b00cc9f066dece7a8738ad4a1efa7344dbff9590.tar.gz
gentoo-2-b00cc9f066dece7a8738ad4a1efa7344dbff9590.tar.bz2
gentoo-2-b00cc9f066dece7a8738ad4a1efa7344dbff9590.zip
New and improved sed statement by Kevin Pyle <kevin.pyle@bluecoat.com> keeps LDFLAGS from being ignored. Closes bug #248101 filed by Diego E. Flameeyes Pettenò <flameeyes@gentoo.org>.
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/ipsc')
-rw-r--r--net-misc/ipsc/ChangeLog12
-rw-r--r--net-misc/ipsc/ipsc-0.4.3.2-r2.ebuild (renamed from net-misc/ipsc/ipsc-0.4.3.2-r1.ebuild)13
2 files changed, 19 insertions, 6 deletions
diff --git a/net-misc/ipsc/ChangeLog b/net-misc/ipsc/ChangeLog
index 7286c05f1533..8234894e4699 100644
--- a/net-misc/ipsc/ChangeLog
+++ b/net-misc/ipsc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/ipsc
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ipsc/ChangeLog,v 1.5 2008/10/11 23:07:47 chainsaw Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ipsc/ChangeLog,v 1.6 2009/02/18 16:26:06 chainsaw Exp $
+
+*ipsc-0.4.3.2-r2 (18 Feb 2009)
+
+ 18 Feb 2009; <chainsaw@gentoo.org> -ipsc-0.4.3.2-r1.ebuild,
+ +ipsc-0.4.3.2-r2.ebuild:
+ New and improved sed statement by Kevin Pyle <kevin.pyle@bluecoat.com>
+ keeps LDFLAGS from being ignored. Closes bug #248101 filed by Diego E.
+ Flameeyes Pettenò <flameeyes@gentoo.org>.
*ipsc-0.4.3.2-r1 (11 Oct 2008)
diff --git a/net-misc/ipsc/ipsc-0.4.3.2-r1.ebuild b/net-misc/ipsc/ipsc-0.4.3.2-r2.ebuild
index ebef05af6e8e..24f35db10c7b 100644
--- a/net-misc/ipsc/ipsc-0.4.3.2-r1.ebuild
+++ b/net-misc/ipsc/ipsc-0.4.3.2-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ipsc/ipsc-0.4.3.2-r1.ebuild,v 1.1 2008/10/11 23:07:47 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ipsc/ipsc-0.4.3.2-r2.ebuild,v 1.1 2009/02/18 16:26:06 chainsaw Exp $
inherit toolchain-funcs
@@ -16,8 +16,13 @@ RDEPEND="virtual/libc"
src_unpack() {
unpack ${A}
cd "${S}"
- sed -i -e "s:^CC = gcc:CC = $(tc-getCC):" src/Makefile || die "Unable to override compiler selection"
- sed -i -e "s:^CFLAGS = .*::" src/Makefile || die "Unable to unset upstream CFLAGS"
+ sed -i \
+ -e "s:^CC = gcc:CC = $(tc-getCC):" \
+ -e "/^CFLAGS = .*/d" \
+ -e "s/^LIBS = /LDLIBS = /" \
+ -e '/$(CC).*\\$/,+1d' \
+ -e '/$(CC)/d' \
+ src/Makefile || die "Unable to sed upstream Makefile"
}
src_compile() {