summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Wever <weeve@gentoo.org>2006-05-22 22:49:19 +0000
committerJason Wever <weeve@gentoo.org>2006-05-22 22:49:19 +0000
commit59e4a138e62c92f76278184823950fac44acd052 (patch)
tree576a8f490e8e3066674fc87dbb08d40a68dea481 /net-misc/jigdo
parentAdd smbfs ebuild from gentoo-alt overlay for Samba support on FreeBSD. (diff)
downloadgentoo-2-59e4a138e62c92f76278184823950fac44acd052.tar.gz
gentoo-2-59e4a138e62c92f76278184823950fac44acd052.tar.bz2
gentoo-2-59e4a138e62c92f76278184823950fac44acd052.zip
Version bump.
(Portage version: 2.1_rc1-r3)
Diffstat (limited to 'net-misc/jigdo')
-rw-r--r--net-misc/jigdo/ChangeLog9
-rw-r--r--net-misc/jigdo/files/digest-jigdo-0.7.22
-rw-r--r--net-misc/jigdo/files/digest-jigdo-0.7.33
-rw-r--r--net-misc/jigdo/jigdo-0.7.3.ebuild48
4 files changed, 60 insertions, 2 deletions
diff --git a/net-misc/jigdo/ChangeLog b/net-misc/jigdo/ChangeLog
index b99d9586ffc7..29ddba7217d4 100644
--- a/net-misc/jigdo/ChangeLog
+++ b/net-misc/jigdo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/jigdo
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/jigdo/ChangeLog,v 1.11 2005/08/21 22:05:08 weeve Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/jigdo/ChangeLog,v 1.12 2006/05/22 22:49:19 weeve Exp $
+
+*jigdo-0.7.3 (22 May 2006)
+
+ 22 May 2006; Jason Wever <weeve@gentoo.org> +jigdo-0.7.3.ebuild:
+ Version bump.
21 Aug 2005; Jason Wever <weeve@gentoo.org> files/jigdo-0.7.2-64bit.patch:
Fixed patch to resolve bug #103238.
diff --git a/net-misc/jigdo/files/digest-jigdo-0.7.2 b/net-misc/jigdo/files/digest-jigdo-0.7.2
index 0ec0375c82d0..180d37028941 100644
--- a/net-misc/jigdo/files/digest-jigdo-0.7.2
+++ b/net-misc/jigdo/files/digest-jigdo-0.7.2
@@ -1 +1,3 @@
MD5 031756ff6c7084a139dc9550a27f6906 jigdo-0.7.2.tar.bz2 643314
+RMD160 e43804b1cdf6df9e9f52f77879d3a1d0b8fdfc89 jigdo-0.7.2.tar.bz2 643314
+SHA256 760ae41d2d9e439dc367f0278c8b3e51c31e7cc852728a3d63f8fa150a95acb7 jigdo-0.7.2.tar.bz2 643314
diff --git a/net-misc/jigdo/files/digest-jigdo-0.7.3 b/net-misc/jigdo/files/digest-jigdo-0.7.3
new file mode 100644
index 000000000000..99c890348467
--- /dev/null
+++ b/net-misc/jigdo/files/digest-jigdo-0.7.3
@@ -0,0 +1,3 @@
+MD5 bbc1d9ac750bb34e0748f0b57157cc72 jigdo-0.7.3.tar.bz2 644670
+RMD160 545b4abbcb0a02636072e5acadeba7d99f59365f jigdo-0.7.3.tar.bz2 644670
+SHA256 875c069abad67ce67d032a9479228acdb37c8162236c0e768369505f264827f0 jigdo-0.7.3.tar.bz2 644670
diff --git a/net-misc/jigdo/jigdo-0.7.3.ebuild b/net-misc/jigdo/jigdo-0.7.3.ebuild
new file mode 100644
index 000000000000..48911da871eb
--- /dev/null
+++ b/net-misc/jigdo/jigdo-0.7.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/jigdo/jigdo-0.7.3.ebuild,v 1.1 2006/05/22 22:49:19 weeve Exp $
+
+inherit eutils
+
+DESCRIPTION="Jigsaw Download, or short jigdo, is a tool designed to ease the distribution of very large files over the internet, for example CD or DVD images."
+HOMEPAGE="http://atterer.net/jigdo/"
+SRC_URI="http://atterer.net/jigdo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+IUSE="gtk nls berkdb libwww"
+
+DEPEND="gtk? ( >=x11-libs/gtk+-2.0.6 )
+ nls? ( sys-devel/gettext )
+ berkdb? ( =sys-libs/db-3* )
+ libwww? ( >=net-libs/libwww-5.3.2 )"
+
+src_compile() {
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+ use gtk && use libwww || myconf="${myconf} --without-gui"
+ use berkdb || myconf="${myconf} --without-libdb"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man ${myconf} \
+ --datadir=/usr/share || die "./configure failed"
+
+ # Patch the Makefile so that when jidgo is installed, jigdo-lite has
+ # the correct path to the debian mirrors file.
+ epatch ${FILESDIR}/makefile.patch
+
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc COPYING README THANKS VERSION changelog
+ dodoc doc/*.txt
+ dohtml doc/*.html
+}