summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2008-09-15 07:30:29 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2008-09-15 07:30:29 +0000
commit477be9216c4d25f6c4afae4127ba45499747e7df (patch)
tree430f1b7c20f5bca06e437b413b97c794e8400e55 /net-misc/ksb26/ksb26-0.0.4.ebuild
parentBump and cleanup (diff)
downloadgentoo-2-477be9216c4d25f6c4afae4127ba45499747e7df.tar.gz
gentoo-2-477be9216c4d25f6c4afae4127ba45499747e7df.tar.bz2
gentoo-2-477be9216c4d25f6c4afae4127ba45499747e7df.zip
Fixed compilation of version 0.0.4 with recent kernels.
Some minor QA fixing. Closes bug #237251. (Portage version: 2.1.4.4)
Diffstat (limited to 'net-misc/ksb26/ksb26-0.0.4.ebuild')
-rw-r--r--net-misc/ksb26/ksb26-0.0.4.ebuild23
1 files changed, 13 insertions, 10 deletions
diff --git a/net-misc/ksb26/ksb26-0.0.4.ebuild b/net-misc/ksb26/ksb26-0.0.4.ebuild
index 69eadc99cd59..16f60236621e 100644
--- a/net-misc/ksb26/ksb26-0.0.4.ebuild
+++ b/net-misc/ksb26/ksb26-0.0.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ksb26/ksb26-0.0.4.ebuild,v 1.1 2006/01/30 11:17:50 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ksb26/ksb26-0.0.4.ebuild,v 1.2 2008/09/15 07:30:28 s4t4n Exp $
inherit linux-mod
@@ -31,9 +31,12 @@ src_unpack()
{
unpack ${A}
- cd ${S}
- cp ${FILESDIR}/${PN}-kernel-Makefile kernel/Makefile
+ cd "${S}"
+ cp "${FILESDIR}/${PN}-kernel-Makefile" kernel/Makefile
sed -i -e "s:@gcc:\${CC} \${CFLAGS}:" user/Makefile
+
+ #patch to fix compilation with recent kernels
+ epatch "${FILESDIR}/${P}_unreg_chrdev.patch" || die "epatch failed"
}
src_compile()
@@ -41,7 +44,7 @@ src_compile()
linux-mod_src_compile || die "Kernel module compilation failed!"
einfo "Preparing userspace tools"
- cd ${S}/user
+ cd "${S}/user"
emake || die "Userspace tools compilation failed!"
}
@@ -49,7 +52,7 @@ src_install()
{
linux-mod_src_install
- cd ${S}
+ cd "${S}"
dobin user/ksb26manager
dodir /etc/ksb26
@@ -64,8 +67,8 @@ pkg_postinst()
{
linux-mod_pkg_postinst
- if [ ! -e ${ROOT}/dev/ksb26 ]; then
- mknod ${ROOT}/dev/ksb26 c 254 0
+ if [ ! -e "${ROOT}/dev/ksb26" ]; then
+ mknod "${ROOT}/dev/ksb26" c 254 0
fi
einfo "Read man page (man ksb26) for informations about the use of ksb26"
@@ -74,7 +77,7 @@ pkg_postinst()
pkg_postrm()
{
- if [ -e ${ROOT}/dev/ksb26 ]; then
- rm ${ROOT}/dev/ksb26
+ if [ -e "${ROOT}/dev/ksb26" ]; then
+ rm "${ROOT}/dev/ksb26"
fi
}