summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-09-08 02:24:58 +0000
committerMike Gilbert <floppym@gentoo.org>2014-09-08 02:24:58 +0000
commit8a2028fbd1e34e43e690be7979ae9b06626db9e7 (patch)
tree64077e51fc7c334a5ef33733d05880c98de997c6 /net-misc/libreswan
parentAdd several patches from Fedora to fix various issues. (diff)
downloadgentoo-2-8a2028fbd1e34e43e690be7979ae9b06626db9e7.tar.gz
gentoo-2-8a2028fbd1e34e43e690be7979ae9b06626db9e7.tar.bz2
gentoo-2-8a2028fbd1e34e43e690be7979ae9b06626db9e7.zip
Version bump.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'net-misc/libreswan')
-rw-r--r--net-misc/libreswan/ChangeLog8
-rw-r--r--net-misc/libreswan/libreswan-3.10.ebuild99
-rw-r--r--net-misc/libreswan/libreswan-9999.ebuild3
3 files changed, 107 insertions, 3 deletions
diff --git a/net-misc/libreswan/ChangeLog b/net-misc/libreswan/ChangeLog
index d9a3bbf2bc65..4fddd93097fe 100644
--- a/net-misc/libreswan/ChangeLog
+++ b/net-misc/libreswan/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/libreswan
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/libreswan/ChangeLog,v 1.9 2014/07/09 21:30:39 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/libreswan/ChangeLog,v 1.10 2014/09/08 02:24:58 floppym Exp $
+
+*libreswan-3.10 (08 Sep 2014)
+
+ 08 Sep 2014; Mike Gilbert <floppym@gentoo.org> +libreswan-3.10.ebuild,
+ libreswan-9999.ebuild:
+ Version bump.
*libreswan-3.9 (09 Jul 2014)
diff --git a/net-misc/libreswan/libreswan-3.10.ebuild b/net-misc/libreswan/libreswan-3.10.ebuild
new file mode 100644
index 000000000000..2a31995c48e7
--- /dev/null
+++ b/net-misc/libreswan/libreswan-3.10.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/libreswan/libreswan-3.10.ebuild,v 1.1 2014/09/08 02:24:58 floppym Exp $
+
+EAPI=5
+
+inherit eutils systemd toolchain-funcs
+
+if [[ ${PV} != 9999 ]]; then
+ SRC_URI="https://download.libreswan.org/${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~x86"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/libreswan/libreswan.git"
+fi
+
+DESCRIPTION="IPsec implementation for Linux, fork of Openswan"
+HOMEPAGE="https://libreswan.org/"
+
+LICENSE="GPL-2 BSD-4 RSA DES"
+SLOT="0"
+IUSE="caps curl dnssec ldap pam"
+
+COMMON_DEPEND="
+ dev-libs/gmp
+ dev-libs/nspr
+ caps? ( sys-libs/libcap-ng )
+ curl? ( net-misc/curl )
+ dnssec? ( net-dns/unbound net-libs/ldns )
+ ldap? ( net-nds/openldap )
+ pam? ( sys-libs/pam )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/xmlto
+ dev-libs/nss
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ dev-libs/nss[utils(+)]
+ sys-apps/iproute2
+ !net-misc/openswan
+ !net-misc/strongswan
+"
+
+src_prepare() {
+ epatch_user
+}
+
+usetf() {
+ usex "$1" true false
+}
+
+src_configure() {
+ tc-export AR CC
+ export INC_USRLOCAL=/usr
+ export INC_MANDIR=share/man
+ export FINALEXAMPLECONFDIR=/usr/share/doc/${PF}
+ export FINALDOCDIR=/usr/share/doc/${PF}/html
+ export INITSYSTEM=openrc
+ export INC_RCDIRS=
+ export INC_RCDEFAULT=/etc/init.d
+ export USERCOMPILE=
+ export USERLINK=
+ export USE_DNSSEC=$(usetf dnssec)
+ export USE_LIBCAP_NG=$(usetf caps)
+ export USE_LIBCURL=$(usetf curl)
+ export USE_LDAP=$(usetf ldap)
+ export USE_XAUTHPAM=$(usetf pam)
+}
+
+src_compile() {
+ emake programs
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ echo "include /etc/ipsec.d/*.secrets" > "${D}"/etc/ipsec.secrets
+ fperms 0600 /etc/ipsec.secrets
+
+ systemd_dounit "${FILESDIR}/ipsec.service"
+
+ dodoc CHANGES README
+ dodoc -r docs
+
+ find "${D}" -type d -empty -delete || die
+}
+
+pkg_postinst() {
+ local IPSEC_CONFDIR=${ROOT%/}/etc/ipsec.d
+ if [[ ! -f ${IPSEC_CONFDIR}/cert8.db ]]; then
+ ebegin "Setting up NSS database in ${IPSEC_CONFDIR}"
+ certutil -N -d "${IPSEC_CONFDIR}" -f <(echo)
+ eend $?
+ fi
+}
diff --git a/net-misc/libreswan/libreswan-9999.ebuild b/net-misc/libreswan/libreswan-9999.ebuild
index d776af656bed..79260d4df2d2 100644
--- a/net-misc/libreswan/libreswan-9999.ebuild
+++ b/net-misc/libreswan/libreswan-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/libreswan/libreswan-9999.ebuild,v 1.6 2014/07/09 21:30:39 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/libreswan/libreswan-9999.ebuild,v 1.7 2014/09/08 02:24:58 floppym Exp $
EAPI=5
@@ -77,7 +77,6 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" install
- sed -i -e '1s:python$:python2:' "${D}"/usr/libexec/ipsec/verify || die
echo "include /etc/ipsec.d/*.secrets" > "${D}"/etc/ipsec.secrets
fperms 0600 /etc/ipsec.secrets