summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2006-11-26 16:36:18 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2006-11-26 16:36:18 +0000
commitd203117b35fbb19940613828b10d428faaaf5e25 (patch)
tree017af66a1d3a2b5567bdaaf193d6813b078bcaf2 /net-misc/linphone/linphone-1.5.1.ebuild
parentuse -fno-strict-aliasing #155906 (diff)
downloadgentoo-2-d203117b35fbb19940613828b10d428faaaf5e25.tar.gz
gentoo-2-d203117b35fbb19940613828b10d428faaaf5e25.tar.bz2
gentoo-2-d203117b35fbb19940613828b10d428faaaf5e25.zip
Added an explicit call to PKG_PROG_PKG_CONFIG (thx to Flameeyes) in configure.in.
(Portage version: 2.1.2_rc2-r2)
Diffstat (limited to 'net-misc/linphone/linphone-1.5.1.ebuild')
-rw-r--r--net-misc/linphone/linphone-1.5.1.ebuild15
1 files changed, 14 insertions, 1 deletions
diff --git a/net-misc/linphone/linphone-1.5.1.ebuild b/net-misc/linphone/linphone-1.5.1.ebuild
index b14dd05d2604..80db3ddc2462 100644
--- a/net-misc/linphone/linphone-1.5.1.ebuild
+++ b/net-misc/linphone/linphone-1.5.1.ebuild
@@ -1,9 +1,14 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/linphone/linphone-1.5.1.ebuild,v 1.1 2006/11/26 15:17:55 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/linphone/linphone-1.5.1.ebuild,v 1.2 2006/11/26 16:36:18 drizzt Exp $
MY_DPV="${PV%.*}.x"
+WANT_AUTOCONF="2.5"
+WANT_AUTOMAKE="1.9"
+
+inherit eutils autotools
+
DESCRIPTION="Linphone is a SIP phone with a GNOME interface."
HOMEPAGE="http://www.linphone.org"
SRC_URI="http://download.savannah.nongnu.org/releases/${PN}/${MY_DPV}/source/${P}.tar.gz"
@@ -32,6 +37,14 @@ RDEPEND="dev-libs/glib
DEPEND="${RDEPEND}"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-pkgconfig.patch
+ ./autogen.sh
+}
+
src_compile() {
local withgnome myconf=""