summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLisa M. Seelye <lisa@gentoo.org>2006-04-04 14:07:55 +0000
committerLisa M. Seelye <lisa@gentoo.org>2006-04-04 14:07:55 +0000
commit05b9cd4a121c08dd612356f2fd96da4d582429fd (patch)
treeb170c9124dea971c751f75b1774cb4aea190545b /net-misc/memcached/memcached-1.1.12-r3.ebuild
parentAdded patch to fix missing CLK_TCK in glibc-2.4. This fixes bug #128689. (diff)
downloadgentoo-2-05b9cd4a121c08dd612356f2fd96da4d582429fd.tar.gz
gentoo-2-05b9cd4a121c08dd612356f2fd96da4d582429fd.tar.bz2
gentoo-2-05b9cd4a121c08dd612356f2fd96da4d582429fd.zip
Close bug 122246, please read it for info on how to use multiple instances
(Portage version: 2.1_pre7-r3)
Diffstat (limited to 'net-misc/memcached/memcached-1.1.12-r3.ebuild')
-rw-r--r--net-misc/memcached/memcached-1.1.12-r3.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-misc/memcached/memcached-1.1.12-r3.ebuild b/net-misc/memcached/memcached-1.1.12-r3.ebuild
new file mode 100644
index 000000000000..49cda883bb69
--- /dev/null
+++ b/net-misc/memcached/memcached-1.1.12-r3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/memcached/memcached-1.1.12-r3.ebuild,v 1.1 2006/04/04 14:07:55 lisa Exp $
+
+inherit eutils
+
+DESCRIPTION="memcached is a high-performance, distributed memory object caching system, generic in nature, but intended for use in speeding up dynamic web applications by alleviating database load."
+
+HOMEPAGE="http://www.danga.com/memcached/"
+
+SRC_URI="http://www.danga.com/memcached/dist/${P}.tar.gz"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static perl doc"
+
+DEPEND=">=dev-libs/libevent-0.6
+ perl? ( dev-perl/Cache-Memcached )"
+
+src_compile() {
+ local myconf=""
+ use static || myconf="--disable-static ${myconf}"
+ econf ${myconf} || die "econf failed"
+ emake || die
+}
+
+src_install() {
+ dobin ${S}/memcached
+ dodoc ${S}/{AUTHORS,COPYING,ChangeLog,INSTALL,NEWS,README}
+
+ insinto /etc/conf.d
+ newins "${FILESDIR}/${PV}/conf" memcached
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/${PV}/init" memcached
+
+ doman ${S}/doc/memcached.1
+
+ if use doc; then
+ dodoc ${S}/doc/{memory_management.txt,protocol.txt}
+ fi
+}
+
+pkg_postinst() {
+ enewuser memcached -1 -1 /dev/null daemon
+ einfo "With this version of Memcached Gentoo now supporst multiple instances."
+ einfo "To enable this you must create a symlink in /etc/init.d/ for each instance"
+ einfo "to /etc/init.d/memcached and create the matching conf files in /etc/conf.d/"
+ einfo "Please see Gentoo bug #122246 for more info"
+}