summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-11-27 23:24:52 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-11-27 23:24:52 +0000
commitc5812e6cdf565899fd2ed889a1de18c7a5eca74f (patch)
treea06a6cb5ab390db265e7a7c31ee076ac5506da46 /net-misc/memcached
parentVersion bump. (diff)
downloadgentoo-2-c5812e6cdf565899fd2ed889a1de18c7a5eca74f.tar.gz
gentoo-2-c5812e6cdf565899fd2ed889a1de18c7a5eca74f.tar.bz2
gentoo-2-c5812e6cdf565899fd2ed889a1de18c7a5eca74f.zip
Version bump. Also fix bug #288833 for --as-needed.
(Portage version: 2.2_rc51/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/memcached')
-rw-r--r--net-misc/memcached/ChangeLog8
-rw-r--r--net-misc/memcached/files/memcached-1.4.4-as-needed.patch31
-rw-r--r--net-misc/memcached/memcached-1.4.4.ebuild79
3 files changed, 117 insertions, 1 deletions
diff --git a/net-misc/memcached/ChangeLog b/net-misc/memcached/ChangeLog
index 33697a95a6b9..653db43c8774 100644
--- a/net-misc/memcached/ChangeLog
+++ b/net-misc/memcached/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/memcached
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/memcached/ChangeLog,v 1.104 2009/10/12 19:42:46 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/memcached/ChangeLog,v 1.105 2009/11/27 23:24:52 robbat2 Exp $
+
+*memcached-1.4.4 (27 Nov 2009)
+
+ 27 Nov 2009; Robin H. Johnson <robbat2@gentoo.org>
+ +memcached-1.4.4.ebuild, +files/memcached-1.4.4-as-needed.patch:
+ Version bump. Also fix bug #288833 for --as-needed.
12 Oct 2009; Robin H. Johnson <robbat2@gentoo.org> memcached-1.4.2.ebuild:
Disable doc building as it wants a bunch of stuff that Gentoo doesn't
diff --git a/net-misc/memcached/files/memcached-1.4.4-as-needed.patch b/net-misc/memcached/files/memcached-1.4.4-as-needed.patch
new file mode 100644
index 000000000000..f6e5cde11057
--- /dev/null
+++ b/net-misc/memcached/files/memcached-1.4.4-as-needed.patch
@@ -0,0 +1,31 @@
+diff -Nuar memcached-1.4.4.orig/configure.ac memcached-1.4.4/configure.ac
+--- memcached-1.4.4.orig/configure.ac 2009-11-24 16:40:29.000000000 -0800
++++ memcached-1.4.4/configure.ac 2009-11-27 15:20:38.000000000 -0800
+@@ -115,6 +115,14 @@
+ AC_SUBST(ENABLE_SASL)
+ AC_SUBST(PROFILER_LDFLAGS)
+
++dnl Check whether the user's system supports pthread before adding -pthread to CFLAGS
++dnl otherwise we won't get -l{threads} in LIBS
++dnl AFAIK -pthread should be added to LDFLAGS on BSD systems
++AC_SEARCH_LIBS(pthread_create, [pthread pthreads thread threads] )
++if test "x$ac_cv_search_pthread_create" == "xno"; then
++ AC_MSG_ERROR([Can't enable threads without the POSIX thread library.])
++fi
++
+ AC_ARG_ENABLE(coverage,
+ [AS_HELP_STRING([--disable-coverage],[Disable code coverage])])
+
+@@ -376,12 +384,6 @@
+
+ AC_C_HTONLL
+
+-dnl Check whether the user's system supports pthread
+-AC_SEARCH_LIBS(pthread_create, pthread)
+-if test "x$ac_cv_search_pthread_create" = "xno"; then
+- AC_MSG_ERROR([Can't enable threads without the POSIX thread library.])
+-fi
+-
+ AC_CHECK_FUNCS(mlockall)
+ AC_CHECK_FUNCS(getpagesizes)
+ AC_CHECK_FUNCS(memcntl)
diff --git a/net-misc/memcached/memcached-1.4.4.ebuild b/net-misc/memcached/memcached-1.4.4.ebuild
new file mode 100644
index 000000000000..1164de123eda
--- /dev/null
+++ b/net-misc/memcached/memcached-1.4.4.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/memcached/memcached-1.4.4.ebuild,v 1.1 2009/11/27 23:24:52 robbat2 Exp $
+
+EAPI=2
+inherit eutils autotools flag-o-matic
+
+MY_PV="${PV/_rc/-rc}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="High-performance, distributed memory object caching system"
+HOMEPAGE="http://code.google.com/p/memcached/"
+SRC_URI="http://memcached.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="test slabs-reassign debug sasl" # hugetlbfs later
+
+RDEPEND=">=dev-libs/libevent-1.4
+ dev-lang/perl
+ sasl? ( dev-libs/cyrus-sasl )"
+DEPEND="${RDEPEND}
+ test? ( virtual/perl-Test-Harness >=dev-perl/Cache-Memcached-1.24 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.2.2-fbsd.patch"
+ # Handled different upstream
+ #epatch "${FILESDIR}/${PN}-1.3.3-gcc4-slab-fixup.patch"
+ epatch "${FILESDIR}/${PN}-1.4.0-fix-as-needed-linking.patch"
+ epatch "${FILESDIR}/${PN}-1.4.4-as-needed.patch"
+ sed -i -e 's,-Werror,,g' configure.ac || die "sed failed"
+ eautoreconf
+ use slabs-reassign && append-flags -DALLOW_SLABS_REASSIGN
+}
+
+src_configure() {
+ econf \
+ --disable-docs \
+ $(use_enable sasl)
+ # The xml2rfc tool to build the additional docs requires TCL :-(
+ # `use_enable doc docs`
+}
+
+src_compile() {
+ # There is a heavy degree of per-object compile flags
+ # Users do NOT know better than upstream. Trying to compile the testapp and
+ # the -debug version with -DNDEBUG _WILL_ fail.
+ append-flags -UNDEBUG
+ emake testapp memcached-debug CFLAGS="${CFLAGS}" || die "emake of testapp and memcached-debug failed."
+ filter-flags -UNDEBUG
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dobin scripts/memcached-tool
+ use debug && dobin memcached-debug
+
+ dodoc AUTHORS ChangeLog NEWS README doc/{CONTRIBUTORS,*.txt}
+
+ newconfd "${FILESDIR}"/1.3.3/conf memcached
+ newinitd "${FILESDIR}"/1.3.3/init memcached
+}
+
+pkg_postinst() {
+ enewuser memcached -1 -1 /dev/null daemon
+
+ elog "With this version of Memcached Gentoo now supports multiple instances."
+ elog "To enable this you should create a symlink in /etc/init.d/ for each instance"
+ elog "to /etc/init.d/memcached and create the matching conf files in /etc/conf.d/"
+ elog "Please see Gentoo bug #122246 for more info"
+}
+
+src_test() {
+ emake -j1 test || die "Failed testing"
+}