summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-12-11 10:52:18 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-12-11 10:52:18 +0000
commit913807c665347c77f45964dfd82aa0f1b2e4dcf2 (patch)
tree01b9480430c2830c1a8923d4cd492dda0398b666 /net-misc/mico
parentNew ebuild. This release adds support for the PMac Windtunnel and Xserve. (diff)
downloadgentoo-2-913807c665347c77f45964dfd82aa0f1b2e4dcf2.tar.gz
gentoo-2-913807c665347c77f45964dfd82aa0f1b2e4dcf2.tar.bz2
gentoo-2-913807c665347c77f45964dfd82aa0f1b2e4dcf2.zip
new ebuild. bug 5393
Diffstat (limited to 'net-misc/mico')
-rw-r--r--net-misc/mico/ChangeLog11
-rw-r--r--net-misc/mico/files/digest-mico-2.3.71
-rw-r--r--net-misc/mico/mico-2.3.7.ebuild57
3 files changed, 69 insertions, 0 deletions
diff --git a/net-misc/mico/ChangeLog b/net-misc/mico/ChangeLog
new file mode 100644
index 000000000000..8bc2e47e3ad3
--- /dev/null
+++ b/net-misc/mico/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-misc/mico
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mico/ChangeLog,v 1.1 2002/12/11 10:52:18 mkennedy Exp $
+
+*mico-2.3.7 (11 Dec 2002)
+
+ 11 Dec 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ mico-2.3.7.ebuild, files/digest-mico-2.3.7 :
+
+ Initial import.
+
diff --git a/net-misc/mico/files/digest-mico-2.3.7 b/net-misc/mico/files/digest-mico-2.3.7
new file mode 100644
index 000000000000..19766f6472ab
--- /dev/null
+++ b/net-misc/mico/files/digest-mico-2.3.7
@@ -0,0 +1 @@
+MD5 26f576b8b4c809fc0740aeff02db0b1b mico-2.3.7.tar.gz 1968216
diff --git a/net-misc/mico/mico-2.3.7.ebuild b/net-misc/mico/mico-2.3.7.ebuild
new file mode 100644
index 000000000000..dbdfad43a762
--- /dev/null
+++ b/net-misc/mico/mico-2.3.7.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mico/mico-2.3.7.ebuild,v 1.1 2002/12/11 10:52:18 mkennedy Exp $
+
+IUSE="ssl tcltk"
+
+DESCRIPTION="A freely available and fully compliant implementation of the CORBA standard"
+HOMEPAGE="http://www.mico.org/"
+SRC_URI="http://www.mico.org/${P}.tar.gz"
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="x86 ~alpha"
+
+DEPEND="virtual/glibc
+ sys-devel/flex
+ sys-devel/bison
+ ssl? ( dev-libs/openssl )
+ tcltk? ( dev-lang/tcl )"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ local myopts="--enable-final
+ --disable-mini-stl
+ --enable-except
+ --enable-dynamic
+ --enable-repo
+ --enable-shared"
+
+ myopts="${myopts}
+ --enable-life
+ --enable-externalize"
+
+ use ssl && myopts="${myopts} --with-ssl=/usr" \
+ || myopts="${myopts} --without-ssl"
+ use tcltk && myopts="${myopts} --with-tcl=/usr" \
+ || myopts="${myopts} --without-tcl"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+
+ make || die
+}
+
+src_install() {
+ make INSTDIR=${D}/usr SHARED_INSTDIR=${D}/usr install || die
+
+ dodir /usr/share/
+ mv ${D}/usr/man ${D}/usr/share
+ dodir /usr/share/doc/
+ mv ${D}/usr/doc ${D}/usr/share/doc/${P}
+
+ dodoc CHANGES CONVERT FAQ INSTALL LICENSE* MANIFEST README* ROADMAP TODO VERSION
+}