summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2013-04-17 20:57:30 +0000
committerJason A. Donenfeld <zx2c4@gentoo.org>2013-04-17 20:57:30 +0000
commit3f6fd4dce2fd77e7ab065bf77b59447a775b558d (patch)
tree761e7c27bad1d63a2454d58eec6e7d2160cdf5fe /net-misc/ndppd
parentBump. (diff)
downloadgentoo-2-3f6fd4dce2fd77e7ab065bf77b59447a775b558d.tar.gz
gentoo-2-3f6fd4dce2fd77e7ab065bf77b59447a775b558d.tar.bz2
gentoo-2-3f6fd4dce2fd77e7ab065bf77b59447a775b558d.zip
Initial import.
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key A5DE03AE)
Diffstat (limited to 'net-misc/ndppd')
-rw-r--r--net-misc/ndppd/ChangeLog9
-rw-r--r--net-misc/ndppd/files/ndppd.initd14
-rw-r--r--net-misc/ndppd/metadata.xml11
-rw-r--r--net-misc/ndppd/ndppd-0.2.3.ebuild25
4 files changed, 59 insertions, 0 deletions
diff --git a/net-misc/ndppd/ChangeLog b/net-misc/ndppd/ChangeLog
new file mode 100644
index 000000000000..a7dc7975f30a
--- /dev/null
+++ b/net-misc/ndppd/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-misc/ndppd
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ndppd/ChangeLog,v 1.1 2013/04/17 20:57:30 zx2c4 Exp $
+
+*ndppd-0.2.3 (17 Apr 2013)
+
+ 17 Apr 2013; Jason A. Donenfeld <zx2c4@gentoo.org> +files/ndppd.initd,
+ +metadata.xml, +ndppd-0.2.3.ebuild:
+ Initial import.
diff --git a/net-misc/ndppd/files/ndppd.initd b/net-misc/ndppd/files/ndppd.initd
new file mode 100644
index 000000000000..93327b8bf983
--- /dev/null
+++ b/net-misc/ndppd/files/ndppd.initd
@@ -0,0 +1,14 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ndppd/files/ndppd.initd,v 1.1 2013/04/17 20:57:30 zx2c4 Exp $
+
+command="/usr/sbin/ndppd"
+pidfile="/var/run/ndppd.pid"
+command_args="-p $pidfile -d"
+start_stop_daemon_args="--quiet"
+description="Proxies NDP messages between interfaces."
+
+depend() {
+ use net
+}
diff --git a/net-misc/ndppd/metadata.xml b/net-misc/ndppd/metadata.xml
new file mode 100644
index 000000000000..70b099927c12
--- /dev/null
+++ b/net-misc/ndppd/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zx2c4@gentoo.org</email>
+ <name>Jason A. Donenfeld</name>
+ </maintainer>
+ <longdescription>
+ ndppd, or NDP Proxy Daemon, is a daemon that proxies NDP (Neighbor Discovery Protocol) messages between interfaces.
+ </longdescription>
+</pkgmetadata>
diff --git a/net-misc/ndppd/ndppd-0.2.3.ebuild b/net-misc/ndppd/ndppd-0.2.3.ebuild
new file mode 100644
index 000000000000..ed6d76b995c6
--- /dev/null
+++ b/net-misc/ndppd/ndppd-0.2.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ndppd/ndppd-0.2.3.ebuild,v 1.1 2013/04/17 20:57:30 zx2c4 Exp $
+
+EAPI=5
+
+DESCRIPTION="Proxies NDP messages between interfaces."
+HOMEPAGE="http://priv.nu/projects/ndppd/"
+SRC_URI="http://priv.nu/projects/ndppd/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_install()
+{
+ emake PREFIX=/usr DESTDIR="${D}" install
+ insinto /etc
+ newins ndppd.conf-dist ndppd.conf
+ newinitd "${FILESDIR}"/ndppd.initd ndppd
+}