summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2009-09-15 22:04:58 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2009-09-15 22:04:58 +0000
commit9d7eb9da93381aba89783057858e2439878b997c (patch)
treed1078924515659c21f5e590ba54ab4ee53b7ef73 /net-misc/neatx
parentWarn if xv is requested but xcb is not enabled as xcb is the only xvideo outp... (diff)
downloadgentoo-2-9d7eb9da93381aba89783057858e2439878b997c.tar.gz
gentoo-2-9d7eb9da93381aba89783057858e2439878b997c.tar.bz2
gentoo-2-9d7eb9da93381aba89783057858e2439878b997c.zip
Revision bump to fix a few things: neatx.conf default options, netcat/gnu-netcat support, fix python objects precompilation. Thanks to calchan for review and pointers
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/neatx')
-rw-r--r--net-misc/neatx/ChangeLog10
-rw-r--r--net-misc/neatx/neatx-0.3.1_p43-r1.ebuild (renamed from net-misc/neatx/neatx-0.3.1_p43.ebuild)20
2 files changed, 20 insertions, 10 deletions
diff --git a/net-misc/neatx/ChangeLog b/net-misc/neatx/ChangeLog
index e32befa6b254..0aced888a9cf 100644
--- a/net-misc/neatx/ChangeLog
+++ b/net-misc/neatx/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/neatx
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/neatx/ChangeLog,v 1.1 2009/09/09 11:30:04 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neatx/ChangeLog,v 1.2 2009/09/15 22:04:58 voyageur Exp $
+
+*neatx-0.3.1_p43-r1 (15 Sep 2009)
+
+ 15 Sep 2009; Bernard Cafarelli <voyageur@gentoo.org>
+ -neatx-0.3.1_p43.ebuild, +neatx-0.3.1_p43-r1.ebuild:
+ Revision bump to fix a few things: neatx.conf default options,
+ netcat/gnu-netcat support, fix python objects precompilation. Thanks to
+ calchan for review and pointers
*neatx-0.3.1_p43 (09 Sep 2009)
diff --git a/net-misc/neatx/neatx-0.3.1_p43.ebuild b/net-misc/neatx/neatx-0.3.1_p43-r1.ebuild
index 6c47d7ead103..6c7acf3e858a 100644
--- a/net-misc/neatx/neatx-0.3.1_p43.ebuild
+++ b/net-misc/neatx/neatx-0.3.1_p43-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/neatx/neatx-0.3.1_p43.ebuild,v 1.1 2009/09/09 11:30:04 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neatx/neatx-0.3.1_p43-r1.ebuild,v 1.1 2009/09/15 22:04:58 voyageur Exp $
EAPI="2"
@@ -23,7 +23,7 @@ RDEPEND="dev-python/pexpect
app-portage/portage-utils
media-fonts/font-misc-misc
media-fonts/font-cursor-misc
- net-analyzer/netcat
+ || ( net-analyze/gnu-netcat net-analyzer/netcat )
net-misc/nx"
S=${WORKDIR}/${PN}
@@ -37,11 +37,6 @@ src_prepare() {
-i lib/constants.py || die "constants.py sed failed"
eautoreconf
-
- # This is for bug 215944, so .pyo/.pyc files don't get into the
- # file system
- mv "${S}"/autotools/py-compile "${S}"/autotools/py-compile.orig
- ln -s $(type -P true) "${S}"/autotools/py-compile
}
pkg_setup () {
@@ -65,11 +60,18 @@ src_install() {
insinto /etc
newins doc/neatx.conf.example neatx.conf
+
+ # nc or netcat?
+ if has_version net-analyzer/gnu-netcat; then
+ nc_path="/usr/bin/netcat"
+ else
+ nc_path="/usr/bin/nc"
+ fi
cat >> "${D}"/etc/neatx.conf << EOF
-netcat-path = /usr/bin/netcat
-xserssion-path = /etc/X11/Sessions/Xsession
+netcat-path = ${nc_path}
use-xsession = false
+start-gnome-command = /etc/X11/Sessions/Gnome
EOF
insinto ${NX_HOME_DIR}/.ssh