summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2014-05-20 20:11:17 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2014-05-20 20:11:17 +0000
commit58a47bd391dcc875a484a722eb98041cd28141d6 (patch)
treeb38af1f9e338f77eac61b5072c7928e16a6d8a4a /net-misc/netctl
parentVersion bump, migrate to new python eclasses (#486962 by hasufell), drop old. (diff)
downloadgentoo-2-58a47bd391dcc875a484a722eb98041cd28141d6.tar.gz
gentoo-2-58a47bd391dcc875a484a722eb98041cd28141d6.tar.bz2
gentoo-2-58a47bd391dcc875a484a722eb98041cd28141d6.zip
Version bump. Add myself as maintainer
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 09BF4F54C2BA7F3C!)
Diffstat (limited to 'net-misc/netctl')
-rw-r--r--net-misc/netctl/ChangeLog8
-rw-r--r--net-misc/netctl/metadata.xml4
-rw-r--r--net-misc/netctl/netctl-1.7.ebuild80
3 files changed, 91 insertions, 1 deletions
diff --git a/net-misc/netctl/ChangeLog b/net-misc/netctl/ChangeLog
index 01ab8efd03cc..554615a787d9 100644
--- a/net-misc/netctl/ChangeLog
+++ b/net-misc/netctl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/netctl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/ChangeLog,v 1.18 2014/03/22 17:39:28 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/ChangeLog,v 1.19 2014/05/20 20:11:17 hwoarang Exp $
+
+*netctl-1.7 (20 May 2014)
+
+ 20 May 2014; Markos Chandras <hwoarang@gentoo.org> +netctl-1.7.ebuild,
+ metadata.xml:
+ Version bump. Add myself as maintainer
*netctl-1.6 (22 Mar 2014)
diff --git a/net-misc/netctl/metadata.xml b/net-misc/netctl/metadata.xml
index 09ddbff14dbf..c524795cfacb 100644
--- a/net-misc/netctl/metadata.xml
+++ b/net-misc/netctl/metadata.xml
@@ -5,4 +5,8 @@
<email>floppym@gentoo.org</email>
<name>Mike Gilbert</name>
</maintainer>
+ <maintainer>
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+ </maintainer>
</pkgmetadata>
diff --git a/net-misc/netctl/netctl-1.7.ebuild b/net-misc/netctl/netctl-1.7.ebuild
new file mode 100644
index 000000000000..aed8409ebd10
--- /dev/null
+++ b/net-misc/netctl/netctl-1.7.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/netctl-1.7.ebuild,v 1.1 2014/05/20 20:11:17 hwoarang Exp $
+
+EAPI=5
+
+inherit bash-completion-r1
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://projects.archlinux.org/netctl.git"
+ inherit git-2
+ DEPEND="app-text/asciidoc"
+else
+ SRC_URI="ftp://ftp.archlinux.org/other/packages/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Profile based network connection tool from Arch Linux"
+HOMEPAGE="https://wiki.archlinux.org/index.php/Netctl
+ https://www.archlinux.org/packages/core/any/netctl/
+ https://projects.archlinux.org/netctl.git/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND+="
+ virtual/pkgconfig
+ sys-apps/systemd
+"
+RDEPEND="
+ >=app-shells/bash-4.0
+ >=net-dns/openresolv-3.5.4-r1
+ sys-apps/iproute2
+ sys-apps/systemd
+ !<net-misc/dhcpcd-5.6.7
+"
+
+src_prepare() {
+ sed -i -e "s:/usr/bin/ifplugd:/usr/sbin/ifplugd:" \
+ "services/netctl-ifplugd@.service" || die
+}
+
+src_compile() {
+ return 0
+}
+
+src_install() {
+ emake DESTDIR="${D%/}" SHELL=bash install
+ dodoc AUTHORS NEWS README
+ newbashcomp contrib/bash-completion netctl
+ insinto /usr/share/zsh/site-functions
+ newins contrib/zsh-completion _netctl
+}
+
+optfeature() {
+ local desc=$1
+ shift
+ while (( $# )); do
+ if has_version "$1"; then
+ elog " [I] $1 for ${desc}"
+ else
+ elog " [ ] $1 for ${desc}"
+ fi
+ shift
+ done
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "To get additional features, a number of optional runtime dependencies may be"
+ elog "installed."
+ optfeature "DHCP support" net-misc/dhcpcd ">=net-misc/dhcp-5.6.7[client]"
+ optfeature "WPA support" net-wireless/wpa_supplicant
+ optfeature "interactive assistant" dev-util/dialog
+ optfeature "automatic connection" sys-apps/ifplugd
+ optfeature "bonding support" net-misc/ifenslave
+ optfeature "dialup support" net-dialup/ppp
+ fi
+}