summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-05-25 19:07:31 +0000
committerMike Gilbert <floppym@gentoo.org>2013-05-25 19:07:31 +0000
commit9b2f3bdac1dd907443809d7207ad60653fe2bf55 (patch)
treef63982bf53940541311f660e5121af555d2099ae /net-misc/netctl
parentStable for x86, wrt bug #470678 (diff)
downloadgentoo-2-9b2f3bdac1dd907443809d7207ad60653fe2bf55.tar.gz
gentoo-2-9b2f3bdac1dd907443809d7207ad60653fe2bf55.tar.bz2
gentoo-2-9b2f3bdac1dd907443809d7207ad60653fe2bf55.zip
Version bump. Install bash and zsh completion code, bug 471234 by poncho.
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'net-misc/netctl')
-rw-r--r--net-misc/netctl/ChangeLog8
-rw-r--r--net-misc/netctl/netctl-1.1.ebuild40
-rw-r--r--net-misc/netctl/netctl-9999.ebuild7
3 files changed, 52 insertions, 3 deletions
diff --git a/net-misc/netctl/ChangeLog b/net-misc/netctl/ChangeLog
index 63f62f66da71..4e0e9e1b5c43 100644
--- a/net-misc/netctl/ChangeLog
+++ b/net-misc/netctl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/netctl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/ChangeLog,v 1.4 2013/04/30 14:27:32 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/ChangeLog,v 1.5 2013/05/25 19:07:31 floppym Exp $
+
+*netctl-1.1 (25 May 2013)
+
+ 25 May 2013; Mike Gilbert <floppym@gentoo.org> +netctl-1.1.ebuild,
+ netctl-9999.ebuild:
+ Version bump. Install bash and zsh completion code, bug 471234 by poncho.
*netctl-1.0 (30 Apr 2013)
diff --git a/net-misc/netctl/netctl-1.1.ebuild b/net-misc/netctl/netctl-1.1.ebuild
new file mode 100644
index 000000000000..8287d3f60dad
--- /dev/null
+++ b/net-misc/netctl/netctl-1.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/netctl-1.1.ebuild,v 1.1 2013/05/25 19:07:31 floppym Exp $
+
+EAPI=5
+
+inherit bash-completion-r1 eutils
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://projects.archlinux.org/netctl.git"
+ inherit git-2
+else
+ SRC_URI="ftp://ftp.archlinux.org/other/packages/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Profile based network connection tool from Arch Linux"
+HOMEPAGE="https://www.archlinux.org/netctl/"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=app-shells/bash-4.0
+ >=net-dns/openresolv-3.5.4-r1
+ sys-apps/iproute2
+ sys-apps/systemd
+"
+
+src_compile() {
+ return 0
+}
+
+src_install() {
+ emake DESTDIR="${D%/}" SHELL=bash install
+ dodoc AUTHORS NEWS README
+ newbashcomp contrib/bash-completion netctl
+ insinto /usr/share/zsh/site-functions
+ newins contrib/zsh-completion _netctl
+}
diff --git a/net-misc/netctl/netctl-9999.ebuild b/net-misc/netctl/netctl-9999.ebuild
index 219cb9131a6c..bc830d5ab311 100644
--- a/net-misc/netctl/netctl-9999.ebuild
+++ b/net-misc/netctl/netctl-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/netctl-9999.ebuild,v 1.3 2013/04/30 14:27:32 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/netctl-9999.ebuild,v 1.4 2013/05/25 19:07:31 floppym Exp $
EAPI=5
-inherit eutils
+inherit bash-completion-r1 eutils
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="git://projects.archlinux.org/netctl.git"
@@ -34,4 +34,7 @@ src_compile() {
src_install() {
emake DESTDIR="${D%/}" SHELL=bash install
dodoc AUTHORS NEWS README
+ newbashcomp contrib/bash-completion netctl
+ insinto /usr/share/zsh/site-functions
+ newins contrib/zsh-completion _netctl
}