summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-06-26 14:46:05 +0000
committerMike Frysinger <vapier@gentoo.org>2003-06-26 14:46:05 +0000
commit2aaab9915bad897a1b5d4cb3c459d30801eeb7f5 (patch)
tree1650f5b472bbf7fb613899c015646fa238609ea4 /net-misc/ntp
parentremove pid file ... mrannanj@irc (diff)
downloadgentoo-2-2aaab9915bad897a1b5d4cb3c459d30801eeb7f5.tar.gz
gentoo-2-2aaab9915bad897a1b5d4cb3c459d30801eeb7f5.tar.bz2
gentoo-2-2aaab9915bad897a1b5d4cb3c459d30801eeb7f5.zip
add parse clock support
Diffstat (limited to 'net-misc/ntp')
-rw-r--r--net-misc/ntp/Manifest4
-rw-r--r--net-misc/ntp/ntp-4.1.1b-r6.ebuild8
2 files changed, 8 insertions, 4 deletions
diff --git a/net-misc/ntp/Manifest b/net-misc/ntp/Manifest
index 235c5babd80d..b5e87e731f8b 100644
--- a/net-misc/ntp/Manifest
+++ b/net-misc/ntp/Manifest
@@ -1,5 +1,3 @@
-MD5 2fc6086a3788c4279b444ac97acc7648 ChangeLog 4593
-MD5 7912b3b3d37cdde44d3bd94482203a81 ntp-4.1.1b-r6.ebuild 1583
MD5 dc4866d87240ff3d7e6685c365f0839f files/digest-ntp-4.1.1b-r6 134
MD5 dded11ceec4b8f2c1b140341a357f507 files/linux-config-phone.patch 747
MD5 e82bbe682098cf66f513ca2d11e4bc36 files/ntp-4.1.1b-syscall-libc.patch 522
@@ -7,3 +5,5 @@ MD5 40c3ee9069686a0f1004b583741cfdb0 files/ntp-bk.diff 618
MD5 df5af3eae0f809622f36f560e4f556a4 files/ntp.conf 1636
MD5 f8102e350a5174f62ff394d8b4888563 files/ntpd.confd 1586
MD5 8555f70b99956043bd7d2312dc1c3b4d files/ntpd.rc 1146
+MD5 2fc6086a3788c4279b444ac97acc7648 ChangeLog 4593
+MD5 9ee1b7e778ba28a57473353c07f4535c ntp-4.1.1b-r6.ebuild 1641
diff --git a/net-misc/ntp/ntp-4.1.1b-r6.ebuild b/net-misc/ntp/ntp-4.1.1b-r6.ebuild
index b9cdbe8061bb..db09b05a3ed7 100644
--- a/net-misc/ntp/ntp-4.1.1b-r6.ebuild
+++ b/net-misc/ntp/ntp-4.1.1b-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ntp-4.1.1b-r6.ebuild,v 1.1 2003/06/16 18:25:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ntp-4.1.1b-r6.ebuild,v 1.2 2003/06/26 14:45:57 vapier Exp $
inherit eutils
@@ -12,6 +12,7 @@ HOMEPAGE="http://www.ntp.org/"
SLOT="0"
LICENSE="as-is"
KEYWORDS="x86 ppc sparc mips alpha arm hppa"
+IUSE="parse-clocks"
DEPEND=">=sys-apps/sed-4.0.5
>=sys-libs/ncurses-5.2
@@ -31,7 +32,10 @@ src_compile() {
cp configure{,.orig}
sed -i "s:-Wpointer-arith::" configure
- econf --build=${CHOST} || die
+ econf \
+ --build=${CHOST} \
+ `use_enable parse-clocks` \
+ || die
emake || die
}