summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJared H.Hudson <jhhudso@gentoo.org>2003-02-24 12:58:48 +0000
committerJared H.Hudson <jhhudso@gentoo.org>2003-02-24 12:58:48 +0000
commit6606a7258740078f781c68e8cc4cb0a4743cd052 (patch)
tree474d5cf39e1afebd747e898798c6223bf94db96c /net-misc/nut
parentversion bump (diff)
downloadgentoo-2-6606a7258740078f781c68e8cc4cb0a4743cd052.tar.gz
gentoo-2-6606a7258740078f781c68e8cc4cb0a4743cd052.tar.bz2
gentoo-2-6606a7258740078f781c68e8cc4cb0a4743cd052.zip
Enabled ./configure option for USB UPS support
Diffstat (limited to 'net-misc/nut')
-rw-r--r--net-misc/nut/ChangeLog7
-rw-r--r--net-misc/nut/files/digest-nut-1.2.1-r11
-rw-r--r--net-misc/nut/nut-1.2.1-r1.ebuild109
3 files changed, 116 insertions, 1 deletions
diff --git a/net-misc/nut/ChangeLog b/net-misc/nut/ChangeLog
index b5b4e5616eb6..b48e339de80f 100644
--- a/net-misc/nut/ChangeLog
+++ b/net-misc/nut/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for net-misc/nut
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/nut/ChangeLog,v 1.11 2003/02/12 08:29:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nut/ChangeLog,v 1.12 2003/02/24 12:58:48 jhhudso Exp $
+*nut-1.2.1-r1 (24 Feb 2003)
+
+ 24 Feb 2003; Jared Hudson <jhhudso@gentoo.org> : Added hiddev driver support.
+ Used by several USB based UPSs.
+
*nut-1.2.1 (27 Jan 2003)
27 Jan 2003; Donny Davies <woodchip@gentoo.org> : New testing release.
diff --git a/net-misc/nut/files/digest-nut-1.2.1-r1 b/net-misc/nut/files/digest-nut-1.2.1-r1
new file mode 100644
index 000000000000..519b08fcd6db
--- /dev/null
+++ b/net-misc/nut/files/digest-nut-1.2.1-r1
@@ -0,0 +1 @@
+MD5 bf1147dbc04a6d5bb982d03720d2331e nut-1.2.1.tar.gz 444256
diff --git a/net-misc/nut/nut-1.2.1-r1.ebuild b/net-misc/nut/nut-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..c487d80a7905
--- /dev/null
+++ b/net-misc/nut/nut-1.2.1-r1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nut/nut-1.2.1-r1.ebuild,v 1.1 2003/02/24 12:58:48 jhhudso Exp $
+
+IUSE="png"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Network-UPS Tools"
+SRC_URI="http://www.exploits.org/nut/release/${PV%.*}/${P}.tar.gz"
+HOMEPAGE="http://www.exploits.org/nut/"
+KEYWORDS="~x86 ~sparc"
+LICENSE="GPL-2"
+SLOT="0"
+
+# -- [ FIXME ] --
+# a better idea would be to have virtual/httpd dependencies and
+# USE cgi-bin support. USE png and apache are used for now :\
+
+DEPEND="png? ( =sys-libs/zlib-1* =media-libs/libgd-1* =media-libs/libpng-1.2* )"
+RDEPEND="${DEPEND} png? ( net-www/apache ) >=sys-apps/baselayout-1.8.2"
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S} || die
+ cp configure.in configure.in.orig
+ sed -e "s:GD_LIBS.*=.*-L/usr/X11R6/lib \(.*\) -lXpm -lX11:GD_LIBS=\"\1:" \
+ configure.in.orig >configure.in
+ WANT_AUTOCONF_2_5=1 autoconf || die
+}
+
+src_compile() {
+ local myconf
+ use png && myconf="--with-cgi --with-cgipath=/home/httpd/cgi-bin"
+ use png || myconf="--without-cgi"
+
+ #default is to build all drivers; but the following is common:
+ #--with-drivers=apcsmart,hidups
+ ./configure \
+ --prefix=/usr \
+ --with-user=nut \
+ --with-group=nut \
+ --with-port=3493 \
+ --with-drvpath=/sbin \
+ --sysconfdir=/etc/nut \
+ --mandir=/usr/share/man \
+ --with-pidpath=/var/run \
+ --with-logfacility=LOG_DAEMON \
+ --with-statepath=/var/state/nut \
+ --with-altpidpath=/var/state/nut \
+ --with-linux-hiddev \
+ --host=${CHOST} ${myconf} || die
+
+ emake || die
+
+ if [ -n "`use png`" ]
+ then
+ emake cgi || die
+ fi
+}
+
+src_install() {
+ # Makefile: user/group nut might not exist until after
+ # pkg_preinst() runs; so use root for now, and fix it
+ # up in pkg_postinst().
+ make DESTDIR=${D} RUNUID=root RUNGID=root install || die
+
+ if [ -n "`use png`" ]
+ then
+ make DESTDIR=${D} install-cgi || die
+ fi
+ # see above note...
+ rm -rf ${D}/var/state/nut
+
+ dodoc CHANGES COPYING CREDITS INSTALL NEWS README \
+ UPGRADING docs/{FAQ,*.txt,driver.list}
+ docinto cables ; dodoc docs/cables/*
+ docinto drivers ; dodoc docs/drivers/*
+
+ # clean up /etc/nut/*.sample files
+ cd ${D}/etc/nut
+ for i in *.sample
+ do
+ mv $i ${i/.sample/}
+ done
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/upsd-init upsd
+ newexe ${FILESDIR}/upsmon-init upsmon
+}
+
+pkg_preinst() {
+ if ! groupmod nut ; then
+ groupadd -g 84 nut || die "problem adding group nut"
+ fi
+
+ # usermod returns 2 on user-exists-but-no-flags-given
+ usermod nut &>/dev/null
+ if [ $? != 2 ] ; then
+ useradd -u 84 -g nut -s /bin/false -c "nut" \
+ -d /var/state/nut nut || die "problem adding user nut"
+ fi
+}
+
+pkg_postinst() {
+ install -m0700 -o nut -g nut -d ${ROOT}/var/state/nut
+ chown root.nut ${ROOT}/etc/nut/{upsd.conf,upsd.users,upsmon.conf}
+ chmod 640 ${ROOT}/etc/nut/{upsd.conf,upsd.users,upsmon.conf}
+ ewarn "Dont forget to merge any changes in /etc/init.d/._cfgXXXX_halt.sh"
+}