summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2003-08-27 03:07:10 +0000
committerStuart Herbert <stuart@gentoo.org>2003-08-27 03:07:10 +0000
commit0808c9799d10b901fef90790bc63d6b74fb8f536 (patch)
tree0455293d0f95be07cf31c94617b15a760dc7ce2c /net-misc/nxssh
parentInitial import (diff)
downloadgentoo-2-0808c9799d10b901fef90790bc63d6b74fb8f536.tar.gz
gentoo-2-0808c9799d10b901fef90790bc63d6b74fb8f536.tar.bz2
gentoo-2-0808c9799d10b901fef90790bc63d6b74fb8f536.zip
Initial import
Diffstat (limited to 'net-misc/nxssh')
-rw-r--r--net-misc/nxssh/ChangeLog9
-rw-r--r--net-misc/nxssh/Manifest3
-rw-r--r--net-misc/nxssh/files/digest-nxssh-1.2.21
-rw-r--r--net-misc/nxssh/nxssh-1.2.2.ebuild49
4 files changed, 61 insertions, 1 deletions
diff --git a/net-misc/nxssh/ChangeLog b/net-misc/nxssh/ChangeLog
new file mode 100644
index 000000000000..c4c7fa137883
--- /dev/null
+++ b/net-misc/nxssh/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-misc/nxssh
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nxssh/ChangeLog,v 1.1 2003/08/27 03:07:02 stuart Exp $
+
+*nxssh-1.2.2 (27 Aug 2003)
+
+ 27 Aug 2003; stuart nxssh-1.2.2.ebuild:
+ Initial import
+
diff --git a/net-misc/nxssh/Manifest b/net-misc/nxssh/Manifest
index a432da00bb9b..fb42119c7f91 100644
--- a/net-misc/nxssh/Manifest
+++ b/net-misc/nxssh/Manifest
@@ -1,2 +1,3 @@
-MD5 f81f27c7338a35f6b9ce809b10478a19 nxssh-1.2.2.ebuild 1189
+MD5 5d682fff9a53bb50df38069ed4166525 nxssh-1.2.2.ebuild 1343
+MD5 b34343b53861d0084fb3082a0f16b200 ChangeLog 298
MD5 f6305e9a9358e4b8a76fc81c45775fce files/digest-nxssh-1.2.2 65
diff --git a/net-misc/nxssh/files/digest-nxssh-1.2.2 b/net-misc/nxssh/files/digest-nxssh-1.2.2
new file mode 100644
index 000000000000..f0e12f7c7c53
--- /dev/null
+++ b/net-misc/nxssh/files/digest-nxssh-1.2.2
@@ -0,0 +1 @@
+MD5 ad942b49798c6f236b54a3644d37875a nxssh-1.2.2-5.tar.gz 879067
diff --git a/net-misc/nxssh/nxssh-1.2.2.ebuild b/net-misc/nxssh/nxssh-1.2.2.ebuild
new file mode 100644
index 000000000000..a131d7a3d1ca
--- /dev/null
+++ b/net-misc/nxssh/nxssh-1.2.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nxssh/nxssh-1.2.2.ebuild,v 1.1 2003/08/27 03:07:02 stuart Exp $
+
+MY_P="${P}-5"
+DESCRIPTION="Modified openssh client, used by nxclient"
+HOMEPAGE="http://www.nomachine.com/"
+SRC_URI="http://www.nomachine.com/download/nxsources/nxssh/${MY_P}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND=""
+# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
+#RDEPEND=""
+IUSE="tcpd pam kerberos"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ local myconf
+
+ use tcpd || myconf="${myconf} --without-tcp-wrappers"
+ use tcpd && myconf="${myconf} --with-tcp-wrappers"
+ use pam || myconf="${myconf} --without-pam"
+ use pam && myconf="${myconf} --with-pam"
+ use ipv6 || myconf="${myconf} --with-ipv4-default"
+
+ # app-crypt/mit-krb5
+ use kerberos && myconf="${myconf} --with-kerberos5"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc/ssh \
+ --mandir=/usr/share/man \
+ --libexecdir=/usr/lib/misc \
+ --datadir=/usr/share/openssh \
+ --disable-suid-ssh \
+ --with-privsep-path=/var/empty \
+ --with-privsep-user=sshd \
+ --with-md5-passwords \
+ --host=${CHOST} ${myconf} || die "bad configure"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ exeinto /usr/NX/bin
+ doexe nxssh
+}