summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2013-10-21 17:13:38 +0000
committerChristoph Junghans <ottxor@gentoo.org>2013-10-21 17:13:38 +0000
commit9c6a42347bd53ca9afeb73caf37325d5b001c836 (patch)
tree2c7c4862a253eb40e37d2f432585fc4ef6cd7ec6 /net-misc/openntpd
parentInitial commit; dependency of net-irc/rbot (diff)
downloadgentoo-2-9c6a42347bd53ca9afeb73caf37325d5b001c836.tar.gz
gentoo-2-9c6a42347bd53ca9afeb73caf37325d5b001c836.tar.bz2
gentoo-2-9c6a42347bd53ca9afeb73caf37325d5b001c836.zip
move log file (bug #477714#c10)
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'net-misc/openntpd')
-rw-r--r--net-misc/openntpd/ChangeLog8
-rw-r--r--net-misc/openntpd/files/openntpd.init.d-20080406-r418
-rw-r--r--net-misc/openntpd/openntpd-20080406-r4.ebuild81
3 files changed, 106 insertions, 1 deletions
diff --git a/net-misc/openntpd/ChangeLog b/net-misc/openntpd/ChangeLog
index 40594008b3a0..c3111e630577 100644
--- a/net-misc/openntpd/ChangeLog
+++ b/net-misc/openntpd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/openntpd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openntpd/ChangeLog,v 1.87 2013/10/02 02:30:09 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openntpd/ChangeLog,v 1.88 2013/10/21 17:13:38 ottxor Exp $
+
+*openntpd-20080406-r4 (21 Oct 2013)
+
+ 21 Oct 2013; Christoph Junghans <ottxor@gentoo.org>
+ +files/openntpd.init.d-20080406-r4, +openntpd-20080406-r4.ebuild:
+ move log file (bug #477714#c10)
02 Oct 2013; Jeroen Roovers <jer@gentoo.org> openntpd-20080406-r3.ebuild:
Stable for HPPA (bug #477714).
diff --git a/net-misc/openntpd/files/openntpd.init.d-20080406-r4 b/net-misc/openntpd/files/openntpd.init.d-20080406-r4
new file mode 100644
index 000000000000..2874da24f4ae
--- /dev/null
+++ b/net-misc/openntpd/files/openntpd.init.d-20080406-r4
@@ -0,0 +1,18 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openntpd/files/openntpd.init.d-20080406-r4,v 1.1 2013/10/21 17:13:38 ottxor Exp $
+
+name="OpenNTPD"
+command="/usr/sbin/ntpd"
+command_args="${NTPD_OPTS} -d"
+command_background="yes"
+pidfile="/run/ntpd.pid"
+logfile="/var/log/ntpd.log"
+start_stop_daemon_args="--stderr ${logfile}"
+
+depend() {
+ need net
+ after ntp-client
+ use dns logger
+}
diff --git a/net-misc/openntpd/openntpd-20080406-r4.ebuild b/net-misc/openntpd/openntpd-20080406-r4.ebuild
new file mode 100644
index 000000000000..15c3fea349f4
--- /dev/null
+++ b/net-misc/openntpd/openntpd-20080406-r4.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openntpd/openntpd-20080406-r4.ebuild,v 1.1 2013/10/21 17:13:38 ottxor Exp $
+
+EAPI=5
+
+inherit autotools eutils toolchain-funcs systemd user
+
+MY_P="${P/-/_}p"
+DEB_VER="4"
+DESCRIPTION="Lightweight NTP server ported from OpenBSD"
+HOMEPAGE="http://www.openntpd.org/"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${MY_P}-${DEB_VER}.debian.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl selinux"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ selinux? ( sec-policy/selinux-ntp )
+ !<=net-misc/ntp-4.2.0-r2
+ !net-misc/ntp[-openntpd]"
+DEPEND="${RDEPEND}
+ virtual/yacc"
+
+S="${WORKDIR}/${MY_P/_/-}"
+
+pkg_setup() {
+ export NTP_HOME="${NTP_HOME:=/var/lib/openntpd/chroot}"
+ enewgroup ntp
+ enewuser ntp -1 -1 "${NTP_HOME}" ntp
+
+ # make sure user has correct HOME as flipng between
+ # the standard ntp pkg and this one was possible in
+ # the past
+ if [[ $(egethome ntp) != ${NTP_HOME} ]]; then
+ ewarn "From this version on, the homedir of the ntp user cannot be changed"
+ ewarn "dynamically after the installation. For homedir different from"
+ ewarn "/var/lib/openntpd/chroot set NTP_HOME in your make.conf and re-emerge."
+ esethome ntp "${NTP_HOME}"
+ fi
+}
+
+src_prepare() {
+ sed -i '/NTPD_USER/s:_ntp:ntp:' ntpd.h || die
+
+ epatch "${WORKDIR}"/debian/patches/*.patch
+ sed -i 's:debian:gentoo:g' ntpd.conf || die
+ eautoreconf # deb patchset touches .ac files and such
+}
+
+src_configure() {
+ econf \
+ --disable-strip \
+ $(use_with !ssl builtin-arc4random) \
+ AR="$(type -p $(tc-getAR))"
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}/${PN}.init.d-${PVR}" ntpd
+ newconfd "${FILESDIR}/${PN}.conf.d-${PV}-r3" ntpd
+
+ systemd_newunit "${FILESDIR}/${PN}.service-${PVR}" ntpd.service
+}
+
+pkg_postinst() {
+ # remove localtime file from previous installations
+ rm -f "${EROOT}${NTP_HOME}"/etc/localtime
+ mkdir -p "${NTP_HOME}"/etc
+ ln -s /etc/localtime "${NTP_HOME}"/etc/localtime || die
+ chown -R root:root "${EROOT}${NTP_HOME}" || die
+}
+
+pkg_postrm() {
+ # remove localtime file from previous installations
+ rm -f "${EROOT}${NTP_HOME}"/etc/localtime
+}