summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-11-17 22:31:30 +0000
committerMike Frysinger <vapier@gentoo.org>2008-11-17 22:31:30 +0000
commit2f8efd1ffb9c129a5c9dc025f477ceb35efdc384 (patch)
treec2ff9eb3c512b18bb91cb666d301ef54526aa3df /net-misc/openssh/files
parentFix patch with absolute paths. (diff)
downloadgentoo-2-2f8efd1ffb9c129a5c9dc025f477ceb35efdc384.tar.gz
gentoo-2-2f8efd1ffb9c129a5c9dc025f477ceb35efdc384.tar.bz2
gentoo-2-2f8efd1ffb9c129a5c9dc025f477ceb35efdc384.zip
Fix ssp detection on uClibc hosts.
(Portage version: 2.2_rc14/cvs/Linux 2.6.27.4 x86_64)
Diffstat (limited to 'net-misc/openssh/files')
-rw-r--r--net-misc/openssh/files/openssh-5.1_p1-better-ssp-check.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/net-misc/openssh/files/openssh-5.1_p1-better-ssp-check.patch b/net-misc/openssh/files/openssh-5.1_p1-better-ssp-check.patch
new file mode 100644
index 000000000000..5f3578ec22b0
--- /dev/null
+++ b/net-misc/openssh/files/openssh-5.1_p1-better-ssp-check.patch
@@ -0,0 +1,18 @@
+a simple 'int main(){}' function won't generate references to SSP functions
+when using -fstack-protector which means systems that dont have SSP support
+wont get properly detected as lacking support. instead, create a big buffer
+on the stack and use it as that seems to do the trick.
+
+--- openssh-5.1p1/configure.ac
++++ openssh-5.1p1/configure.ac
+@@ -145,8 +145,8 @@ int main(void){return 0;}
+ AC_MSG_CHECKING(if $t works)
+ AC_RUN_IFELSE(
+ [AC_LANG_SOURCE([
+-#include <stdlib.h>
+-int main(void){exit(0);}
++#include <stdio.h>
++int main(void){char foo[1024];return sprintf(foo, "moo cow");}
+ ])],
+ [ AC_MSG_RESULT(yes)
+ break ],