summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-04-12 20:10:55 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-04-12 20:10:55 +0000
commit6530b6a07545e5871366420bb435968e890f4759 (patch)
tree88487eedb7506d6e3b6ac8c7ebae320759501fb0 /net-misc/openssh/openssh-5.2_p1-r1.ebuild
parentStable on sparc, security bug #257004 (diff)
downloadgentoo-2-6530b6a07545e5871366420bb435968e890f4759.tar.gz
gentoo-2-6530b6a07545e5871366420bb435968e890f4759.tar.bz2
gentoo-2-6530b6a07545e5871366420bb435968e890f4759.zip
Bug #264841, the ssh testsuite needs a real shell to run, so run a subset of tests otherwise.
(Portage version: 2.2_rc27/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/openssh/openssh-5.2_p1-r1.ebuild')
-rw-r--r--net-misc/openssh/openssh-5.2_p1-r1.ebuild20
1 files changed, 17 insertions, 3 deletions
diff --git a/net-misc/openssh/openssh-5.2_p1-r1.ebuild b/net-misc/openssh/openssh-5.2_p1-r1.ebuild
index ba93b8e7fb17..01354a7b1664 100644
--- a/net-misc/openssh/openssh-5.2_p1-r1.ebuild
+++ b/net-misc/openssh/openssh-5.2_p1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.2_p1-r1.ebuild,v 1.8 2009/04/04 15:45:37 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.2_p1-r1.ebuild,v 1.9 2009/04/12 20:10:55 robbat2 Exp $
inherit eutils flag-o-matic multilib autotools pam
@@ -172,17 +172,31 @@ src_install() {
src_test() {
local t failed passwd
- for t in tests interop-tests compat-tests ; do
+ tests="interop-tests compat-tests"
+ skipped=""
+ portage_shell="$(getent passwd portage |cut -d: -f7)"
+ if [ "${portage_shell/nologin}" != ${portage_shell}" -o
+ "${portage_shell/false}" != ${portage_shell}" ]; then
+ elog "Running the full OpenSSH testsuite"
+ elog "requires a usable shell for the 'portage'"
+ elog "user, so we will run a subset only."
+ skipped="${skipped} tests"
+ else
+ tests="${tests} tests"
+ fi
+ for t in ${tests} ; do
# Some tests read from stdin ...
emake -k -j1 ${t} </dev/null \
&& passed="${passed}${t} " \
|| failed="${failed}${t} "
done
+ einfo "Passed tests: ${passed}"
+ ewarn "Skipped tests: ${skipped}"
if [[ -n ${failed} ]] ; then
- einfo "Passed tests: ${passed}"
ewarn "Failed tests: ${failed}"
die "Some tests failed: ${failed}"
else
+ einfo "Failed tests: ${failed}"
return 0
fi
}