summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-29 12:01:10 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-29 12:01:10 +0000
commit587a1bf1c492e4c27a20fd66df9e1c5902db289b (patch)
tree30319e5e124e0c40cf808d118859e65305f19c2e /net-misc/openssh
parentVersion bump. Adding virtual/jdk to DEPEND, virtual/jre to RDEPEND, fix lazy ... (diff)
downloadgentoo-2-587a1bf1c492e4c27a20fd66df9e1c5902db289b.tar.gz
gentoo-2-587a1bf1c492e4c27a20fd66df9e1c5902db289b.tar.bz2
gentoo-2-587a1bf1c492e4c27a20fd66df9e1c5902db289b.zip
Fix cross-compiling #120567 by Raphael Burnes.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'net-misc/openssh')
-rw-r--r--net-misc/openssh/ChangeLog9
-rw-r--r--net-misc/openssh/files/openssh-4.2_p1-cross-compile.patch35
-rw-r--r--net-misc/openssh/openssh-4.0_p1-r2.ebuild5
-rw-r--r--net-misc/openssh/openssh-4.1_p1-r1.ebuild5
-rw-r--r--net-misc/openssh/openssh-4.2_p1.ebuild5
5 files changed, 51 insertions, 8 deletions
diff --git a/net-misc/openssh/ChangeLog b/net-misc/openssh/ChangeLog
index 57dc05752ce0..e634a70b43c2 100644
--- a/net-misc/openssh/ChangeLog
+++ b/net-misc/openssh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/openssh
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.143 2005/12/25 15:21:10 flameeyes Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.144 2006/01/29 12:01:10 vapier Exp $
+
+ 29 Jan 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/openssh-4.2_p1-cross-compile.patch, openssh-4.0_p1-r2.ebuild,
+ openssh-4.1_p1-r1.ebuild, openssh-4.2_p1.ebuild:
+ Fix cross-compiling #120567 by Raphael Burnes.
25 Dec 2005; Diego Pettenò <flameeyes@gentoo.org> openssh-4.2_p1.ebuild:
Use bindnow-flags function instead of -Wl,-z,now.
diff --git a/net-misc/openssh/files/openssh-4.2_p1-cross-compile.patch b/net-misc/openssh/files/openssh-4.2_p1-cross-compile.patch
new file mode 100644
index 000000000000..11652f88e702
--- /dev/null
+++ b/net-misc/openssh/files/openssh-4.2_p1-cross-compile.patch
@@ -0,0 +1,35 @@
+Add fallback tests for cross-compile
+
+http://bugs.gentoo.org/120567
+http://bugzilla.mindrot.org/show_bug.cgi?id=1145
+
+--- openssh/configure.ac
++++ openssh/configure.ac
+@@ -1366,6 +1366,9 @@
+ [
+ AC_MSG_RESULT(no)
+ AC_DEFINE(SSHD_ACQUIRES_CTTY)
++ ],
++ [
++ AC_MSG_WARN([cross compiling: Assuming yes])
+ ]
+ )
+ fi
+@@ -2959,13 +2964,12 @@
+ [ etc_default_login=yes ]
+ )
+
+-if test "x$etc_default_login" != "xno"; then
++if test ! -z "$cross_compiling" && test "x$cross_compiling" = "xyes"; then
++ AC_MSG_WARN([cross compiling: Disabling /etc/default/login test])
++elif test "x$etc_default_login" != "xno"; then
+ AC_CHECK_FILE("/etc/default/login",
+ [ external_path_file=/etc/default/login ])
+- if test ! -z "$cross_compiling" && test "x$cross_compiling" = "xyes";
+- then
+- AC_MSG_WARN([cross compiling: Disabling /etc/default/login test])
+- elif test "x$external_path_file" = "x/etc/default/login"; then
++ if test "x$external_path_file" = "x/etc/default/login"; then
+ AC_DEFINE(HAVE_ETC_DEFAULT_LOGIN)
+ fi
+ fi
diff --git a/net-misc/openssh/openssh-4.0_p1-r2.ebuild b/net-misc/openssh/openssh-4.0_p1-r2.ebuild
index 71cfc0b28acc..8703709c56de 100644
--- a/net-misc/openssh/openssh-4.0_p1-r2.ebuild
+++ b/net-misc/openssh/openssh-4.0_p1-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-4.0_p1-r2.ebuild,v 1.8 2005/10/19 03:32:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-4.0_p1-r2.ebuild,v 1.9 2006/01/29 12:01:10 vapier Exp $
inherit eutils flag-o-matic ccc pam
@@ -56,6 +56,7 @@ src_unpack() {
#epatch "${FILESDIR}"/openssh-3.9_p1-largekey.patch.bz2
epatch "${FILESDIR}"/openssh-3.9_p1-configure-openct.patch #78730
epatch "${FILESDIR}"/openssh-3.9_p1-kerberos-detection.patch #80811
+ epatch "${FILESDIR}"/openssh-4.2_p1-cross-compile.patch #120567
use X509 && epatch "${DISTDIR}"/${X509_PATCH}
use sftplogging && epatch "${FILESDIR}"/openssh-4.0_p1-sftplogging-1.2-gentoo.patch.bz2
diff --git a/net-misc/openssh/openssh-4.1_p1-r1.ebuild b/net-misc/openssh/openssh-4.1_p1-r1.ebuild
index 51279025d6d6..567993ea2a2c 100644
--- a/net-misc/openssh/openssh-4.1_p1-r1.ebuild
+++ b/net-misc/openssh/openssh-4.1_p1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-4.1_p1-r1.ebuild,v 1.9 2005/10/19 03:32:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-4.1_p1-r1.ebuild,v 1.10 2006/01/29 12:01:10 vapier Exp $
inherit eutils flag-o-matic ccc pam
@@ -55,6 +55,7 @@ src_unpack() {
#epatch "${FILESDIR}"/openssh-3.9_p1-largekey.patch.bz2
epatch "${FILESDIR}"/openssh-3.9_p1-kerberos-detection.patch #80811
+ epatch "${FILESDIR}"/openssh-4.2_p1-cross-compile.patch #120567
use X509 && epatch "${DISTDIR}"/${X509_PATCH}
use sftplogging && epatch "${FILESDIR}"/openssh-4.0_p1-sftplogging-1.2-gentoo.patch.bz2
diff --git a/net-misc/openssh/openssh-4.2_p1.ebuild b/net-misc/openssh/openssh-4.2_p1.ebuild
index 2c92aad7b54e..fa40401dcc85 100644
--- a/net-misc/openssh/openssh-4.2_p1.ebuild
+++ b/net-misc/openssh/openssh-4.2_p1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-4.2_p1.ebuild,v 1.15 2005/12/25 15:21:10 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-4.2_p1.ebuild,v 1.16 2006/01/29 12:01:10 vapier Exp $
inherit eutils flag-o-matic ccc pam
@@ -53,6 +53,7 @@ src_unpack() {
#epatch "${FILESDIR}"/openssh-3.9_p1-largekey.patch.bz2
epatch "${FILESDIR}"/openssh-4.2_p1-kerberos-detection.patch #80811
+ epatch "${FILESDIR}"/openssh-4.2_p1-cross-compile.patch #120567
use X509 && epatch "${DISTDIR}"/${X509_PATCH}
use sftplogging && epatch "${FILESDIR}"/openssh-4.2_p1-sftplogging-1.4-gentoo.patch.bz2