summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-05-01 09:02:35 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-05-01 09:02:35 +0000
commit690f24331fdb7f010b9ca2537ddb816fca9b343d (patch)
treef1299c1a47cd22dd3bdbd19a4751eaaf0bc2758d /net-misc/openvpn/openvpn-1.6.0.ebuild
parentStable on ppc64 (diff)
downloadgentoo-2-690f24331fdb7f010b9ca2537ddb816fca9b343d.tar.gz
gentoo-2-690f24331fdb7f010b9ca2537ddb816fca9b343d.tar.bz2
gentoo-2-690f24331fdb7f010b9ca2537ddb816fca9b343d.zip
marked 1.6.0 stable on amd64 and x86, some cosmetic changes.
(Portage version: 2.0.51.20-r5)
Diffstat (limited to 'net-misc/openvpn/openvpn-1.6.0.ebuild')
-rw-r--r--net-misc/openvpn/openvpn-1.6.0.ebuild28
1 files changed, 15 insertions, 13 deletions
diff --git a/net-misc/openvpn/openvpn-1.6.0.ebuild b/net-misc/openvpn/openvpn-1.6.0.ebuild
index 788f2ef94684..0cbb934b98cb 100644
--- a/net-misc/openvpn/openvpn-1.6.0.ebuild
+++ b/net-misc/openvpn/openvpn-1.6.0.ebuild
@@ -1,17 +1,18 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-1.6.0.ebuild,v 1.7 2005/02/05 16:59:59 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-1.6.0.ebuild,v 1.8 2005/05/01 09:02:35 luckyduck Exp $
inherit gnuconfig
-IUSE="ssl threads"
DESCRIPTION="OpenVPN is a robust and highly flexible tunneling application compatible with many OSes."
SRC_URI="mirror://sourceforge/openvpn/${P}.tar.gz"
HOMEPAGE="http://openvpn.sourceforge.net/"
-SLOT="0"
+
LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~ppc-macos ~amd64"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc ~alpha ~ppc-macos amd64"
+IUSE="ssl threads"
RDEPEND=">=dev-libs/lzo-1.07
ssl? ( >=dev-libs/openssl-0.9.6 )"
@@ -24,24 +25,25 @@ src_unpack() {
src_compile() {
econf \
- `use_enable ssl` \
- `use_enable ssl crypto` \
- `use_enable threads pthread` \
- || die
- emake || die
+ $(use_enable ssl) \
+ $(use_enable ssl crypto) \
+ $(use_enable threads pthread) \
+ || die "configure failed"
+ emake || die "make failed"
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR=${D} install || die "make install failed"
- dodoc COPYING ChangeLog INSTALL PORTS README
+ dodoc ChangeLog INSTALL PORTS README
exeinto /etc/init.d
doexe ${FILESDIR}/openvpn
}
-
pkg_postinst() {
- einfo "The init.d script that comes with OpenVPN expects directories /etc/openvpn/*/ with a local.conf and any supporting files, such as keys."
+ einfo "The init.d script that comes with OpenVPN expects directories"
+ einfo "/etc/openvpn/*/ with a local.conf and any supporting files,"
+ einfo "such as keys."
ewarn "This version of OpenVPN is NOT COMPATIBLE with 1.4.2!"
ewarn "If you need compatibility with 1.4.2 please emerge that version."
}