summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2005-11-08 13:19:41 +0000
committerRoy Marples <uberlord@gentoo.org>2005-11-08 13:19:41 +0000
commit24daff5eb469bd51a0c57d14e54db60079f95c44 (patch)
tree23e1f11cde8c3cb8a89e2e79563587a8f6be1d59 /net-misc/openvpn/openvpn-2.0.4-r2.ebuild
parent'examples' IUSE flag (bug #111508) (diff)
downloadgentoo-2-24daff5eb469bd51a0c57d14e54db60079f95c44.tar.gz
gentoo-2-24daff5eb469bd51a0c57d14e54db60079f95c44.tar.bz2
gentoo-2-24daff5eb469bd51a0c57d14e54db60079f95c44.zip
Punted a few versions
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'net-misc/openvpn/openvpn-2.0.4-r2.ebuild')
-rw-r--r--net-misc/openvpn/openvpn-2.0.4-r2.ebuild127
1 files changed, 0 insertions, 127 deletions
diff --git a/net-misc/openvpn/openvpn-2.0.4-r2.ebuild b/net-misc/openvpn/openvpn-2.0.4-r2.ebuild
deleted file mode 100644
index 738090b9b21f..000000000000
--- a/net-misc/openvpn/openvpn-2.0.4-r2.ebuild
+++ /dev/null
@@ -1,127 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-2.0.4-r2.ebuild,v 1.3 2005/11/03 14:36:55 uberlord Exp $
-
-inherit eutils gnuconfig multilib
-
-DESCRIPTION="OpenVPN is a robust and highly flexible tunneling application compatible with many OSes."
-SRC_URI="http://openvpn.net/release/openvpn-${PV}.tar.gz"
-HOMEPAGE="http://openvpn.net/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~ppc-macos ~sparc ~x86"
-IUSE="examples iproute2 minimal pam passwordsave selinux ssl static threads"
-
-RDEPEND=">=dev-libs/lzo-1.07
- kernel_linux? (
- iproute2? ( sys-apps/iproute2 ) !iproute2? ( sys-apps/net-tools )
- )
- !minimal? ( pam? ( virtual/pam ) )
- selinux? ( sec-policy/selinux-openvpn )
- ssl? ( >=dev-libs/openssl-0.9.6 )"
-DEPEND="${RDEPEND}
- virtual/os-headers"
-
-src_unpack() {
- unpack "${A}"
- gnuconfig_update
- epatch "${FILESDIR}/${P}"-darwin.patch
-}
-
-src_compile() {
- local myconf=""
- # We cannot use use_enable with iproute2 as the Makefile stupidly
- # enables it with --disable-iproute2
- use iproute2 && myconf="${myconf} --enable-iproute2"
- use minimal && myconf="${myconf} --disable-plugins"
-
- econf ${myconf} \
- $(use_enable passwordsave password-save) \
- $(use_enable ssl) \
- $(use_enable ssl crypto) \
- $(use_enable threads pthread) \
- || die "configure failed"
-
- use static && sed -e -i '/^LIBS/s/LIBS = /LIBS = -static /' Makefile
-
- emake || die "make failed"
-
- if ! use minimal ; then
- cd plugin
- for i in $( ls 2>/dev/null ); do
- [[ ${i} == "README" || ${i} == "examples" ]] && continue
- [[ ${i} == "auth-pam" ]] && ! use pam && continue
- einfo "Building ${i} plugin"
- cd "${i}"
- emake || die "make failed"
- cd ..
- done
- cd ..
- fi
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
-
- # install documentation
- dodoc AUTHORS ChangeLog INSTALL PORTS README
-
- # Empty dir
- dodir /etc/openvpn
- keepdir /etc/openvpn
-
- # Install the init script
- newinitd "${FILESDIR}/openvpn.init" openvpn
-
- # Install easy-rsa stuff
- exeinto "/usr/share/${PN}/easy-rsa"
- doexe easy-rsa/*-*
- insinto "/usr/share/${PN}/easy-rsa"
- doins easy-rsa/{README,openssl.cnf,vars}
-
- # install examples, controlled by the respective useflag
- if use examples ; then
- # dodoc does not supportly support directory traversal, #15193
- insinto /usr/share/doc/${PF}/examples
- doins -r sample-{config-files,keys,scripts} contrib
- prepalldocs
- fi
-
- # Install plugins
- if ! use minimal ; then
- exeinto "/usr/$(get_libdir)/${PN}"
- doexe plugin/*/*.so
- fi
-}
-
-pkg_postinst() {
- ewarn "WARNING: The openvpn init script has changed"
- ewarn ""
- einfo "The openvpn init script expects to find the configuration file"
- einfo "openvpn.conf in /etc/openvpn along with any extra files it may need."
- einfo ""
- einfo "To create more VPNs, simply create a new .conf file for it and"
- einfo "then create a symlink to the openvpn init script from a link called"
- einfo "openvpn.newconfname - like so"
- einfo " cd /etc/openvpn"
- einfo " ${EDITOR##*/} foo.conf"
- einfo " cd /etc/init.d"
- einfo " ln -s openvpn openvpn.foo"
- einfo ""
- einfo "You can then treat openvpn.foo as any other service, so you can"
- einfo "stop one vpn and start another if you need to."
- if ! use minimal ; then
- einfo ""
- einfo "plugins have been installed into /usr/$(get_libdir)/${PN}"
- fi
- einfo ""
- einfo "It is recommended that you create your tun/tap interfaces using"
- einfo "the net.tun0/net.tap0 scripts provided by baselayout instead of"
- einfo "using the 'server' directive in openvpn configuration files."
- einfo "This will insure that the interface really is up after openvpn"
- einfo "starts."
- einfo "Note that you cannot use net.tun0/net.tap0 and the server option,"
- einfo "otherwise openvpn will not start."
- ebeep
-}