summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-04-22 16:19:44 +0000
committerJeroen Roovers <jer@gentoo.org>2011-04-22 16:19:44 +0000
commitf6ed60f27d6ad8cd992d75d0712d6bc4fc5017e2 (patch)
treea71deb4f608c233b1180fff34656c016fea1d484 /net-misc/pipes/pipes-1.16.1.ebuild
parentVersion bump, bug 364481. (diff)
downloadgentoo-2-f6ed60f27d6ad8cd992d75d0712d6bc4fc5017e2.tar.gz
gentoo-2-f6ed60f27d6ad8cd992d75d0712d6bc4fc5017e2.tar.bz2
gentoo-2-f6ed60f27d6ad8cd992d75d0712d6bc4fc5017e2.zip
Do not hardcode flags in Makefile.
(Portage version: 2.2.0_alpha30/cvs/Linux i686)
Diffstat (limited to 'net-misc/pipes/pipes-1.16.1.ebuild')
-rw-r--r--net-misc/pipes/pipes-1.16.1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/net-misc/pipes/pipes-1.16.1.ebuild b/net-misc/pipes/pipes-1.16.1.ebuild
index 5d6ef2235527..8e70aa055c2a 100644
--- a/net-misc/pipes/pipes-1.16.1.ebuild
+++ b/net-misc/pipes/pipes-1.16.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pipes/pipes-1.16.1.ebuild,v 1.1 2011/04/22 16:07:20 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pipes/pipes-1.16.1.ebuild,v 1.2 2011/04/22 16:19:44 jer Exp $
EAPI="3"
@@ -20,12 +20,13 @@ DEPEND="${RDEPEND}
>=sys-apps/sed-4"
src_prepare() {
- sed -i Makefile -e "s:-O2:${CFLAGS}:" || die
+ #sed -i Makefile -e 's:-O2:$(CFLAGS):' || die
+ # Prevent the build system from looking for dependencies
touch .depend
}
src_compile() {
- emake CC=$(tc-getCC) LDFLAGS="${CFLAGS} ${LDFLAGS}" || die "emake failed"
+ emake CC=$(tc-getCC) OPTIM="${CFLAGS}" LDFLAGS="${CFLAGS} ${LDFLAGS}" || die
}
src_install() {