summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-01 12:32:03 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-01 12:32:03 +0000
commit00d423b3eba49e874b796c2cadb7269aeb51914d (patch)
tree4d87be357338ce23e75b5d63fad0ca0031b80d08 /net-misc/proxytunnel
parentMarked stable on x86. (Manifest recommit) (diff)
downloadgentoo-2-00d423b3eba49e874b796c2cadb7269aeb51914d.tar.gz
gentoo-2-00d423b3eba49e874b796c2cadb7269aeb51914d.tar.bz2
gentoo-2-00d423b3eba49e874b796c2cadb7269aeb51914d.zip
security bump #66003
Diffstat (limited to 'net-misc/proxytunnel')
-rw-r--r--net-misc/proxytunnel/ChangeLog7
-rw-r--r--net-misc/proxytunnel/files/digest-proxytunnel-1.2.01
-rw-r--r--net-misc/proxytunnel/proxytunnel-1.2.0.ebuild32
3 files changed, 39 insertions, 1 deletions
diff --git a/net-misc/proxytunnel/ChangeLog b/net-misc/proxytunnel/ChangeLog
index 35043f66731c..bf8999d02afd 100644
--- a/net-misc/proxytunnel/ChangeLog
+++ b/net-misc/proxytunnel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/proxytunnel
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/proxytunnel/ChangeLog,v 1.3 2004/07/01 21:45:18 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/proxytunnel/ChangeLog,v 1.4 2004/10/01 12:32:03 vapier Exp $
+
+*proxytunnel-1.2.0 (01 Oct 2004)
+
+ 01 Oct 2004; Mike Frysinger <vapier@gentoo.org> +proxytunnel-1.2.0.ebuild:
+ Version bump for security #66003.
01 Jul 2004; Jon Hood <squinky86@gentoo.org> proxytunnel-1.1.3.ebuild:
change virtual/glibc to virtual/libc, add IUSE
diff --git a/net-misc/proxytunnel/files/digest-proxytunnel-1.2.0 b/net-misc/proxytunnel/files/digest-proxytunnel-1.2.0
new file mode 100644
index 000000000000..964c231cbca4
--- /dev/null
+++ b/net-misc/proxytunnel/files/digest-proxytunnel-1.2.0
@@ -0,0 +1 @@
+MD5 a6bfbd5176e4360ee6d544cadfd5c90d proxytunnel-1.2.0.tgz 24748
diff --git a/net-misc/proxytunnel/proxytunnel-1.2.0.ebuild b/net-misc/proxytunnel/proxytunnel-1.2.0.ebuild
new file mode 100644
index 000000000000..32f3f01576d2
--- /dev/null
+++ b/net-misc/proxytunnel/proxytunnel-1.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/proxytunnel/proxytunnel-1.2.0.ebuild,v 1.1 2004/10/01 12:32:03 vapier Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="program that connects stdin and stdout to a server somewhere on the network, through a standard HTTPS proxy"
+HOMEPAGE="http://proxytunnel.sourceforge.net/"
+SRC_URI="mirror://sourceforge/proxytunnel/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="static"
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-makefile.patch
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+ dodoc CHANGES CREDITS README
+}