summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2008-12-23 16:30:51 +0000
committerMike Pagano <mpagano@gentoo.org>2008-12-23 16:30:51 +0000
commitfe25612256826347ad08f2c81a2cb8697bf61cc3 (patch)
treeab2fda43279cd95597fdcf3378574c24d441bc55 /net-misc/pump
parentSign Manfiest (diff)
downloadgentoo-2-fe25612256826347ad08f2c81a2cb8697bf61cc3.tar.gz
gentoo-2-fe25612256826347ad08f2c81a2cb8697bf61cc3.tar.bz2
gentoo-2-fe25612256826347ad08f2c81a2cb8697bf61cc3.zip
Add version that builds and works wrt bug #198121 (gcc43).
(Portage version: 2.2_rc18/cvs/Linux 2.6.27-gentoo-r4 i686)
Diffstat (limited to 'net-misc/pump')
-rw-r--r--net-misc/pump/ChangeLog9
-rw-r--r--net-misc/pump/pump-0.8.24-r1.ebuild66
2 files changed, 73 insertions, 2 deletions
diff --git a/net-misc/pump/ChangeLog b/net-misc/pump/ChangeLog
index 72abc838e464..73ff76e45797 100644
--- a/net-misc/pump/ChangeLog
+++ b/net-misc/pump/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/pump
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pump/ChangeLog,v 1.39 2007/12/29 20:04:20 phreak Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pump/ChangeLog,v 1.40 2008/12/23 16:30:51 mpagano Exp $
+
+*pump-0.8.24-r1 (23 Dec 2008)
+
+ 23 Dec 2008; Mike Pagano <mpagano@gentoo.org> +pump-0.8.24-r1.ebuild:
+ Add version that builds and works wrt bug #198121 (gcc43).
29 Dec 2007; Christian Heim <phreak@gentoo.org>
+files/pump-0.8.24-redefinition.patch, pump-0.8.24.ebuild:
diff --git a/net-misc/pump/pump-0.8.24-r1.ebuild b/net-misc/pump/pump-0.8.24-r1.ebuild
new file mode 100644
index 000000000000..d8d77eaa0c59
--- /dev/null
+++ b/net-misc/pump/pump-0.8.24-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pump/pump-0.8.24-r1.ebuild,v 1.1 2008/12/23 16:30:51 mpagano Exp $
+
+inherit eutils
+
+PATCHLEVEL="5"
+
+DESCRIPTION="This is the DHCP/BOOTP client written by RedHat"
+HOMEPAGE="http://ftp.debian.org/debian/pool/main/p/pump/"
+SRC_URI="mirror://debian/pool/main/p/${PN}/${PN}_${PV}.orig.tar.gz
+ mirror://debian/pool/main/p/${PN}/${PN}_${PV}-${PATCHLEVEL}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/popt-1.5"
+PROVIDE="virtual/dhcpc"
+
+src_unpack() {
+ cd "${WORKDIR}"
+ unpack "${PN}_${PV}.orig.tar.gz"
+ cd "${S}"
+
+ # Apply Debians pump patchset - they fix things good :)
+ epatch "${DISTDIR}/${PN}_${PV}-${PATCHLEVEL}.diff.gz"
+
+ # Enable the -m (--route-metric) option to specify the default
+ # metric applied to routes
+ # Enable the --keep-up option to keep interfaces up when we release
+ # Enable the creation of /etc/ntp.conf and the --no-ntp option
+ epatch "${FILESDIR}/pump-${PV}-gentoo.patch"
+
+ # Add an if defined around the definition of foo, just like in popt.h
+ epatch "${FILESDIR}/${P}-redefinition.patch"
+
+ # Only install specific po files if LINGUAS is set
+ if [[ -n ${LINGUAS} ]]; then
+ cd po
+ local p
+ for l in $(ls *.po) ; do
+ [[ " ${LINGUAS} " != *" ${l%%.po} "* ]] && rm -f "${l}"
+ done
+ fi
+}
+
+src_compile() {
+ make DEB_CFLAGS="-fPIC ${CFLAGS}" pump || die
+}
+
+src_install() {
+ into /
+ dosbin pump || die
+
+ doman pump.8
+ dodoc CREDITS
+
+ into /usr
+ dolib.a libpump.a || die
+ insinto /usr/include
+ doins pump.h || die
+
+ make -C po install datadir="${D}/usr/share/"
+}