summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-08-20 23:06:29 +0000
committerJeroen Roovers <jer@gentoo.org>2014-08-20 23:06:29 +0000
commitcecc797b29b545807580f2a194ade1f47b1cade4 (patch)
tree7441391fd04059d4a46f0cc2dee71f76aeb1f343 /net-misc/putty
parentOld. (diff)
downloadgentoo-2-cecc797b29b545807580f2a194ade1f47b1cade4.tar.gz
gentoo-2-cecc797b29b545807580f2a194ade1f47b1cade4.tar.bz2
gentoo-2-cecc797b29b545807580f2a194ade1f47b1cade4.zip
Snapshot bump.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-misc/putty')
-rw-r--r--net-misc/putty/ChangeLog7
-rw-r--r--net-misc/putty/putty-0.63_p20140820.ebuild88
2 files changed, 94 insertions, 1 deletions
diff --git a/net-misc/putty/ChangeLog b/net-misc/putty/ChangeLog
index 3a3916cda23a..5fee296328e9 100644
--- a/net-misc/putty/ChangeLog
+++ b/net-misc/putty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/putty
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/ChangeLog,v 1.94 2014/04/16 15:53:52 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/ChangeLog,v 1.95 2014/08/20 23:06:29 jer Exp $
+
+*putty-0.63_p20140820 (20 Aug 2014)
+
+ 20 Aug 2014; Jeroen Roovers <jer@gentoo.org> +putty-0.63_p20140820.ebuild:
+ Snapshot bump.
*putty-0.63_p20140416 (16 Apr 2014)
diff --git a/net-misc/putty/putty-0.63_p20140820.ebuild b/net-misc/putty/putty-0.63_p20140820.ebuild
new file mode 100644
index 000000000000..322489edbdea
--- /dev/null
+++ b/net-misc/putty/putty-0.63_p20140820.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/putty-0.63_p20140820.ebuild,v 1.1 2014/08/20 23:06:29 jer Exp $
+
+EAPI=5
+inherit autotools eutils gnome2-utils toolchain-funcs versionator
+
+DESCRIPTION="A Free Telnet/SSH Client"
+HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/putty/"
+SRC_URI="
+ http://dev.gentoo.org/~jer/${P/_p*/}-2014-08-20.tar.gz
+ http://dev.gentoo.org/~jer/${PN}-icons.tar.bz2
+"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="doc +gtk ipv6 kerberos"
+
+S=${WORKDIR}/${P/_p*/}-2014-08-20
+
+RDEPEND="
+ !net-misc/pssh
+ kerberos? ( virtual/krb5 )
+ gtk? ( x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/pango
+ dev-libs/glib )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-lang/perl
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ sed -i \
+ -e '/AM_PATH_GTK(/d' \
+ -e 's|-Werror||g' \
+ configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ cd "${S}"/unix || die
+ econf \
+ $(use_with kerberos gssapi) \
+ $(use_with gtk)
+}
+
+src_compile() {
+ cd "${S}"/unix || die
+ emake AR=$(tc-getAR) $(usex ipv6 '' COMPAT=-DNO_IPV6)
+}
+
+src_install() {
+ dodoc doc/puttydoc.txt
+
+ if use doc; then
+ dohtml doc/*.html
+ fi
+
+ cd "${S}"/unix || die
+ default
+
+ if use gtk ; then
+ for i in 16 22 24 32 48 64 128 256; do
+ newicon -s ${i} "${WORKDIR}"/${PN}-icons/${PN}-${i}.png ${PN}.png
+ done
+
+ # install desktop file provided by Gustav Schaffter in #49577
+ make_desktop_entry ${PN} PuTTY ${PN} Network
+ fi
+}
+
+pkg_preinst() {
+ use gtk && gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ use gtk && gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ use gtk && gnome2_icon_cache_update
+}