summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2007-03-05 15:15:17 +0000
committerSteve Dibb <beandog@gentoo.org>2007-03-05 15:15:17 +0000
commitffb6745041fae194c906ff4378e71e723c4e3bf7 (patch)
tree9c079221543ade8bbcb3532ff3bf4a74b769f191 /net-misc/putty
parentVersion bump, bug 143900 and fix bug 146147, and assign to net-p2p herd (diff)
downloadgentoo-2-ffb6745041fae194c906ff4378e71e723c4e3bf7.tar.gz
gentoo-2-ffb6745041fae194c906ff4378e71e723c4e3bf7.tar.bz2
gentoo-2-ffb6745041fae194c906ff4378e71e723c4e3bf7.zip
Version bump
(Portage version: 2.1.2-r14)
Diffstat (limited to 'net-misc/putty')
-rw-r--r--net-misc/putty/files/digest-putty-0.593
-rw-r--r--net-misc/putty/putty-0.58.ebuild4
-rw-r--r--net-misc/putty/putty-0.59.ebuild61
3 files changed, 66 insertions, 2 deletions
diff --git a/net-misc/putty/files/digest-putty-0.59 b/net-misc/putty/files/digest-putty-0.59
new file mode 100644
index 000000000000..b40713d1e8a5
--- /dev/null
+++ b/net-misc/putty/files/digest-putty-0.59
@@ -0,0 +1,3 @@
+MD5 2c90f3aecd2e4b41df61fb047a6c8f11 putty-0.59.tar.gz 1736071
+RMD160 dea0c6b3890760617e26d380e500fcc8b898bbeb putty-0.59.tar.gz 1736071
+SHA256 578006f899a9363a7a627fcd362fbfb4b500c3b265c389df2d1ed292a7653bbc putty-0.59.tar.gz 1736071
diff --git a/net-misc/putty/putty-0.58.ebuild b/net-misc/putty/putty-0.58.ebuild
index e81ce209d4db..0db1980da304 100644
--- a/net-misc/putty/putty-0.58.ebuild
+++ b/net-misc/putty/putty-0.58.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/putty-0.58.ebuild,v 1.7 2006/01/21 17:34:48 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/putty-0.58.ebuild,v 1.8 2007/03/05 15:15:17 beandog Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -42,7 +42,7 @@ src_install() {
dobin puttygen plink pscp psftp
cd ${S}
- dodoc README README.txt LICENCE CHECKLST.txt LATEST.VER
+ dodoc README README.txt CHECKLST.txt LATEST.VER
prepallman
diff --git a/net-misc/putty/putty-0.59.ebuild b/net-misc/putty/putty-0.59.ebuild
new file mode 100644
index 000000000000..e9ed09be34fa
--- /dev/null
+++ b/net-misc/putty/putty-0.59.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/putty-0.59.ebuild,v 1.1 2007/03/05 15:15:17 beandog Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="UNIX port of the famous Telnet and SSH client"
+HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/putty/"
+SRC_URI="http://the.earth.li/~sgtatham/putty/${PV}/${P}.tar.gz"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="doc gtk ipv6"
+
+RDEPEND="gtk? ( =x11-libs/gtk+-1.2* )"
+DEPEND="${RDEPEND} dev-lang/perl"
+
+src_compile() {
+ use gtk && unset ptargets || local ptargets="puttygen plink pscp psftp"
+
+ cd ${S}/unix
+
+ append-flags '-I.././' '-I../charset/' '-I../unix/'
+
+ use ipv6 || append-flags '-DNO_IPV6'
+ use gtk && append-flags '`gtk-config --cflags`'
+
+ emake -f Makefile.gtk ${ptargets:-all} CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ cd ${S}/doc
+ use gtk && doman pterm.1 putty.1 puttytel.1
+ use doc && dohtml *.html
+ dodoc puttydoc.txt
+ doman puttygen.1 plink.1
+
+ cd ${S}/unix
+ use gtk && dobin pterm putty puttytel
+ dobin puttygen plink pscp psftp
+
+ cd ${S}
+ dodoc README README.txt CHECKLST.txt LATEST.VER
+
+ prepallman
+
+ # install desktop file provided by Gustav Schaffter in #49577
+ use gtk && {
+ dodir /usr/share/applications
+ insinto /usr/share/applications
+ doins ${FILESDIR}/putty.desktop
+ }
+
+ if test ! -c /dev/ptmx; then
+ ewarn
+ ewarn "The pterm application requires kernel UNIX98 PTY support to operate."
+ ewarn
+ fi
+}