summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-02-10 10:32:00 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-02-10 10:32:00 +0000
commit8fd15682e87b5fd2dc67143c0a7efff93c646c8c (patch)
tree641923b42c18858a859ca0fcd2906383ad3f193c /net-misc/rdesktop/rdesktop-1.1.0-r1.ebuild
parentsed expression fixups, filesdir cleanups (diff)
downloadgentoo-2-8fd15682e87b5fd2dc67143c0a7efff93c646c8c.tar.gz
gentoo-2-8fd15682e87b5fd2dc67143c0a7efff93c646c8c.tar.bz2
gentoo-2-8fd15682e87b5fd2dc67143c0a7efff93c646c8c.zip
sed fixes and other misc
Diffstat (limited to 'net-misc/rdesktop/rdesktop-1.1.0-r1.ebuild')
-rw-r--r--net-misc/rdesktop/rdesktop-1.1.0-r1.ebuild23
1 files changed, 16 insertions, 7 deletions
diff --git a/net-misc/rdesktop/rdesktop-1.1.0-r1.ebuild b/net-misc/rdesktop/rdesktop-1.1.0-r1.ebuild
index e1209ad2254f..b7d9a876bd3f 100644
--- a/net-misc/rdesktop/rdesktop-1.1.0-r1.ebuild
+++ b/net-misc/rdesktop/rdesktop-1.1.0-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/rdesktop/rdesktop-1.1.0-r1.ebuild,v 1.9 2002/12/09 04:33:18 manson Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rdesktop/rdesktop-1.1.0-r1.ebuild,v 1.10 2003/02/10 10:32:00 seemant Exp $
IUSE="ssl"
@@ -9,25 +9,34 @@ DESCRIPTION="A Remote Desktop Protocol Client"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
HOMEPAGE="http://rdesktop.sourceforge.net/"
-KEYWORDS="x86 ppc sparc "
-DEPEND="x11-base/xfree ssl? ( >=dev-libs/openssl-0.9.6b )"
-LICENSE="GPL-2"
SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc"
+
+DEPEND="virtual/x11
+ ssl? ( >=dev-libs/openssl-0.9.6b )"
src_compile() {
local myconf
use ssl && myconf="--with-openssl"
use ssl || myconf="--without-openssl"
+
[ "${DEBUG}" ] && myconf="${myconf} --with-debug"
+
./configure \
--prefix=/usr \
- --mandir=/usr/share/man $myconf || die
+ --mandir=/usr/share/man \
+ ${myconf} || die
+
use ssl && echo "CFLAGS += -I/usr/include/openssl" >> Makeconf
+
# Hold on tight folks, this ain't purdy
if [ ! -z "${CXXFLAGS}" ]; then
- sed -e 's/-O2//g' Makefile > Makefile.tmp && mv Makefile.tmp Makefile
+ sed -e 's:-O2::g' Makefile > Makefile.tmp
+ mv Makefile.tmp Makefile
echo "CFLAGS += ${CXXFLAGS}" >> Makeconf
fi
+
emake || die "compile problem"
}