summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Keadle <mkeadle@gentoo.org>2002-11-06 01:24:48 +0000
committerMatt Keadle <mkeadle@gentoo.org>2002-11-06 01:24:48 +0000
commit37845aa08b2e240e9a770707c4ad54c047d84282 (patch)
treea596d8e0c896da6df26be3213d01864ef81b9f87 /net-misc/rwbs
parentInital commit (diff)
downloadgentoo-2-37845aa08b2e240e9a770707c4ad54c047d84282.tar.gz
gentoo-2-37845aa08b2e240e9a770707c4ad54c047d84282.tar.bz2
gentoo-2-37845aa08b2e240e9a770707c4ad54c047d84282.zip
Initial import of rwbs. ~keyworded for testing by more knowledgable users.
Diffstat (limited to 'net-misc/rwbs')
-rw-r--r--net-misc/rwbs/ChangeLog12
-rw-r--r--net-misc/rwbs/files/digest-rwbs-0.271
-rw-r--r--net-misc/rwbs/rwbs-0.27.ebuild85
3 files changed, 98 insertions, 0 deletions
diff --git a/net-misc/rwbs/ChangeLog b/net-misc/rwbs/ChangeLog
new file mode 100644
index 000000000000..0a2f3622202f
--- /dev/null
+++ b/net-misc/rwbs/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for net-misc/rwbs
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header
+
+*rwbs-0.27 (5 Nov 2002)
+
+ 5 Nov 2002; Matt Keadle <mkeadle@gentoo.org> rwbs-0.27.ebuild
+ ChangeLog files/digest-rwbs-0.27:
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. Thanks to "delta407" for submitting this
+ ebuild.
diff --git a/net-misc/rwbs/files/digest-rwbs-0.27 b/net-misc/rwbs/files/digest-rwbs-0.27
new file mode 100644
index 000000000000..a66c385eea12
--- /dev/null
+++ b/net-misc/rwbs/files/digest-rwbs-0.27
@@ -0,0 +1 @@
+MD5 95daaee2671d4eef285f0a8347482d50 rwbs_Linux_0_27.tar.gz 365489
diff --git a/net-misc/rwbs/rwbs-0.27.ebuild b/net-misc/rwbs/rwbs-0.27.ebuild
new file mode 100644
index 000000000000..3e8f23b876dd
--- /dev/null
+++ b/net-misc/rwbs/rwbs-0.27.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+S=${WORKDIR}
+
+DESCRIPTION="Roger Wilco base station"
+HOMEPAGE="http://rogerwilco.gamespy.com/"
+SRC_URI="http://games.gci.net/pub/VoiceOverIP/RogerWilco/rwbs_Linux_0_27.tar.gz"
+KEYWORDS="~x86"
+# Everything is statically linked
+DEPEND=""
+IUSE=""
+
+src_install () {
+ cd ${WORKDIR}
+ dodoc README.TXT CHANGES.TXT LICENSE.TXT
+
+ dobin ${S}/rwbs ${S}/run_rwbs
+ rm -f ${S}/rwbs ${S}/run_rwbs
+
+ # Put distribution into /usr/share/rwbs
+ mkdir -p ${D}/usr/share/rwbs/
+ mv * ${D}/usr/share/rwbs/
+
+ # Do conf script
+ mkdir -p ${D}/etc/conf.d/
+ cat > ${D}/etc/conf.d/rwbs <<EOF
+# Roger Wilco base station configuration
+#
+# $ rwbs --help reads:
+# usage: ./rwbs [-b(ackwardcompat)] [-t(est)] [-s(tatic)] [-p <passwd>] [-u <udpport>] [-x <connectspeed>] [-n <hostname>]
+# connectspeed is an integer measuring the allocated broadcast
+# capacity for the channel host. The recommended value is 1.
+# Higher values will cause the RWBS to use its additional broadcast capacity
+# to help relay transmissions, at the expense of scalability.
+# the b(ackwardcompat) option tells RWBS to appear as a "user" on the
+# channel. Mark I users will prefer this, but not Mark Ia users.
+# The s(tatic) option indicates that a client asking to join a
+# non-existent named channel should be turned away with an error.
+# rather than being hosted on a dynamically-created channel.
+# hostname is what your station's name will be in the Roger Wilco Channel Tab.
+# For instance, if you used -n "Clan Hurt", Roger Wilco users will see
+# an entry in the Channel window named "Clan Hurt Base"
+# If the -t(est) flag is used, the base station echoes transmissions
+# when there is just one other party on the channel.
+
+# Specify whatever options you want on this line
+RWBS_OPTS='-n "Gentoo Linux"'
+EOF
+
+ # do init script
+ mkdir -p ${D}/etc/init.d/
+ cat > ${D}/etc/init.d/rwbs <<EOF
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting Roger Wilco base station"
+ start-stop-daemon --start --quiet --exec /usr/bin/rwbs -b \\
+ -- \${RWBS_OPTS} >>/var/log/rwbs 2>&1
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Roger Wilco base station"
+ start-stop-daemon --stop --quiet --exec /usr/bin/rwbs \\
+ > /dev/null 2>&1
+ eend $?
+}
+EOF
+ chmod 755 ${D}/etc/init.d/rwbs
+}
+
+pkg_postinst() {
+ einfo
+ einfo "This build of ${PN} uses an init script, located at"
+ einfo "/etc/init.d/rwbs, to start and stop ${PN}."
+ einfo
+}