summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-01-24 15:55:03 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-01-24 15:55:03 +0000
commiteb76c47e96fd14a3ec2ee5a7d8ec1403c44c1630 (patch)
tree0304bb761b5afb908a4b8bea3bb1251f9f6fa6b5 /net-misc/siproxd/siproxd-0.8.0-r2.ebuild
parentRemoved old (diff)
downloadgentoo-2-eb76c47e96fd14a3ec2ee5a7d8ec1403c44c1630.tar.gz
gentoo-2-eb76c47e96fd14a3ec2ee5a7d8ec1403c44c1630.tar.bz2
gentoo-2-eb76c47e96fd14a3ec2ee5a7d8ec1403c44c1630.zip
Avoid mantainer-mode automake calls by properly re-building autotools.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/siproxd/siproxd-0.8.0-r2.ebuild')
-rw-r--r--net-misc/siproxd/siproxd-0.8.0-r2.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/net-misc/siproxd/siproxd-0.8.0-r2.ebuild b/net-misc/siproxd/siproxd-0.8.0-r2.ebuild
index 5b9f95f9e823..fbbf1497ec82 100644
--- a/net-misc/siproxd/siproxd-0.8.0-r2.ebuild
+++ b/net-misc/siproxd/siproxd-0.8.0-r2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/siproxd/siproxd-0.8.0-r2.ebuild,v 1.1 2011/01/20 16:39:28 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/siproxd/siproxd-0.8.0-r2.ebuild,v 1.2 2011/01/24 15:55:03 flameeyes Exp $
EAPI="2"
-inherit eutils
+inherit eutils autotools
DESCRIPTION="A proxy/masquerading daemon for the SIP protocol"
HOMEPAGE="http://siproxd.sourceforge.net/"
@@ -36,10 +36,12 @@ src_prepare() {
sed -i -e "s:nobody:siproxd:" doc/siproxd.conf.example \
|| die "patching doc/siproxd.conf.example failed"
# do not fail when building with external libltdl
- sed -i 's/libltdl //' Makefile.in Makefile.am || die "patching Makefile failed"
+ sed -i 's/libltdl //' Makefile.am || die "patching Makefile failed"
epatch "${FILESDIR}/${PN}-libtool-2.4.patch"
# do not crash when building with external libltdl, bug 308495
sed -i 's|"../libltdl/ltdl.h"|<ltdl.h>|' src/plugins.h || die "patching plugins.h failed"
+
+ eautoreconf
}
src_configure() {