summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Weiler <pylon@gentoo.org>2007-01-20 00:20:39 +0000
committerLars Weiler <pylon@gentoo.org>2007-01-20 00:20:39 +0000
commit254103ac962ab953e1014a0f91b8bd7c7949ef9f (patch)
treeb49bf1f9ae963885835e31dcb75143767d307167 /net-misc/strongswan/strongswan-2.8.0.ebuild
parent>=net-misc/strongswan-2.8.1; 't compile on a stable system (diff)
downloadgentoo-2-254103ac962ab953e1014a0f91b8bd7c7949ef9f.tar.gz
gentoo-2-254103ac962ab953e1014a0f91b8bd7c7949ef9f.tar.bz2
gentoo-2-254103ac962ab953e1014a0f91b8bd7c7949ef9f.zip
Version bump (currently masked due to compile problems on a stable system)
and a patch for newer linux-headers; bug #162811. (Portage version: 2.1.2-r1)
Diffstat (limited to 'net-misc/strongswan/strongswan-2.8.0.ebuild')
-rw-r--r--net-misc/strongswan/strongswan-2.8.0.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/net-misc/strongswan/strongswan-2.8.0.ebuild b/net-misc/strongswan/strongswan-2.8.0.ebuild
index 6ca1a2ec9291..b02bbc031cf0 100644
--- a/net-misc/strongswan/strongswan-2.8.0.ebuild
+++ b/net-misc/strongswan/strongswan-2.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/strongswan/strongswan-2.8.0.ebuild,v 1.6 2007/01/18 19:25:04 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/strongswan/strongswan-2.8.0.ebuild,v 1.7 2007/01/20 00:20:38 pylon Exp $
inherit eutils linux-info
@@ -55,6 +55,11 @@ src_unpack() {
epatch ${FILESDIR}/ipsec-path.patch.bz2
+ # Fix for newer sys-kernel/linux-headers; bug #162811
+ if has_version ">=sys-kernel/linux-headers-2.6.18" ; then
+ epatch ${FILESDIR}/linux-headers-2.6.18.patch
+ fi
+
if use curl ; then
ebegin "Curl support requested. Enabling curl support"
sed -i -e 's:\(USE_LIBCURL?=\)false:\1true:g' Makefile.inc || die
@@ -67,11 +72,13 @@ src_unpack() {
eend $?
fi
- if use smartcard ; then
+ if use smartcard ; then
ebegin "Smartcard support requested. Enabling opensc support"
sed -i -e 's:\(USE_SMARTCARD?=\)false:\1true:g' Makefile.inc || die
- sed -i -e 's:\(PKCS11_DEFAULT_LIB=\\\"/usr/lib/pkcs11/opensc-pkcs11.so\\\"\):#\1:g' Makefile.inc || die
- sed -i -e 's:#\(PKCS11_DEFAULT_LIB=\\\"/usr/lib/opensc-pkcs11.so\\\"\):\1:g' Makefile.inc || die
+ sed -i -e 's:\(PKCS11_DEFAULT_LIB=\\\"/usr/lib/pkcs11/opensc-pkcs11.so\\\"\):#\1:g' \
+ Makefile.inc || die
+ sed -i -e 's:#\(PKCS11_DEFAULT_LIB=\\\"/usr/lib/opensc-pkcs11.so\\\"\):\1:g' \
+ Makefile.inc || die
eend $?
fi