summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-10-19 08:47:01 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-10-19 08:47:01 +0000
commit41908285af3fd6cc940667b702083ed2570a069d (patch)
tree1820cbc6216e731b2c112631aae8c79f0b84a30f /net-misc/stunnel
parentadded prefix support (bug #435580) (diff)
downloadgentoo-2-41908285af3fd6cc940667b702083ed2570a069d.tar.gz
gentoo-2-41908285af3fd6cc940667b702083ed2570a069d.tar.bz2
gentoo-2-41908285af3fd6cc940667b702083ed2570a069d.zip
added prefix support (bug #435792)
(Portage version: 2.2.0_alpha141/cvs/Linux i686, signed Manifest commit with key C2000586)
Diffstat (limited to 'net-misc/stunnel')
-rw-r--r--net-misc/stunnel/ChangeLog5
-rw-r--r--net-misc/stunnel/stunnel-4.44-r1.ebuild25
2 files changed, 17 insertions, 13 deletions
diff --git a/net-misc/stunnel/ChangeLog b/net-misc/stunnel/ChangeLog
index 2d3d7b793fd2..769ed2b6809a 100644
--- a/net-misc/stunnel/ChangeLog
+++ b/net-misc/stunnel/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-misc/stunnel
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/ChangeLog,v 1.130 2012/05/13 21:13:57 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/ChangeLog,v 1.131 2012/10/19 08:47:01 ottxor Exp $
+
+ 19 Oct 2012; Christoph Junghans <ottxor@gentoo.org> stunnel-4.44-r1.ebuild:
+ added prefix support (bug #435792)
13 May 2012; Lance Albertson <ramereth@gentoo.org>
-files/stunnel-4.21-libwrap.patch, -stunnel-4.25.ebuild,
diff --git a/net-misc/stunnel/stunnel-4.44-r1.ebuild b/net-misc/stunnel/stunnel-4.44-r1.ebuild
index 23ec1e5a12c8..76d4418eb3c4 100644
--- a/net-misc/stunnel/stunnel-4.44-r1.ebuild
+++ b/net-misc/stunnel/stunnel-4.44-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/stunnel-4.44-r1.ebuild,v 1.1 2012/05/13 21:08:13 ramereth Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/stunnel-4.44-r1.ebuild,v 1.2 2012/10/19 08:47:01 ottxor Exp $
-EAPI="2"
+EAPI="4"
-inherit autotools ssl-cert eutils
+inherit autotools ssl-cert eutils user
DESCRIPTION="TLS/SSL - Port Wrapper"
HOMEPAGE="http://stunnel.mirt.net/"
@@ -12,7 +12,7 @@ SRC_URI="ftp://ftp.stunnel.org/stunnel/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="ipv6 selinux tcpd xforward listen-queue"
DEPEND="tcpd? ( sys-apps/tcp-wrappers )
@@ -37,14 +37,15 @@ src_prepare() {
src_configure() {
econf $(use_enable ipv6) \
- $(use_enable tcpd libwrap) || die "econf died"
+ --with-ssl="${EPREFIX}"/usr \
+ $(use_enable tcpd libwrap)
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- rm -rf "${D}"/usr/share/doc/${PN}
- rm -f "${D}"/etc/stunnel/stunnel.conf-sample "${D}"/usr/bin/stunnel3 \
- "${D}"/usr/share/man/man8/stunnel.{fr,pl}.8
+ emake DESTDIR="${D}" install
+ rm -rf "${ED}"/usr/share/doc/${PN}
+ rm -f "${ED}"/etc/stunnel/stunnel.conf-sample "${ED}"/usr/bin/stunnel3 \
+ "${ED}"/usr/share/man/man8/stunnel.{fr,pl}.8
# The binary was moved to /usr/bin with 4.21,
# symlink for backwards compatibility
@@ -63,10 +64,10 @@ src_install() {
}
pkg_postinst() {
- if [ ! -f "${ROOT}"/etc/stunnel/stunnel.key ]; then
+ if [ ! -f "${EROOT}"/etc/stunnel/stunnel.key ]; then
install_cert /etc/stunnel/stunnel
- chown stunnel:stunnel "${ROOT}"/etc/stunnel/stunnel.{crt,csr,key,pem}
- chmod 0640 "${ROOT}"/etc/stunnel/stunnel.{crt,csr,key,pem}
+ chown stunnel:stunnel "${EROOT}"/etc/stunnel/stunnel.{crt,csr,key,pem}
+ chmod 0640 "${EROOT}"/etc/stunnel/stunnel.{crt,csr,key,pem}
fi
einfo "If you want to run multiple instances of stunnel, create a new config"