summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-04-09 04:52:09 +0000
committerJeroen Roovers <jer@gentoo.org>2010-04-09 04:52:09 +0000
commitcb7a3e1e9b88da54f6242c49f5734f9de1bb2104 (patch)
tree6cbd00cb638f8a110b1fb5265e11ae026f3ce2b5 /net-misc/tcpsound/tcpsound-0.3.1.ebuild
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-cb7a3e1e9b88da54f6242c49f5734f9de1bb2104.tar.gz
gentoo-2-cb7a3e1e9b88da54f6242c49f5734f9de1bb2104.tar.bz2
gentoo-2-cb7a3e1e9b88da54f6242c49f5734f9de1bb2104.zip
Clean up ebuild. Remove all "mktool" use. Respect LDFLAGS. Incidentally fix useless compiler flags. Make (failing) Makefile commands explicit. Finish building or die (bug #313661).
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'net-misc/tcpsound/tcpsound-0.3.1.ebuild')
-rw-r--r--net-misc/tcpsound/tcpsound-0.3.1.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/net-misc/tcpsound/tcpsound-0.3.1.ebuild b/net-misc/tcpsound/tcpsound-0.3.1.ebuild
index 7636235eaed5..c9c4846da2d3 100644
--- a/net-misc/tcpsound/tcpsound-0.3.1.ebuild
+++ b/net-misc/tcpsound/tcpsound-0.3.1.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tcpsound/tcpsound-0.3.1.ebuild,v 1.4 2010/03/29 12:20:07 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tcpsound/tcpsound-0.3.1.ebuild,v 1.5 2010/04/09 04:52:09 jer Exp $
-inherit eutils
+EAPI="2"
+
+inherit eutils toolchain-funcs
DESCRIPTION="Play sounds in response to network traffic"
HOMEPAGE="http://www.ioplex.com/~miallen/tcpsound/"
@@ -17,13 +19,12 @@ DEPEND="net-analyzer/tcpdump
media-libs/libsdl
dev-libs/libmba"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-asneeded.patch
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
}
src_compile() {
+ tc-export CC
sed -i -e "s;/usr/share/sounds:/usr/local/share/sounds;/usr/share/tcpsound;g"\
"${S}"/src/tcpsound.c "${S}"/elaborate.conf
@@ -34,9 +35,7 @@ src_compile() {
src_install() {
# Makefile expects /usr/bin to be there...
- dodir /usr/bin
- # einstall is required here
- einstall || die
+ emake DESTDIR="${D}" install || die
dodoc README.txt elaborate.conf
}