summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-05-24 16:00:53 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-05-24 16:00:53 +0000
commit126d8c49ca8a6d9522d7d581d5c9fa14d57739c7 (patch)
treeb38495d2c8a67d31813a2c6717a289c64007fc89 /net-misc/teamviewer
parentfix linking issues wrt #511128, patch by Andrei Slavoiu (diff)
downloadgentoo-2-126d8c49ca8a6d9522d7d581d5c9fa14d57739c7.tar.gz
gentoo-2-126d8c49ca8a6d9522d7d581d5c9fa14d57739c7.tar.bz2
gentoo-2-126d8c49ca8a6d9522d7d581d5c9fa14d57739c7.zip
version bump wrt #491770
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'net-misc/teamviewer')
-rw-r--r--net-misc/teamviewer/ChangeLog10
-rw-r--r--net-misc/teamviewer/files/teamviewer-9.0.27891-gentoo.patch133
-rw-r--r--net-misc/teamviewer/teamviewer-9.0.27891.ebuild147
3 files changed, 288 insertions, 2 deletions
diff --git a/net-misc/teamviewer/ChangeLog b/net-misc/teamviewer/ChangeLog
index 4e226ed43ecb..e87d0df58bec 100644
--- a/net-misc/teamviewer/ChangeLog
+++ b/net-misc/teamviewer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/teamviewer
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/teamviewer/ChangeLog,v 1.7 2013/09/21 19:52:20 hasufell Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/teamviewer/ChangeLog,v 1.8 2014/05/24 16:00:53 hasufell Exp $
+
+*teamviewer-9.0.27891 (24 May 2014)
+
+ 24 May 2014; Julian Ospald <hasufell@gentoo.org>
+ +teamviewer-9.0.27891.ebuild, +files/teamviewer-9.0.27891-gentoo.patch:
+ version bump wrt #491770
*teamviewer-8.0.20931 (21 Sep 2013)
diff --git a/net-misc/teamviewer/files/teamviewer-9.0.27891-gentoo.patch b/net-misc/teamviewer/files/teamviewer-9.0.27891-gentoo.patch
new file mode 100644
index 000000000000..7302ba78ae92
--- /dev/null
+++ b/net-misc/teamviewer/files/teamviewer-9.0.27891-gentoo.patch
@@ -0,0 +1,133 @@
+diff --git a/opt/teamviewer9/tv_bin/script/tvw_extra b/opt/teamviewer9/tv_bin/script/tvw_extra
+index 71164aa..848cd25 100644
+--- a/opt/teamviewer9/tv_bin/script/tvw_extra
++++ b/opt/teamviewer9/tv_bin/script/tvw_extra
+@@ -16,13 +16,6 @@ function PrintHelp()
+ isInstalledTV || return
+ ABecho "teamviewer --passwd [PASSWD]" "set a password (useful when installing remote (ssh)"
+ echo
+- ABecho "teamviewer --daemon status" "show current status of the TeamViewer daemon"
+- ABecho "teamviewer --daemon start" "start TeamViewer daemon"
+- ABecho "teamviewer --daemon stop" "stop TeamViewer daemon"
+- ABecho "teamviewer --daemon restart" "stop/start TeamViewer daemon"
+- ABecho "teamviewer --daemon disable" "disable TeamViewer daemon - don't start daemon on system startup"
+- ABecho "teamviewer --daemon enable" "enable TeamViewer daemon - start daemon on system startup (default)"
+- echo
+ }
+
+ function PrintVersion()
+@@ -39,19 +32,6 @@ function PrintInfo()
+ PrintTeamViewerID
+ }
+
+-function PrintDaemonStatus()
+-{
+- local cmd="$(daemonCtl 'status')"
+- local txt="n/a"
+-
+- if [ isInstalledTV ] ; then
+- txt="$(eval "$cmd")"
+- [ $? = 0 ] || txt='n/a (error)'
+- fi
+-
+- ABecho "teamviewerd status" "$txt"
+-}
+-
+ function PrintTeamViewerID()
+ {
+ local config="$TV_BASE_DIR/config/global.conf"
+@@ -64,16 +44,17 @@ function PrintTeamViewerID()
+ ABecho "TeamViewer ID:" "$tvid"
+
+ if [ -z "$tvid" ] && isInstalledTV; then
+- echo "Try restarting the TeamViewer daemon (e.g. teamviewer --daemon restart)"
++ echo "Try restarting the TeamViewer daemon."
+ fi
+ }
+
+ function SetPasswd()
+ {
++ echo "Stop your teamviewer daemon first, then press enter."
++ read
++
+ local pwd="$1"
+ [ -n "$pwd" ] || die 'no password specified'
+-
+- Run_Daemon 'stop' > /dev/null
+
+ $TV_BIN_DIR/teamviewerd --passwd "$pwd"
+ case $? in
+@@ -84,19 +65,19 @@ function SetPasswd()
+ * ) echo 'unknown response' ;;
+ esac
+
+- Run_Daemon 'start' || die 'failed to restart the daemon'
+- echo
++ echo "You may start your teamviewer daemon again."
+ }
+
+ function ExportLicense()
+ {
++ echo "Stop your teamviewer daemon first, then press enter."
++ read
++
+ local license="$1"
+ local path='/tmp/tv_global.conf'
+
+ [ -n "$license" ] || die 'no license specified'
+-
+- Run_Daemon 'stop' > /dev/null
+-
++
+ $TV_BIN_DIR/teamviewerd --export-license "$license" "$path"
+ case $? in
+ 0 ) echo "ok - license exported to '$path'" ;;
+@@ -104,8 +85,7 @@ function ExportLicense()
+ * ) echo 'unknown response' ;;
+ esac
+
+- Run_Daemon 'start' || die 'failed to restart the daemon'
+- echo
++ echo "You may start your teamviewer daemon again."
+ }
+
+ function StripPersonalInformation()
+diff --git a/opt/teamviewer9/tv_bin/script/tvw_main b/opt/teamviewer9/tv_bin/script/tvw_main
+index 8984db0..c6dff8d 100644
+--- a/opt/teamviewer9/tv_bin/script/tvw_main
++++ b/opt/teamviewer9/tv_bin/script/tvw_main
+@@ -4,7 +4,6 @@ source "$TV_SCRIPT_DIR/tvw_aux"
+ source "$TV_SCRIPT_DIR/tvw_config"
+ source "$TV_SCRIPT_DIR/tvw_exec"
+ source "$TV_SCRIPT_DIR/tvw_extra"
+-source "$TV_SCRIPT_DIR/tvw_daemon"
+ source "$TV_SCRIPT_DIR/tvw_profile"
+
+
+@@ -19,7 +18,6 @@ function Main()
+ --help ) PrintHelp ;;
+ --version ) PrintVersion ;;
+ --info ) PrintInfo ;;
+- --daemon ) Run_Daemon $opt ;;
+ --winecfg ) shift; Run_WineCfg "$@" ;;
+ --regedit ) shift; Run_RegEdit "$@" ;;
+ --kill ) Run_KillTeamViewer ;;
+@@ -166,18 +164,3 @@ function Run_RegEdit()
+ Init
+ wine regedit "$@"
+ }
+-
+-function Run_Daemon()
+-{
+- local opt="$1"
+-
+- installedTVorDie
+-
+- case "$opt" in
+- ( disable ) removeDaemon || rootSuggest ;;
+- ( enable ) installDaemon || rootSuggest ;;
+- ( start | stop | restart ) cmdDaemon $opt || rootSuggest ;;
+- ( status ) cmdDaemon $opt ;;
+- ( * ) echo "unknown option '$opt'" ;;
+- esac
+-}
diff --git a/net-misc/teamviewer/teamviewer-9.0.27891.ebuild b/net-misc/teamviewer/teamviewer-9.0.27891.ebuild
new file mode 100644
index 000000000000..4888dbe6c331
--- /dev/null
+++ b/net-misc/teamviewer/teamviewer-9.0.27891.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/teamviewer/teamviewer-9.0.27891.ebuild,v 1.1 2014/05/24 16:00:53 hasufell Exp $
+
+EAPI=5
+
+inherit eutils gnome2-utils systemd unpacker
+
+# Major version
+MV=${PV/\.*}
+MY_PN=${PN}${MV}
+DESCRIPTION="All-In-One Solution for Remote Access and Support over the Internet"
+HOMEPAGE="http://www.teamviewer.com"
+SRC_URI="http://www.teamviewer.com/download/version_${MV}x/teamviewer_linux.deb -> ${P}.deb"
+
+LICENSE="TeamViewer !system-wine? ( LGPL-2.1 )"
+SLOT=${MV}
+KEYWORDS="~amd64 ~x86"
+IUSE="system-wine"
+
+RESTRICT="mirror"
+
+RDEPEND="
+ app-shells/bash
+ x11-misc/xdg-utils
+ !system-wine? (
+ amd64? (
+ app-emulation/emul-linux-x86-baselibs
+ app-emulation/emul-linux-x86-soundlibs
+ || (
+ (
+ x11-libs/libSM[abi_x86_32]
+ x11-libs/libX11[abi_x86_32]
+ x11-libs/libXau[abi_x86_32]
+ x11-libs/libXdamage[abi_x86_32]
+ x11-libs/libXext[abi_x86_32]
+ x11-libs/libXfixes[abi_x86_32]
+ x11-libs/libXtst[abi_x86_32]
+ )
+ app-emulation/emul-linux-x86-xlibs
+ )
+ )
+ x86? (
+ sys-libs/zlib
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXtst
+ )
+ )
+ system-wine? ( app-emulation/wine )"
+
+QA_PREBUILT="opt/teamviewer${MV}/*"
+
+S=${WORKDIR}/opt/teamviewer${MV}/tv_bin
+
+make_winewrapper() {
+ cat << EOF > "${T}/${MY_PN}"
+#!/bin/sh
+export WINEDLLPATH=/opt/${MY_PN}
+exec wine "/opt/${MY_PN}/TeamViewer.exe" "\$@"
+EOF
+ chmod go+rx "${T}/${MY_PN}"
+ exeinto /opt/bin
+ doexe "${T}/${MY_PN}"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+
+ sed \
+ -e "s#@TVV@#${MV}/tv_bin#g" \
+ "${FILESDIR}"/${PN}d.init > "${T}"/${PN}d${MV} || die
+}
+
+src_install () {
+ if use system-wine ; then
+ make_winewrapper
+ exeinto /opt/${MY_PN}
+ doexe wine/drive_c/TeamViewer/*
+ else
+ # install scripts and .reg
+ insinto /opt/${MY_PN}/tv_bin
+ doins -r *
+
+ exeinto /opt/${MY_PN}/tv_bin
+ doexe TeamViewer_Desktop
+ exeinto /opt/${MY_PN}/tv_bin/script
+ doexe script/teamviewer script/tvw_{aux,config,exec,extra,main,profile}
+
+ dosym /opt/${MY_PN}/tv_bin/script/${PN} /opt/bin/${MY_PN}
+
+ # fix permissions
+ fperms 755 /opt/${MY_PN}/tv_bin/wine/bin/wine{,-preloader,server}
+ fperms 755 /opt/${MY_PN}/tv_bin/wine/drive_c/TeamViewer/TeamViewer.exe
+ find "${D}"/opt/${MY_PN} -type f -name "*.so*" -execdir chmod 755 '{}' \;
+ fi
+
+ # install daemon binary
+ exeinto /opt/${MY_PN}/tv_bin
+ doexe ${PN}d
+
+ # set up logdir
+ keepdir /var/log/${MY_PN}
+ dosym /var/log/${MY_PN} /opt/${MY_PN}/logfiles
+
+ # set up config dir
+ keepdir /etc/${MY_PN}
+ dosym /etc/${MY_PN} /opt/${MY_PN}/config
+
+ doinitd "${T}"/${PN}d${MV}
+ systemd_dounit script/${PN}d.service
+
+ newicon -s 48 desktop/${PN}.png ${MY_PN}.png
+ dodoc ../doc/linux_FAQ_{EN,DE}.txt
+ make_desktop_entry ${MY_PN} TeamViewer ${MY_PN}
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+ if use system-wine ; then
+ echo
+ eerror "IMPORTANT NOTICE!"
+ elog "Using ${PN} with system wine is not supported and experimental."
+ elog "Do not report gentoo bugs while using this version."
+ echo
+ fi
+
+ eerror "STARTUP NOTICE:"
+ elog "You cannot start the daemon via \"teamviewer --daemon start\"."
+ elog "Instead use the provided gentoo initscript:"
+ elog " /etc/init.d/${PN}d${MV} start"
+ elog
+ elog "Logs are written to \"/var/log/teamviewer${MV}\""
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}