summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-02-15 21:46:04 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-02-15 21:46:04 +0000
commit5cf906016c06728786e69537c4e4e788165ecbc2 (patch)
tree2624b89f7ae9ae63096362bee531e6ba35c4deda /net-misc/tiers
parentRemove mask of mail-client/xfmail, mail-client/elm (diff)
downloadgentoo-2-5cf906016c06728786e69537c4e4e788165ecbc2.tar.gz
gentoo-2-5cf906016c06728786e69537c4e4e788165ecbc2.tar.bz2
gentoo-2-5cf906016c06728786e69537c4e4e788165ecbc2.zip
Adding gcc-4.3 patch per bug 251513. Thanks to Gene Seto <geneseto@hotmail.com> for the patch.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/tiers')
-rw-r--r--net-misc/tiers/ChangeLog9
-rw-r--r--net-misc/tiers/files/tiers-1.1-gcc43.patch118
-rw-r--r--net-misc/tiers/tiers-1.1.ebuild13
3 files changed, 132 insertions, 8 deletions
diff --git a/net-misc/tiers/ChangeLog b/net-misc/tiers/ChangeLog
index 93b4713b810a..9eb10ffc9873 100644
--- a/net-misc/tiers/ChangeLog
+++ b/net-misc/tiers/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/tiers
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tiers/ChangeLog,v 1.11 2007/06/12 21:21:39 jokey Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tiers/ChangeLog,v 1.12 2009/02/15 21:46:04 loki_val Exp $
+
+ 15 Feb 2009; Peter Alfredsen <loki_val@gentoo.org>
+ +files/tiers-1.1-gcc43.patch, tiers-1.1.ebuild:
+ Adding gcc-4.3 patch per bug 251513. Thanks to Gene Seto
+ <geneseto@hotmail.com> for the patch.
12 Jun 2007; Markus Ullmann <jokey@gentoo.org> tiers-1.1.ebuild:
Stable on x86 wrt bug #181612
diff --git a/net-misc/tiers/files/tiers-1.1-gcc43.patch b/net-misc/tiers/files/tiers-1.1-gcc43.patch
new file mode 100644
index 000000000000..4f167daf13ce
--- /dev/null
+++ b/net-misc/tiers/files/tiers-1.1-gcc43.patch
@@ -0,0 +1,118 @@
+--- tiers1.1b/src/tiers_create.cc 2009-01-21 03:56:28.000000000 -0400
++++ tiers1.1/src/tiers_create.cc 2009-01-21 03:57:39.000000000 -0400
+@@ -16,7 +16,7 @@
+ //////////////////////////////////////////////////////////////////////////////
+
+ // tiers.cc
+-#include <iostream.h>
++#include <iostream>
+
+ #ifndef _TIERS_HH
+ #include "tiers.hh"
+--- tiers1.1b/src/tiers.cc 2009-01-21 03:56:28.000000000 -0400
++++ tiers1.1/src/tiers.cc 2009-01-21 03:57:22.000000000 -0400
+@@ -17,8 +17,9 @@
+
+ // tiers.cc
+
+-#include <iostream.h>
+-#include <limits.h>
++#include <iostream>
++#include <cstdlib>
++#include <climits>
+
+ #ifndef _TIERS_HH
+ #include "tiers.hh"
+--- tiers1.1b/src/tiers_misc.cc 2009-01-21 03:56:28.000000000 -0400
++++ tiers1.1/src/tiers_misc.cc 2009-01-21 04:07:21.000000000 -0400
+@@ -16,9 +16,9 @@
+ //////////////////////////////////////////////////////////////////////////////
+
+ // tiers_misc.cc
+-#include <iostream.h>
+-#include <math.h>
+-#include <limits.h> // for ULONG_MAX
++#include <iostream>
++#include <cmath>
++#include <climits> // for ULONG_MAX
+
+ #ifndef _TIERS_HH
+ #include "tiers.hh"
+--- tiers1.1b/src/tiers_main.cc 2009-01-21 03:56:28.000000000 -0400
++++ tiers1.1/src/tiers_main.cc 2009-01-21 04:08:13.000000000 -0400
+@@ -17,9 +17,9 @@
+
+ // tiers_main.cc
+
+-#include <iostream.h>
+-#include <stdlib.h> // for strtoul
+-#include <math.h> // for random
++#include <iostream>
++#include <cstdlib> // for strtoul
++#include <cmath> // for random
+
+ #ifndef _TIERS_HH
+ #include "tiers.hh"
+--- tiers1.1b/src/tiers_output.cc 2009-01-21 03:56:28.000000000 -0400
++++ tiers1.1/src/tiers_output.cc 2009-01-21 04:00:09.000000000 -0400
+@@ -17,7 +17,7 @@
+
+ // tiers_output.cc
+
+-#include <iostream.h>
++#include <iostream>
+ #ifndef _TIERS_HH
+ #include "tiers.hh"
+ #endif
+--- tiers1.1b/src/tiers_output_gnuplot.cc 2009-01-21 03:56:28.000000000 -0400
++++ tiers1.1/src/tiers_output_gnuplot.cc 2009-01-21 04:00:39.000000000 -0400
+@@ -17,7 +17,7 @@
+
+ // tiers_output_gnuplot.cc
+
+-#include <iostream.h>
++#include <iostream>
+ #ifndef _TIERS_HH
+ #include "tiers.hh"
+ #endif
+--- tiers1.1b/src/tiers_prims.cc 2009-01-21 03:56:28.000000000 -0400
++++ tiers1.1/src/tiers_prims.cc 2009-01-21 04:10:24.000000000 -0400
+@@ -17,9 +17,9 @@
+
+ // tiers_prims.cc
+
+-#include <iostream.h>
+-#include <math.h> // for random
+-#include <limits.h> // for ULONG_MAX
++#include <iostream>
++#include <cmath> // for random
++#include <climits> // for ULONG_MAX
+
+ #ifndef _TIERS_HH
+ #include "tiers.hh"
+--- tiers1.1b/src/tiers_red_intra.cc 2009-01-21 03:56:28.000000000 -0400
++++ tiers1.1/src/tiers_red_intra.cc 2009-01-21 04:01:21.000000000 -0400
+@@ -17,8 +17,8 @@
+
+ // tiers_red_intra.cc
+
+-#include <iostream.h>
+-#include <limits.h> // for ULONG_MAX
++#include <iostream>
++#include <climits> // for ULONG_MAX
+
+ #ifndef _TIERS_HH
+ #include "tiers.hh"
+--- tiers1.1b/src/tiers_red_inter.cc 2009-01-21 03:56:28.000000000 -0400
++++ tiers1.1/src/tiers_red_inter.cc 2009-01-21 04:01:46.000000000 -0400
+@@ -17,8 +17,8 @@
+
+ // tiers_red_inter.cc
+
+-#include <iostream.h>
+-#include <limits.h> // for ULONG_MAX
++#include <iostream>
++#include <climits> // for ULONG_MAX
+
+ #ifndef _TIERS_HH
+ #include "tiers.hh"
diff --git a/net-misc/tiers/tiers-1.1.ebuild b/net-misc/tiers/tiers-1.1.ebuild
index 3de2c0bd7949..d53de4490306 100644
--- a/net-misc/tiers/tiers-1.1.ebuild
+++ b/net-misc/tiers/tiers-1.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tiers/tiers-1.1.ebuild,v 1.7 2007/06/12 21:21:39 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tiers/tiers-1.1.ebuild,v 1.8 2009/02/15 21:46:04 loki_val Exp $
inherit eutils
@@ -19,12 +19,13 @@ S=${WORKDIR}/${PN}${PV}
src_unpack() {
unpack ${MY_P}.tar.gz
- epatch ${FILESDIR}/${MY_P}-gccfixes.patch
- sed -e '1a\#!/bin/sh' -e '1d' -e "s|-f |-f /usr/share/${PN}/|g" -i ${S}/bin/strip4gnuplot3.5
+ epatch "${FILESDIR}"/${MY_P}-gccfixes.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ sed -e '1a\#!/bin/sh' -e '1d' -e "s|-f |-f /usr/share/${PN}/|g" -i "${S}"/bin/strip4gnuplot3.5
}
src_compile() {
- cd ${S}/src
+ cd "${S}"/src
emake CFLAGS="${CFLAGS}" CONFIGFILE="/etc/tiers-gnuplot.conf" EXEC="../bin/tiers-gnuplot" || die
# cleanup for a sec
rm *.o
@@ -37,6 +38,6 @@ src_install() {
newins src/tiers_config.generic tiers.conf
newins src/tiers_config.gnuplot tiers-gnuplot.conf
insinto /usr/share/${PN}
- doins bin/*.awk ${DISTDIR}/tiers2ns-lan.awk
+ doins bin/*.awk "${DISTDIR}"/tiers2ns-lan.awk
dodoc CHANGES COPYRIGHT README docs/*
}