summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-05-11 16:49:31 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-05-11 16:49:31 +0000
commitef1a5ec7b8ab39335410e0bea73d2f97936d3df3 (patch)
tree91953bfc0e320c704fbddc9e5222c49d8a11da4b /net-misc/tinc
parentUpdate DESCRIPTION to not exclude sys-apps/systemd. (diff)
downloadgentoo-2-ef1a5ec7b8ab39335410e0bea73d2f97936d3df3.tar.gz
gentoo-2-ef1a5ec7b8ab39335410e0bea73d2f97936d3df3.tar.bz2
gentoo-2-ef1a5ec7b8ab39335410e0bea73d2f97936d3df3.zip
Version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-misc/tinc')
-rw-r--r--net-misc/tinc/ChangeLog9
-rw-r--r--net-misc/tinc/tinc-1.0.24.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/net-misc/tinc/ChangeLog b/net-misc/tinc/ChangeLog
index aa6b26d65cc2..83b58e91af30 100644
--- a/net-misc/tinc/ChangeLog
+++ b/net-misc/tinc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/tinc
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tinc/ChangeLog,v 1.46 2013/10/19 15:58:57 blueness Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tinc/ChangeLog,v 1.47 2014/05/11 16:49:31 blueness Exp $
+
+*tinc-1.0.24 (11 May 2014)
+
+ 11 May 2014; Anthony G. Basile <blueness@gentoo.org> +tinc-1.0.24.ebuild:
+ Version bump
*tinc-1.0.23 (19 Oct 2013)
diff --git a/net-misc/tinc/tinc-1.0.24.ebuild b/net-misc/tinc/tinc-1.0.24.ebuild
new file mode 100644
index 000000000000..d52d6b8af4d4
--- /dev/null
+++ b/net-misc/tinc/tinc-1.0.24.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tinc/tinc-1.0.24.ebuild,v 1.1 2014/05/11 16:49:31 blueness Exp $
+
+EAPI="5"
+inherit systemd
+
+DESCRIPTION="tinc is an easy to configure VPN implementation"
+HOMEPAGE="http://www.tinc-vpn.org/"
+SRC_URI="http://www.tinc-vpn.org/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="+lzo uml vde +zlib"
+
+DEPEND="dev-libs/openssl
+ lzo? ( dev-libs/lzo:2 )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}
+ vde? ( net-misc/vde )"
+
+src_configure() {
+ econf \
+ --enable-jumbograms \
+ --disable-tunemu \
+ $(use_enable lzo) \
+ $(use_enable uml) \
+ $(use_enable vde) \
+ $(use_enable zlib)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodir /etc/tinc
+ dodoc AUTHORS NEWS README THANKS
+ doinitd "${FILESDIR}"/tincd
+ doinitd "${FILESDIR}"/tincd.lo
+ doconfd "${FILESDIR}"/tinc.networks
+ newconfd "${FILESDIR}"/tincd.conf tincd
+ systemd_newunit "${FILESDIR}"/tincd_at.service "tincd@.service"
+}
+
+pkg_postinst() {
+ elog "This package requires the tun/tap kernel device."
+ elog "Look at http://www.tinc-vpn.org/ for how to configure tinc"
+}