summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2008-12-21 01:33:20 +0000
committerChristian Faulhammer <fauli@gentoo.org>2008-12-21 01:33:20 +0000
commit57f59619af38198b06e80ba505eea9ee47fff9ab (patch)
tree96a6bdd4c4c25830f932af6a6dbef1a4622b48b5 /net-misc/tor
parentBug #244775, version bump. (diff)
downloadgentoo-2-57f59619af38198b06e80ba505eea9ee47fff9ab.tar.gz
gentoo-2-57f59619af38198b06e80ba505eea9ee47fff9ab.tar.bz2
gentoo-2-57f59619af38198b06e80ba505eea9ee47fff9ab.zip
install limits file so tor can open more files on the system than normally allowed, this fixes bug 251171 reported by candrews AT integralblue DOT com
(Portage version: 2.1.4.5)
Diffstat (limited to 'net-misc/tor')
-rw-r--r--net-misc/tor/ChangeLog10
-rw-r--r--net-misc/tor/files/tor.conf3
-rw-r--r--net-misc/tor/tor-0.2.0.32-r1.ebuild73
3 files changed, 85 insertions, 1 deletions
diff --git a/net-misc/tor/ChangeLog b/net-misc/tor/ChangeLog
index 030a67fd2d70..282aaac3ed8e 100644
--- a/net-misc/tor/ChangeLog
+++ b/net-misc/tor/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/tor
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.148 2008/12/10 07:02:37 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.149 2008/12/21 01:33:20 fauli Exp $
+
+*tor-0.2.0.32-r1 (21 Dec 2008)
+
+ 21 Dec 2008; Christian Faulhammer <fauli@gentoo.org> +files/tor.conf,
+ +tor-0.2.0.32-r1.ebuild:
+ install limits file so tor can open more files on the system than normally
+ allowed, this fixes bug 251171 reported by candrews AT integralblue DOT
+ com
10 Dec 2008; Christian Faulhammer <fauli@gentoo.org>
-files/tor-0.2.0.31-sparc.patch, -tor-0.2.0.31-r1.ebuild:
diff --git a/net-misc/tor/files/tor.conf b/net-misc/tor/files/tor.conf
new file mode 100644
index 000000000000..4e4c63960391
--- /dev/null
+++ b/net-misc/tor/files/tor.conf
@@ -0,0 +1,3 @@
+tor hard nofile 30000
+tor soft nofile 30000
+
diff --git a/net-misc/tor/tor-0.2.0.32-r1.ebuild b/net-misc/tor/tor-0.2.0.32-r1.ebuild
new file mode 100644
index 000000000000..7cb85054f9b4
--- /dev/null
+++ b/net-misc/tor/tor-0.2.0.32-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/tor-0.2.0.32-r1.ebuild,v 1.1 2008/12/21 01:33:20 fauli Exp $
+
+inherit eutils
+
+DESCRIPTION="Anonymizing overlay network for TCP"
+HOMEPAGE="http://tor.eff.org"
+MY_PV=${PV/_/-}
+SRC_URI="http://tor.eff.org/dist/${PN}-${MY_PV}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug logrotate"
+
+DEPEND="dev-libs/openssl
+ >=dev-libs/libevent-1.2"
+RDEPEND="${DEPEND}
+ net-proxy/tsocks"
+
+pkg_setup() {
+ enewgroup tor
+ enewuser tor -1 -1 /var/lib/tor tor
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/torrc.sample-0.1.2.6.patch
+ epatch "${FILESDIR}"/${PN}-0.2.0.30-logrotate.patch
+}
+
+src_compile() {
+ econf $(use_enable debug)
+ emake || die
+}
+
+src_install() {
+ newinitd "${FILESDIR}"/tor.initd-r4 tor
+ emake DESTDIR="${D}" install || die
+ keepdir /var/{lib,log,run}/tor
+
+ dodoc README ChangeLog AUTHORS ReleaseNotes \
+ doc/{HACKING,TODO} \
+ doc/spec/*.txt
+
+ fperms 750 /var/lib/tor /var/log/tor
+ fperms 755 /var/run/tor
+ fowners tor:tor /var/lib/tor /var/log/tor /var/run/tor
+
+ if use logrotate; then
+ sed -e "s:/lib::" \
+ -e "s:/rc.d::" \
+ -e "s:\\*:\\*.:" \
+ -e "s:sharedscripts:create 0640 tor tor\n\tsharedscripts:" -i contrib/tor.logrotate || die
+ insinto /etc/logrotate.d
+ newins contrib/tor.logrotate tor
+ fi
+
+ # allow the tor user more open files to avoid errors, see bug 251171
+ insinto /etc/security/limits.d/
+ doins "${FILESDIR}"/tor.conf
+}
+
+pkg_postinst() {
+ elog "You must create /etc/tor/torrc, you can use the sample that is in that directory"
+ elog "To have privoxy and tor working together you must add:"
+ elog "forward-socks4a / localhost:9050 ."
+ elog "(notice the . at the end of the line)"
+ elog "to /etc/privoxy/config"
+}