summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-02-07 21:11:21 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-02-07 21:11:21 +0000
commit8c1f8d18a203160d0735babb600b9e387cc23748 (patch)
treef4d401c24f8e5f0ca0d1a14664b5423f7896d1f3 /net-misc/tor
parentDirectly inherit multilib, thanks to Arfrever for reporting. (diff)
downloadgentoo-2-8c1f8d18a203160d0735babb600b9e387cc23748.tar.gz
gentoo-2-8c1f8d18a203160d0735babb600b9e387cc23748.tar.bz2
gentoo-2-8c1f8d18a203160d0735babb600b9e387cc23748.zip
Added DEPEND on sec-policy/selinux-tor for selinux systems
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/tor')
-rw-r--r--net-misc/tor/ChangeLog8
-rw-r--r--net-misc/tor/tor-0.2.1.32.ebuild9
-rw-r--r--net-misc/tor/tor-0.2.2.35-r1.ebuild77
-rw-r--r--net-misc/tor/tor-0.2.3.11_alpha.ebuild7
4 files changed, 93 insertions, 8 deletions
diff --git a/net-misc/tor/ChangeLog b/net-misc/tor/ChangeLog
index af231e61a3e4..844dd42d37c6 100644
--- a/net-misc/tor/ChangeLog
+++ b/net-misc/tor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/tor
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.316 2012/01/24 13:06:55 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.317 2012/02/07 21:11:21 blueness Exp $
+
+*tor-0.2.2.35-r1 (07 Feb 2012)
+
+ 07 Feb 2012; Anthony G. Basile <blueness@gentoo.org> tor-0.2.1.32.ebuild,
+ +tor-0.2.2.35-r1.ebuild, tor-0.2.3.11_alpha.ebuild:
+ Added DEPEND on sec-policy/selinux-tor for selinux systems
*tor-0.2.3.11_alpha (24 Jan 2012)
diff --git a/net-misc/tor/tor-0.2.1.32.ebuild b/net-misc/tor/tor-0.2.1.32.ebuild
index eb1f9bb3b67c..53ca42c2b02a 100644
--- a/net-misc/tor/tor-0.2.1.32.ebuild
+++ b/net-misc/tor/tor-0.2.1.32.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/tor-0.2.1.32.ebuild,v 1.2 2011/12/17 00:06:13 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/tor-0.2.1.32.ebuild,v 1.3 2012/02/07 21:11:21 blueness Exp $
EAPI=4
@@ -13,10 +13,11 @@ SRC_URI="http://www.torproject.org/dist/${PN}-${PV}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug"
+IUSE="debug selinux"
DEPEND="dev-libs/openssl
- >=dev-libs/libevent-2.0"
+ >=dev-libs/libevent-2.0
+ selinux? ( sec-policy/selinux-tor )"
RDEPEND="${DEPEND}"
pkg_setup() {
diff --git a/net-misc/tor/tor-0.2.2.35-r1.ebuild b/net-misc/tor/tor-0.2.2.35-r1.ebuild
new file mode 100644
index 000000000000..2428570a51b6
--- /dev/null
+++ b/net-misc/tor/tor-0.2.2.35-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/tor-0.2.2.35-r1.ebuild,v 1.1 2012/02/07 21:11:21 blueness Exp $
+
+EAPI=4
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="Anonymizing overlay network for TCP"
+HOMEPAGE="http://www.torproject.org/"
+SRC_URI="http://www.torproject.org/dist/${PN}-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc tor-hardening +transparent-proxy threads selinux"
+
+DEPEND="dev-libs/openssl
+ >=dev-libs/libevent-2.0
+ selinux? ( sec-policy/selinux-tor )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup tor
+ enewuser tor -1 -1 /var/lib/tor tor
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/torrc.sample.patch
+
+ einfo "Regenerating autotools files ..."
+ epatch "${FILESDIR}"/${PN}-0.2.2.24_alpha-respect-CFLAGS.patch
+ eautoreconf
+}
+
+src_configure() {
+ # Upstream isn't sure of all the user provided CFLAGS that
+ # will break tor, but does recommend against -fstrict-aliasing.
+ # We'll filter-flags them here as we encounter them.
+ filter-flags -fstrict-aliasing
+ econf --docdir=/usr/share/doc/${PF} \
+ $(use_enable doc asciidoc) \
+ $(use_enable tor-hardening gcc-hardening) \
+ $(use_enable tor-hardening linker-hardening)\
+ $(use_enable transparent-proxy transparent) \
+ $(use_enable threads)
+}
+
+src_install() {
+ newconfd "${FILESDIR}"/tor.confd tor
+ newinitd "${FILESDIR}"/tor.initd-r6 tor
+ emake DESTDIR="${D}" install
+ keepdir /var/lib/tor
+
+ dodoc README ChangeLog ReleaseNotes \
+ doc/{HACKING,TODO} \
+ doc/spec/README
+
+ fperms 750 /var/lib/tor
+ fowners tor:tor /var/lib/tor
+
+ insinto /etc/tor/
+ newins "${FILESDIR}"/torrc-r1 torrc
+}
+
+pkg_postinst() {
+ elog
+ elog "We created a configuration file for tor, /etc/tor/torrc, but you can"
+ elog "change it according to your needs. Use the torrc.sample that is in"
+ elog "that directory as a guide. Also, to have privoxy work with tor"
+ elog "just add the following line"
+ elog
+ elog "forward-socks4a / localhost:9050 ."
+ elog
+ elog "to /etc/privoxy/config. Notice the . at the end!"
+ elog
+}
diff --git a/net-misc/tor/tor-0.2.3.11_alpha.ebuild b/net-misc/tor/tor-0.2.3.11_alpha.ebuild
index 4d81f6850f76..168a5bd8cc2c 100644
--- a/net-misc/tor/tor-0.2.3.11_alpha.ebuild
+++ b/net-misc/tor/tor-0.2.3.11_alpha.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/tor-0.2.3.11_alpha.ebuild,v 1.1 2012/01/24 13:06:55 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/tor-0.2.3.11_alpha.ebuild,v 1.2 2012/02/07 21:11:21 blueness Exp $
EAPI="4"
@@ -16,12 +16,13 @@ S="${WORKDIR}/${MY_PF}"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="+bufferevents doc nat-pmp tor-hardening transparent-proxy threads upnp"
+IUSE="+bufferevents doc nat-pmp tor-hardening transparent-proxy threads upnp selinux"
DEPEND="dev-libs/openssl
>=dev-libs/libevent-2.0.14
nat-pmp? ( net-libs/libnatpmp )
- upnp? ( <net-libs/miniupnpc-1.6 )"
+ upnp? ( <net-libs/miniupnpc-1.6 )
+ selinux? ( sec-policy/selinux-tor )"
RDEPEND="${DEPEND}"
pkg_setup() {