summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2012-09-03 16:51:21 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2012-09-03 16:51:21 +0000
commit7c37458a6b3025e6e8fbc55c9cf8c88cd6ad41ac (patch)
tree28f8e624deb7130710ee2ecfa2e3df4fafdf3c68 /net-misc/ucarp/ucarp-1.5.2-r1.ebuild
parentUpdate the tarball to use proper versioning. Update the ebuild from multimedi... (diff)
downloadgentoo-2-7c37458a6b3025e6e8fbc55c9cf8c88cd6ad41ac.tar.gz
gentoo-2-7c37458a6b3025e6e8fbc55c9cf8c88cd6ad41ac.tar.bz2
gentoo-2-7c37458a6b3025e6e8fbc55c9cf8c88cd6ad41ac.zip
Add man page thx to Kerin Millar, fix #419029.
(Portage version: 2.1.11.13/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/ucarp/ucarp-1.5.2-r1.ebuild')
-rw-r--r--net-misc/ucarp/ucarp-1.5.2-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-misc/ucarp/ucarp-1.5.2-r1.ebuild b/net-misc/ucarp/ucarp-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..e2f12caebb1f
--- /dev/null
+++ b/net-misc/ucarp/ucarp-1.5.2-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ucarp/ucarp-1.5.2-r1.ebuild,v 1.1 2012/09/03 16:51:21 ultrabug Exp $
+
+EAPI="4"
+
+inherit base
+
+DESCRIPTION="Portable userland implementation of Common Address Redundancy Protocol (CARP)."
+HOMEPAGE="http://www.ucarp.org"
+SRC_URI="ftp://ftp.ucarp.org/pub/ucarp/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND="net-libs/libpcap"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+DOCS=( "README" "NEWS" "AUTHORS" "ChangeLog"
+ "examples/linux/vip-up.sh" "examples/linux/vip-down.sh" )
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc "${DOCS[@]}"
+ doman "${FILESDIR}"/ucarp.8
+} \ No newline at end of file