summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-11-24 19:24:12 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-11-24 19:24:12 +0000
commit28f5355bb186960e8c5f31bd4d36679d9238def6 (patch)
treea4eb9a69fa5737ba69cf4efe80aa4eece5245d5a /net-misc/vidalia
parentversion bump (diff)
downloadgentoo-2-28f5355bb186960e8c5f31bd4d36679d9238def6.tar.gz
gentoo-2-28f5355bb186960e8c5f31bd4d36679d9238def6.tar.bz2
gentoo-2-28f5355bb186960e8c5f31bd4d36679d9238def6.zip
Added latest upstream stable
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/vidalia')
-rw-r--r--net-misc/vidalia/ChangeLog7
-rw-r--r--net-misc/vidalia/vidalia-0.2.15.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/net-misc/vidalia/ChangeLog b/net-misc/vidalia/ChangeLog
index f4dc1426d620..692f9e24d5bc 100644
--- a/net-misc/vidalia/ChangeLog
+++ b/net-misc/vidalia/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/vidalia
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vidalia/ChangeLog,v 1.24 2011/11/24 17:36:30 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vidalia/ChangeLog,v 1.25 2011/11/24 19:24:12 blueness Exp $
+
+*vidalia-0.2.15 (24 Nov 2011)
+
+ 24 Nov 2011; Anthony G. Basile <blueness@gentoo.org> +vidalia-0.2.15.ebuild:
+ Added latest upstream stable
24 Nov 2011; Anthony G. Basile <blueness@gentoo.org> metadata.xml:
Added myself as maintainer
diff --git a/net-misc/vidalia/vidalia-0.2.15.ebuild b/net-misc/vidalia/vidalia-0.2.15.ebuild
new file mode 100644
index 000000000000..b23b2fcfb1be
--- /dev/null
+++ b/net-misc/vidalia/vidalia-0.2.15.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vidalia/vidalia-0.2.15.ebuild,v 1.1 2011/11/24 19:24:12 blueness Exp $
+
+EAPI="4"
+
+inherit eutils qt4-r2 cmake-utils
+# cmake-utils needs to be last, so we get its src_compile()
+
+DESCRIPTION="Qt 4 front-end for Tor"
+HOMEPAGE="https://www.torproject.org/projects/vidalia.html.en"
+SRC_URI="https://www.torproject.org/dist/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-3 GPL-2 ) openssl"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug +tor"
+
+DEPEND="x11-libs/qt-gui:4[debug?]"
+RDEPEND="${DEPEND}
+ tor? ( net-misc/tor )"
+
+DOCS="CHANGELOG CREDITS README"
+
+pkg_postinst() {
+ echo
+ if use tor; then
+ ewarn "To have vidalia starting tor, you probably have to copy"
+ ewarn "/etc/tor/torrc.sample to the users ~/.tor/torrc and comment"
+ ewarn "the settings there and change the socks. Also, in vidalia"
+ ewarn "change the default user under which tor will run."
+ else
+ ewarn "You have disabled tor USE flag, which means you need to "
+ ewarn "configure tor on a different host."
+ fi
+}