summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2008-02-07 08:09:14 +0000
committerChristian Faulhammer <opfer@gentoo.org>2008-02-07 08:09:14 +0000
commit8e536388f913ac2802f162e75b747d9f4902dac6 (patch)
treead67ddbef1a4564103c416ad4a0c8f6bbc7f73e8 /net-misc/vpnc
parentclean up (diff)
downloadgentoo-2-8e536388f913ac2802f162e75b747d9f4902dac6.tar.gz
gentoo-2-8e536388f913ac2802f162e75b747d9f4902dac6.tar.bz2
gentoo-2-8e536388f913ac2802f162e75b747d9f4902dac6.zip
clean up
(Portage version: 2.1.3.19)
Diffstat (limited to 'net-misc/vpnc')
-rw-r--r--net-misc/vpnc/ChangeLog6
-rw-r--r--net-misc/vpnc/files/vpnc-1.init66
-rw-r--r--net-misc/vpnc/vpnc-0.5.1.ebuild57
3 files changed, 5 insertions, 124 deletions
diff --git a/net-misc/vpnc/ChangeLog b/net-misc/vpnc/ChangeLog
index 00e8178766e7..8bb90bf3e1a7 100644
--- a/net-misc/vpnc/ChangeLog
+++ b/net-misc/vpnc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/vpnc
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vpnc/ChangeLog,v 1.65 2008/02/06 18:56:27 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vpnc/ChangeLog,v 1.66 2008/02/07 08:09:13 opfer Exp $
+
+ 07 Feb 2008; Christian Faulhammer <opfer@gentoo.org> -files/vpnc-1.init,
+ -vpnc-0.5.1.ebuild:
+ clean up
06 Feb 2008; nixnut <nixnut@gentoo.org> vpnc-0.5.1-r1.ebuild:
stable on ppc wrt bug #209045
diff --git a/net-misc/vpnc/files/vpnc-1.init b/net-misc/vpnc/files/vpnc-1.init
deleted file mode 100644
index 315db9cf4a01..000000000000
--- a/net-misc/vpnc/files/vpnc-1.init
+++ /dev/null
@@ -1,66 +0,0 @@
-#!/sbin/runscript
-
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vpnc/files/vpnc-1.init,v 1.2 2007/08/29 13:32:55 opfer Exp $
-
-VPNDIR="/etc/vpnc"
-VPN="${SVCNAME#*.}"
-if [ -n ${VPN} ] && [ ${SVCNAME} != "vpnc" ]; then
- VPNPID="/var/run/vpnc/${VPN}.pid"
-else
- VPNPID="/var/run/vpnc.pid"
-fi
-VPNCONF="${VPNDIR}/${VPN}.conf"
-
-depend() {
- need net
- before netmount
-}
-
-checktundevice() {
- if [ ! -e /dev/net/tun ]; then
- if ! modprobe tun ; then
- eerror "TUN/TAP support is not available in this kernel"
- return 1
- fi
- fi
- if [ -h /dev/net/tun ] && [ -c /dev/misc/net/tun ]; then
- ebegin "Detected broken /dev/net/tun symlink, fixing..."
- rm -f /dev/net/tun
- ln -s /dev/misc/net/tun /dev/net/tun
- eend $?
- fi
-}
-
-screenoutput() {
- if [ "${VPNCOUTPUT}" = "yes" ]; then
- export SCREEN_OUTPUT="/dev/stdout"
- else
- export SCREEN_OUTPUT="/dev/null"
- fi
-}
-
-start() {
- ebegin "Starting VPNC: ${VPN}"
-
- checktundevice || return 1
- screenoutput
-
- if [ ! -e "${VPNCONF}" ]; then
- eend 1 "${VPNCONF} does not exist"
- return 1
- fi
-
- local args=""
-
- start-stop-daemon --start --pidfile "${VPNPID}" --exec /usr/sbin/vpnc \
- -- --pid-file "${VPNPID}" "${VPNCONF}" > ${SCREEN_OUTPUT}
- eend $?
-}
-
-stop() {
- ebegin "Stopping VPNC: ${VPN}"
- start-stop-daemon --stop --exec /usr/sbin/vpnc --pidfile "${VPNPID}"
- eend $?
-}
diff --git a/net-misc/vpnc/vpnc-0.5.1.ebuild b/net-misc/vpnc/vpnc-0.5.1.ebuild
deleted file mode 100644
index 93d21f980f4c..000000000000
--- a/net-misc/vpnc/vpnc-0.5.1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vpnc/vpnc-0.5.1.ebuild,v 1.11 2008/01/24 07:08:11 opfer Exp $
-
-inherit linux-info
-
-DESCRIPTION="Free client for Cisco VPN routing software"
-HOMEPAGE="http://www.unix-ag.uni-kl.de/~massar/vpnc/"
-SRC_URI="http://www.unix-ag.uni-kl.de/~massar/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 ~sparc x86"
-IUSE="hybrid-auth bindist resolvconf"
-
-DEPEND=">=dev-libs/libgcrypt-1.1.91
- >=sys-apps/iproute2-2.6.19.20061214
- !bindist? ( hybrid-auth? ( dev-libs/openssl ) )"
-
-RDEPEND="${DEPEND}
- resolvconf? ( ||
- ( net-dns/resolvconf-gentoo net-dns/openresolv )
- )"
-
-pkg_setup() {
- if use hybrid-auth && use bindist; then
- ewarn "Hybrid authentication will be disabled for this packages as you will"
- ewarn "redistribute it in binary form. This is not allowed due to linking"
- ewarn "of OpenSSL."
- fi
-}
-
-src_compile() {
- # is reported upstream and fixed in next version
- sed -e "s:/usr/local:/usr:" -i vpnc-script
- # only allowed if not distributed in binary form!
- if use hybrid-auth && ! use bindist; then
- hybridauthopts="OPENSSL_GPL_VIOLATION=-DOPENSSL_GPL_VIOLATION OPENSSLLIBS=-lcrypto"
- fi
- emake ${hybridauthopts} || die "emake failed"
-}
-
-src_install() {
- emake PREFIX="/usr" DESTDIR="${D}" install || die "emake install failed"
- dodoc README TODO VERSION
- keepdir /var/run/vpnc
- newinitd "${FILESDIR}/vpnc-1.init" vpnc
- newconfd "${FILESDIR}/vpnc.confd" vpnc
-}
-
-pkg_postinst() {
- elog "You can generate a configuration file from the original Cisco profiles of your"
- elog "connection by using /usr/bin/pcf2vpnc to convert the .pcf file"
- elog "A guide is to be found in http://www.gentoo.org/doc/en/vpnc-howto.xml"
- echo
- elog "Don't forget to turn on TUN support in the kernel."
-}