summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPreston A. Elder <prez@gentoo.org>2002-05-28 04:28:41 +0000
committerPreston A. Elder <prez@gentoo.org>2002-05-28 04:28:41 +0000
commitc6e4a5ba5e872b1e56ffb483776a77507801b0af (patch)
treeeeae1025e68bf64fafa8ec4e5125b7c6ecc0f6a5 /net-misc/vtun
parentMasked links-2.0_pre4-r1... problems with slots. (diff)
downloadgentoo-2-c6e4a5ba5e872b1e56ffb483776a77507801b0af.tar.gz
gentoo-2-c6e4a5ba5e872b1e56ffb483776a77507801b0af.tar.bz2
gentoo-2-c6e4a5ba5e872b1e56ffb483776a77507801b0af.zip
Added vtun-2.5-r1
Diffstat (limited to 'net-misc/vtun')
-rw-r--r--net-misc/vtun/ChangeLog7
-rw-r--r--net-misc/vtun/vtun-2.5-r1.ebuild71
2 files changed, 78 insertions, 0 deletions
diff --git a/net-misc/vtun/ChangeLog b/net-misc/vtun/ChangeLog
index c1ac3c9a8a01..7f6d120c92de 100644
--- a/net-misc/vtun/ChangeLog
+++ b/net-misc/vtun/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
# /space/gentoo/cvsroot/gentoo-x86/skel.ChangeLog,v 1.2 2002/02/05 00:57:47 gbevin Exp
+*vtun-2.5-r1 (28 April 2002)
+
+ 28 May 2002; Preston A. Elder <prez@gentoo.org> vtun-2.5-r1.ebuild
+
+ Accomodated for /usr/include/md5.h left from cyrus-sasl.
+
*vtun-2.5 (28 April 2002)
28 April 2002; Bryce Allen <ballen@mum.edu> vtun-2.5.ebuild ChangeLog files/digest-vtun-2.5 files/vtun.rc files/vtund-start.conf :
@@ -9,3 +15,4 @@
Initial revision.
Includes a few patches for the excellent PLD folks, specifically
to fix a bison issue, and to add DESTDIR to the 'make install' command.
+
diff --git a/net-misc/vtun/vtun-2.5-r1.ebuild b/net-misc/vtun/vtun-2.5-r1.ebuild
new file mode 100644
index 000000000000..ec02115fe6d6
--- /dev/null
+++ b/net-misc/vtun/vtun-2.5-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vtun/vtun-2.5-r1.ebuild,v 1.1 2002/05/28 04:28:41 prez Exp $
+
+DESCRIPTION="Tunneling software to use the universal tunnel"
+HOMEPAGE="http://vtun.sourceforge.net"
+LICENSE="GPL-2"
+DEPEND=">=sys-libs/zlib-1.1.4
+ >=dev-libs/lzo-1.07
+ ssl? ( >=dev-libs/openssl-0.9.6c-r1 )
+ >=sys-kernel/linux-headers-2.4.18"
+#RDEPEND=""
+SRC_URI="ftp://prdownloads.sourceforge.net/vtun/${P}.tar.gz"
+S=${WORKDIR}/vtun
+
+src_compile() {
+ if [ -z "`use ssl`" ]
+ then
+ use_opts="--disable-ssl"
+ fi
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ $use_opts || die "./configure failed"
+ mv config.h config.h.orig
+ mv cfg_file.y cfg_file.y.orig
+ sed "s,/* #undef HAVE_LINUX_IF_TUN_H */,#define HAVE_LINUX_IF_TUN_H 1," \
+ config.h.orig >config.h
+ sed "s,expect 18,expect 20," \
+ cfg_file.y.orig >cfg_file.y
+
+ # Rename this, because its from cyrus, we want the openssl one.
+ if [ -f /usr/include/md5.h ]; then
+ mv /usr/include/md5.h /usr/include/md5.h.vtun_compile
+ fi
+
+ # If this doesnt work, we only remember that we failed, so
+ # we always rename the /etc/include/md5.h file back.
+ emake \
+ ETC_DIR=/etc \
+ VAR_DIR=/var || FAILED=1
+
+ # OK, we're done, rename the cyrus one back to what it was.
+ if [ -f /usr/include/md5.h.vtun_compile -a
+ ! -f /usr/include/md5.h ]; then
+ mv /usr/include/md5.h.vtun_compile /usr/include/md5.h
+ fi
+ if [ 0$FAILED -ne 0 ]; then
+ die
+ fi
+}
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ ETC_DIR=${D}/etc \
+ VAR_DIR=${D}/var \
+ INFO_DIR=${D}/usr/share/info \
+ MAN_DIR=${D}/usr/share/man install || die
+
+ dodoc ChangeLog Credits FAQ README* TODO vtund.conf
+
+ exeinto etc/init.d;
+ newexe ${FILESDIR}/vtun.rc vtun
+
+ insinto etc
+ doins ${FILESDIR}/vtund-start.conf
+}