summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-08-23 18:14:40 +0000
committerMike Frysinger <vapier@gentoo.org>2012-08-23 18:14:40 +0000
commit115ac62b0fa69b6d5b3f07491dda7c57653fde18 (patch)
tree63547e708fee5389c544607104cbf11d98887986 /net-misc/wget
parentold (diff)
downloadgentoo-2-115ac62b0fa69b6d5b3f07491dda7c57653fde18.tar.gz
gentoo-2-115ac62b0fa69b6d5b3f07491dda7c57653fde18.tar.bz2
gentoo-2-115ac62b0fa69b6d5b3f07491dda7c57653fde18.zip
Add USE="pcre uuid zlib" flags to control new deps #432468 by Yuta SATOH.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/wget')
-rw-r--r--net-misc/wget/ChangeLog6
-rw-r--r--net-misc/wget/metadata.xml1
-rw-r--r--net-misc/wget/wget-1.14.ebuild15
3 files changed, 17 insertions, 5 deletions
diff --git a/net-misc/wget/ChangeLog b/net-misc/wget/ChangeLog
index e3571e05f7e2..a48011044401 100644
--- a/net-misc/wget/ChangeLog
+++ b/net-misc/wget/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/wget
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.164 2012/08/06 19:43:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.165 2012/08/23 18:14:40 vapier Exp $
+
+ 23 Aug 2012; Mike Frysinger <vapier@gentoo.org> metadata.xml,
+ wget-1.14.ebuild:
+ Add USE="pcre uuid zlib" flags to control new deps #432468 by Yuta SATOH.
*wget-1.14 (06 Aug 2012)
diff --git a/net-misc/wget/metadata.xml b/net-misc/wget/metadata.xml
index 48906f53c22c..789a0bee1c40 100644
--- a/net-misc/wget/metadata.xml
+++ b/net-misc/wget/metadata.xml
@@ -4,5 +4,6 @@
<herd>base-system</herd>
<use>
<flag name='ntlm'>Enable support for NTLM (Windows-based) authorization</flag>
+ <flag name='uuid'>Generate UUIDs for the WARC (Web ARChive file format) using libuuid; otherwise use a simple RNG (random number generator)</flag>
</use>
</pkgmetadata>
diff --git a/net-misc/wget/wget-1.14.ebuild b/net-misc/wget/wget-1.14.ebuild
index 6d133fd0d15a..b172e7b909e7 100644
--- a/net-misc/wget/wget-1.14.ebuild
+++ b/net-misc/wget/wget-1.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.14.ebuild,v 1.1 2012/08/06 19:43:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.14.ebuild,v 1.2 2012/08/23 18:14:40 vapier Exp $
EAPI="4"
@@ -13,13 +13,16 @@ SRC_URI="mirror://gnu/wget/${P}.tar.xz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug gnutls idn ipv6 nls ntlm +ssl static"
+IUSE="debug gnutls idn ipv6 nls ntlm pcre +ssl static uuid zlib"
LIB_DEPEND="idn? ( net-dns/libidn[static-libs(+)] )
+ pcre? ( dev-libs/libpcre[static-libs(+)] )
ssl? (
gnutls? ( net-libs/gnutls[static-libs(+)] )
!gnutls? ( >=dev-libs/openssl-0.9.6b[static-libs(+)] )
- )"
+ )
+ uuid? ( sys-apps/util-linux[static-libs(+)] )
+ zlib? ( sys-libs/zlib[static-libs(+)] )"
RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
DEPEND="${RDEPEND}
app-arch/xz-utils
@@ -46,6 +49,9 @@ src_configure() {
# the configure script contains a few hacks to workaround openssl
# build limitations. disable those, and use openssl's pkg-config.
eval export ac_cv_lib_{z_compress,dl_{dlopen,shl_load}}=no
+ # some libraries tests lack configure options :( #432468
+ eval export ac_cv_{header_pcre_h,lib_pcre_pcre_compile}=$(usex pcre)
+ eval export ac_cv_{header_uuid_uuid_h,lib_uuid_uuid_generate}=$(usex uuid)
if use static ; then
append-ldflags -static
@@ -61,7 +67,8 @@ src_configure() {
$(use_enable ipv6) \
$(use_enable nls) \
$(use_enable ntlm) \
- $(use_enable debug)
+ $(use_enable debug) \
+ $(use_with zlib)
}
src_install() {