summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-01-28 14:03:21 +0000
committerMike Frysinger <vapier@gentoo.org>2008-01-28 14:03:21 +0000
commit15e6438c2e3b5381e6fa1da9c1db14c959363635 (patch)
treee620a3976a828475fd2bf36acfe93c342fe56147 /net-misc/wget
parentRevision bump, with fixes for multilib, LDFLAGS, crosscompile, ecc. Closes bu... (diff)
downloadgentoo-2-15e6438c2e3b5381e6fa1da9c1db14c959363635.tar.gz
gentoo-2-15e6438c2e3b5381e6fa1da9c1db14c959363635.tar.bz2
gentoo-2-15e6438c2e3b5381e6fa1da9c1db14c959363635.zip
Version bump #207872 by Matthias Vill.
(Portage version: 2.1.4)
Diffstat (limited to 'net-misc/wget')
-rw-r--r--net-misc/wget/ChangeLog10
-rw-r--r--net-misc/wget/files/digest-wget-1.113
-rw-r--r--net-misc/wget/files/wget-1.11-linking.patch96
-rw-r--r--net-misc/wget/wget-1.11.ebuild67
4 files changed, 174 insertions, 2 deletions
diff --git a/net-misc/wget/ChangeLog b/net-misc/wget/ChangeLog
index da888048b65b..60bab15bb3ed 100644
--- a/net-misc/wget/ChangeLog
+++ b/net-misc/wget/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/wget
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.89 2007/12/25 15:17:35 phreak Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.90 2008/01/28 14:03:21 vapier Exp $
+
+*wget-1.11 (28 Jan 2008)
+
+ 28 Jan 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/wget-1.11-linking.patch, +wget-1.11.ebuild:
+ Version bump #207872 by Matthias Vill.
25 Dec 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing seemant from metadata.xml as per #202469. Assigning to
diff --git a/net-misc/wget/files/digest-wget-1.11 b/net-misc/wget/files/digest-wget-1.11
new file mode 100644
index 000000000000..a16062b098a3
--- /dev/null
+++ b/net-misc/wget/files/digest-wget-1.11
@@ -0,0 +1,3 @@
+MD5 d2746aac29f2c0f661ee8e26c6b695ad wget-1.11.tar.bz2 930167
+RMD160 b7f34013e53970299b0d80c22bdcbbf5f93f8eb7 wget-1.11.tar.bz2 930167
+SHA256 3daa33dc67b9096d785253331b6a95db6901caa913f09e2377e1b61f50180d56 wget-1.11.tar.bz2 930167
diff --git a/net-misc/wget/files/wget-1.11-linking.patch b/net-misc/wget/files/wget-1.11-linking.patch
new file mode 100644
index 000000000000..c1e20ebdca96
--- /dev/null
+++ b/net-misc/wget/files/wget-1.11-linking.patch
@@ -0,0 +1,96 @@
+For static linking, we need 2 things:
+1) lib-link.m4 should use -l<libname> and not <full path to lib>, else it tries
+ to link against the .so
+2) lib-link.m4 should add $LIBS after the libs we test for, else newer ld's do
+ not resolve symbols in static libs properly.
+
+Martin Schlemmer <azarah@gentoo.org>
+
+--- configure
++++ configure
+@@ -10304,5 +10304,5 @@
+ if test "X$found_so" != "X"; then
+ if test "$enable_rpath" = no || test "X$found_dir" = "X/usr/lib"; then
+- LIBGNUTLS="${LIBGNUTLS}${LIBGNUTLS:+ }$found_so"
++ LIBGNUTLS="${LIBGNUTLS}${LIBGNUTLS:+ }-l$name"
+ else
+ haveit=
+@@ -10317,8 +10317,8 @@
+ fi
+ if test "$hardcode_direct" = yes; then
+- LIBGNUTLS="${LIBGNUTLS}${LIBGNUTLS:+ }$found_so"
++ LIBGNUTLS="${LIBGNUTLS}${LIBGNUTLS:+ }-l$name"
+ else
+ if test -n "$hardcode_libdir_flag_spec" && test "$hardcode_minus_L" = no; then
+- LIBGNUTLS="${LIBGNUTLS}${LIBGNUTLS:+ }$found_so"
++ LIBGNUTLS="${LIBGNUTLS}${LIBGNUTLS:+ }-l$name"
+ haveit=
+ for x in $rpathdirs; do
+@@ -10352,5 +10352,5 @@
+ fi
+ if test "$hardcode_minus_L" != no; then
+- LIBGNUTLS="${LIBGNUTLS}${LIBGNUTLS:+ }$found_so"
++ LIBGNUTLS="${LIBGNUTLS}${LIBGNUTLS:+ }-l$name"
+ else
+ LIBGNUTLS="${LIBGNUTLS}${LIBGNUTLS:+ }-l$name"
+@@ -10579,5 +10579,5 @@
+
+ ac_save_LIBS="$LIBS"
+- LIBS="$LIBS $LIBGNUTLS"
++ LIBS="$LIBGNUTLS $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+@@ -10957,5 +10957,5 @@
+ if test "X$found_so" != "X"; then
+ if test "$enable_rpath" = no || test "X$found_dir" = "X/usr/lib"; then
+- LIBSSL="${LIBSSL}${LIBSSL:+ }$found_so"
++ LIBSSL="${LIBSSL}${LIBSSL:+ }-l$name"
+ else
+ haveit=
+@@ -10970,8 +10970,8 @@
+ fi
+ if test "$hardcode_direct" = yes; then
+- LIBSSL="${LIBSSL}${LIBSSL:+ }$found_so"
++ LIBSSL="${LIBSSL}${LIBSSL:+ }-l$name"
+ else
+ if test -n "$hardcode_libdir_flag_spec" && test "$hardcode_minus_L" = no; then
+- LIBSSL="${LIBSSL}${LIBSSL:+ }$found_so"
++ LIBSSL="${LIBSSL}${LIBSSL:+ }-l$name"
+ haveit=
+ for x in $rpathdirs; do
+@@ -11005,5 +11005,5 @@
+ fi
+ if test "$hardcode_minus_L" != no; then
+- LIBSSL="${LIBSSL}${LIBSSL:+ }$found_so"
++ LIBSSL="${LIBSSL}${LIBSSL:+ }-l$name"
+ else
+ LIBSSL="${LIBSSL}${LIBSSL:+ }-l$name"
+@@ -11232,5 +11232,5 @@
+
+ ac_save_LIBS="$LIBS"
+- LIBS="$LIBS $LIBSSL"
++ LIBS="$LIBSSL $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+--- src/Makefile.in
++++ src/Makefile.in
+@@ -53,7 +53,7 @@
+ DEFS = @DEFS@ -DSYSTEM_WGETRC=\"$(sysconfdir)/wgetrc\" -DLOCALEDIR=\"$(localedir)\"
+ CFLAGS = @CFLAGS@
+ LDFLAGS = @LDFLAGS@
+-LIBS = @LIBS@ @LIBSSL@ @LIBGNUTLS@
++LIBS = @LIBSSL@ @LIBGNUTLS@ @LIBS@
+ exeext = @EXEEXT@
+
+ INCLUDES = -I. -I$(srcdir)
+--- Makefile.in
++++ Makefile.in
+@@ -58,7 +58,7 @@
+ CFLAGS = @CFLAGS@
+ CPPFLAGS = @CPPFLAGS@
+ DEFS = @DEFS@ -DSYSTEM_WGETRC=\"$(sysconfdir)/wgetrc\" -DLOCALEDIR=\"$(localedir)\"
+-LIBS = @LIBS@ @LIBSSL@ @LIBGNUTLS@
++LIBS = @LIBSSL@ @LIBGNUTLS@ @LIBS@
+ LDFLAGS = @LDFLAGS@
+
+ #
diff --git a/net-misc/wget/wget-1.11.ebuild b/net-misc/wget/wget-1.11.ebuild
new file mode 100644
index 000000000000..f9bf8aa906af
--- /dev/null
+++ b/net-misc/wget/wget-1.11.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.11.ebuild,v 1.1 2008/01/28 14:03:21 vapier Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Network utility to retrieve files from the WWW"
+HOMEPAGE="http://www.gnu.org/software/wget/"
+SRC_URI="mirror://gnu/wget/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="debug ipv6 nls socks5 ssl static"
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )
+ socks5? ( net-proxy/dante )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-linking.patch
+}
+
+src_compile() {
+ # openssl-0.9.8 now builds with -pthread on the BSD's
+ use elibc_FreeBSD && use ssl && append-ldflags -pthread
+
+ use static && append-ldflags -static
+ econf \
+ $(use_with ssl) $(use_enable ssl opie) $(use_enable ssl digest) \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ $(use_with socks5 socks) \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog* MAILING-LIST NEWS README
+ dodoc doc/sample.wgetrc
+
+ use ipv6 && cat "${FILESDIR}"/wgetrc-ipv6 >> "${D}"/etc/wgetrc
+
+ sed -i \
+ -e 's:/usr/local/etc:/etc:g' \
+ "${D}"/etc/wgetrc \
+ "${D}"/usr/share/man/man1/wget.1 \
+ "${D}"/usr/share/info/wget.info
+}
+
+pkg_preinst() {
+ ewarn "The /etc/wget/wgetrc file has been relocated to /etc/wgetrc"
+ if [[ -e ${ROOT}/etc/wget/wgetrc ]] ; then
+ if [[ -e ${ROOT}/etc/wgetrc ]] ; then
+ ewarn "You have both /etc/wget/wgetrc and /etc/wgetrc ... you should delete the former"
+ else
+ einfo "Moving /etc/wget/wgetrc to /etc/wgetrc for you"
+ mv "${ROOT}"/etc/wget/wgetrc "${ROOT}"/etc/wgetrc
+ rmdir "${ROOT}"/etc/wget 2>/dev/null
+ fi
+ fi
+}