summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-01-03 16:49:00 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-01-03 16:49:00 +0000
commit6e9551295d8008aea92598c93ac0059d7cd13a37 (patch)
tree732143096aad9d58f80bcb9163ec8cbb0d9e40de /net-misc/wget
parentzappo (diff)
downloadgentoo-2-6e9551295d8008aea92598c93ac0059d7cd13a37.tar.gz
gentoo-2-6e9551295d8008aea92598c93ac0059d7cd13a37.tar.bz2
gentoo-2-6e9551295d8008aea92598c93ac0059d7cd13a37.zip
new openssl, new openssh rev to build against the new openssl (for emerge
update people -- openssh will refuse to work if openssl has been updated), and new dynamic bash.
Diffstat (limited to 'net-misc/wget')
-rw-r--r--net-misc/wget/wget-1.8.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/net-misc/wget/wget-1.8.ebuild b/net-misc/wget/wget-1.8.ebuild
deleted file mode 100644
index ec4d6547402f..000000000000
--- a/net-misc/wget/wget-1.8.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.8.ebuild,v 1.2 2001/12/17 23:18:51 azarah Exp $
-
-NPVER=20011209
-S=${WORKDIR}/${P}
-DESCRIPTION="Network utility to retrieve files from the WWW"
-SRC_URI="ftp://prep.ai.mit.edu/gnu/wget/${P}.tar.gz
- ftp://gatekeeper.dec.com/pub/GNU/wget/${P}.tar.gz
- http://www.biscom.net/~cade/away/wget-new-percentage/wget-new-percentage-cvs-${NPVER}.tar.gz"
-HOMEPAGE="http://www.cg.tuwien.ac.at/~prikryl/wget.html"
-
-DEPEND="virtual/glibc
- nls? ( sys-devel/gettext )
- ssl? ( >=dev-libs/openssl-0.9.6b )"
-
-RDEPEND="virtual/glibc"
-
-src_unpack() {
- unpack ${P}.tar.gz
- unpack wget-new-percentage-cvs-${NPVER}.tar.gz
- cd ${S}/src
- patch -p0 < ${WORKDIR}/wget-new-percentage/wnp-20011208-2.diff || die
-}
-
-src_compile() {
- local myconf
- use nls || myconf="--disable-nls"
- use ssl && myconf="${myconf} --with-ssl"
- use ssl || myconf="${myconf} --without-ssl --disable-opie --disable-digest"
- [ -z "$DEBUG" ] && myconf="${myconf} --disable-debug"
- use ssl && CFLAGS="${CFLAGS} -I/usr/include/openssl"
- ./configure --prefix=/usr --sysconfdir=/etc/wget \
- --infodir=/usr/share/info --mandir=usr/share/man $myconf || die
- if use static; then
- make LDFLAGS="--static" || die
- else
- make || die
- fi
-}
-
-src_install() {
- if use build || use bootcd; then
- insinto /usr
- dobin ${S}/src/wget
- return
- fi
- make prefix=${D}/usr sysconfdir=${D}/etc/wget \
- mandir=${D}/usr/share/man infodir=${D}/usr/share/info install || die
- dodoc AUTHORS COPYING ChangeLog MACHINES MAILING-LIST NEWS README TODO
- dodoc doc/sample.wgetrc
-}